Skip to content

Commit

Permalink
dev-libs/mongo-cxx-driver: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
ultrabug committed Sep 17, 2015
1 parent 62a2956 commit 8757967
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/mongo-cxx-driver/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST legacy-0.0-26compat-2.6.7.tar.gz 1512331 SHA256 a77165e7ad0c1ff8e246adc5e60b9ebb18eec7f0cc18682a33498c12d7cab0ba SHA512 edf13d5b7802c3b2e9772f08949fd0c412f2cd25ec6d05ff4e8c1f25c3e3506da6ebbd7b017ceec5478585c84e9fa44c66a5094ad3e7a7373187d3fb3c1c1222 WHIRLPOOL f64cfded6a02e241b4b59b3394bcec1cf7df4bc175aba261893d8b24106760eb3899b85b520c5f9af9d929d93ad29ed6d2ef1e11d662b7a331f143f2b88d637c
DIST legacy-1.0.0.tar.gz 1569156 SHA256 1350dfdcdb3969e472bf83eec08378f771196c47e70b474e7349c816acb0cca4 SHA512 e161972715fe45b777ee3d9c7e788ee3a808af789e2c1248af1dde3d3f3936e29f619e039f53210cdd3fc6a6bd8a02c101facf49c61759c6f108d25c5c03b59b WHIRLPOOL 7d5c8fc6d011f219652bc6cc5a8dd59fac899a95ca3bde22fc76a2505cb7393a1762681f77cfc9295028a427e875c0155ee7046fa9d1c2e4e52d340a19e2c925
DIST legacy-1.0.5.tar.gz 1573929 SHA256 7e83927285f294ef5b98c4bad022c3dc8e0af5628595abfb676f3d027a8bbebe SHA512 e904d73f78ffbc1ce18ffa11dd7e3dddd67c730b6e79bace0e48c0be4e8ffd7b5fe12e1373e42ad941d8fc239ef031a47d39ff04aaf3f0a5ecf88115c816bc70 WHIRLPOOL 8512c9a694288d71d0ad3383457a021a905d384c29c1cdbe426adf3aee9d59406518657d263f9b7d6dcb943ad1268dfd1ac007318139ac409254039a29d62c7c
69 changes: 69 additions & 0 deletions dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
SCONS_MIN_VERSION="2.3.0"

inherit eutils flag-o-matic multilib scons-utils

DESCRIPTION="C++ Driver for MongoDB"
HOMEPAGE="https://github.com/mongodb/mongo-cxx-driver"
SRC_URI="https://github.com/mongodb/${PN}/archive/legacy-${PV}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug sasl ssl static-libs"

RDEPEND=">=dev-libs/boost-1.50[threads(+)]
sasl? ( dev-libs/cyrus-sasl )
ssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}"

# Maintainer notes
# TODO: enable test in IUSE with
# test? ( >=dev-cpp/gtest-1.7.0 dev-db/mongodb )

DOCS=( README.md )

S="${WORKDIR}/${PN}-legacy-${PV}"

pkg_setup() {
scons_opts="--variant-dir=build --cc=$(tc-getCC) --cxx=$(tc-getCXX)"
scons_opts+=" --disable-warnings-as-errors --sharedclient"

if use debug; then
scons_opts+=" --dbg=on"
fi

if use prefix; then
scons_opts+=" --cpppath=${EPREFIX}/usr/include"
scons_opts+=" --libpath=${EPREFIX}/usr/$(get_libdir)"
fi

if use sasl; then
scons_opts+=" --use-sasl-client"
fi

if use ssl; then
scons_opts+=" --ssl"
fi
}

src_prepare() {
epatch "${FILESDIR}/${PN}-1.0.0-fix-scons.patch"

# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
if ! use debug; then
filter-flags '-m*'
filter-flags '-O?'
fi
}

src_install() {
escons ${scons_opts} install --prefix="${ED}"/usr

use static-libs || find "${D}" -name '*.a' -delete
}

0 comments on commit 8757967

Please sign in to comment.