Skip to content

Commit

Permalink
dev-db/pgadmin3: Drop obsolete pgslot check, drop bogus html mimetype
Browse files Browse the repository at this point in the history
pgadmin3 is not a webbrowser, and opening html is unsuccessful.
Dropped unused eclasses.
Bumped to EAPI 6.

Gentoo-bug: 626812
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
a17r committed Aug 11, 2017
1 parent ee974c1 commit 878686c
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
15 changes: 15 additions & 0 deletions dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
diff -Naruw a/pkg/pgadmin3.desktop b/pkg/pgadmin3.desktop
--- a/pkg/pgadmin3.desktop 2013-02-22 12:21:19.000000000 -0500
+++ b/pkg/pgadmin3.desktop 2015-02-04 15:36:34.845312953 -0500
@@ -2,9 +2,8 @@
Encoding=UTF-8
Name=pgAdmin III
Exec=/usr/bin/pgadmin3
-Icon=/usr/share/pgadmin3/pgAdmin3.png
+Icon=/usr/share/pixmaps/pgadmin3.png
Type=Application
-Categories=Application;Development;
-MimeType=text/html
+Categories=Development;
DocPath=/usr/share/pgadmin3/docs/en_US/index.html
Comment=PostgreSQL Tools
45 changes: 45 additions & 0 deletions dev-db/pgadmin3/pgadmin3-1.22.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit eutils wxwidgets

DESCRIPTION="wxWidgets GUI for PostgreSQL"
HOMEPAGE="https://www.pgadmin.org/"
SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"

LICENSE="POSTGRESQL"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
SLOT="0"
IUSE="debug +databasedesigner"

DEPEND="
>=dev-db/postgresql-8.4.0:=
>=dev-libs/libxml2-2.6.18
>=dev-libs/libxslt-1.1
x11-libs/wxGTK:3.0=[X]"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${PN}-desktop-r1.patch" )

src_configure() {
WX_GTK_VER="3.0"

setup-wxwidgets

econf --with-wx-version=${WX_GTK_VER} \
$(use_enable debug) \
$(use_enable databasedesigner)
}

src_install() {
default

newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png

domenu "${S}/pkg/pgadmin3.desktop"

# Fixing world-writable files
fperms -R go-w /usr/share
}

0 comments on commit 878686c

Please sign in to comment.