Skip to content

Commit

Permalink
media-video/mkvtoolnix: Bump to 8.5.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
aballier committed Oct 24, 2015
1 parent e68a0be commit 879de8c
Show file tree
Hide file tree
Showing 2 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/mkvtoolnix/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mkvtoolnix-8.2.0.tar.xz 5856988 SHA256 eb6d3d7a0254bb4326dccc99834188017831
DIST mkvtoolnix-8.3.0.tar.xz 5863384 SHA256 87bd82222995d35c310a426ed43e0b27cbfefa0caadcbcca8296787314affc37 SHA512 fb3ac11480c20ae360fef9081991876ef2d7a717f24ec631bb8482ee7d22f79164aafeaf561dee503f1c0a83fe3ed6db319b420c34d638450aada762e6eb00c0 WHIRLPOOL b3cd3f4785c891c75eac3754136aa0b709ff0e784eea6d0e915478eea6fbdbe7132c56a997a007ba6d690649b6caaae46a8b45ae055aab7ae557486d99aab417
DIST mkvtoolnix-8.4.0.tar.xz 3234284 SHA256 f6a5506d14a0b16abb3765d6f78cded0267e01096926b30e8f72df9d30aaf878 SHA512 ab9ab49baf06a8ef713872a09c58fdb1560628dbe3b2b661d809972f56a36c751a390a78ae260624510963b92e177d090088030bb96f9ab9e96e1a372772d22f WHIRLPOOL 811a0466413bdba84959c5ae84d637aba4371018ee3deed70d65f24472c0bf6a714003574efb4e4dcdc3bfb1b3c48595a347ab0bcdd935a9b49e2f1ab4c36c58
DIST mkvtoolnix-8.5.0.tar.xz 3280556 SHA256 ec3f4566dbc324c3bda7314c70d87046136664d72888945f9fdb8d129e1e05a3 SHA512 18f1bac6ba46d3ec3235d4b8ec8fc9bd0b5993344205172f254d3ca8aa7afdb399d81d9e7d8b24fe004661c83757e82b4874865acaa231e7721b1d8382adfdd3 WHIRLPOOL 453a55adf80fca61be3b102c39ccd48aa057983e8e3d4aea563ffe67ad86ded6889f0e1926e600556d43c4fccacdc79facd6438b8dccb9591a6e86de2919e8b1
DIST mkvtoolnix-8.5.1.tar.xz 3288800 SHA256 db9ae151ef236afac190c0137d8d4df4e43c105dbd298e3913b5afae1fdd5b43 SHA512 cf2d254df0851f4450a59b187ec9c4d293c1128d062ab12d098bc77ea4c2213a2d5b78989ee170789aa2bac9c23a531ed7b87f6d7206f03ee73a0821c021fffa WHIRLPOOL 7a7858fd6f22c9bf812cb28528f7612a3fb7a7056889534e24a45fe1bc88e69c9c6220088cd45e66f2072150b876af7eeaa417b2f7f02dff19c1ea4d03853ba9
116 changes: 116 additions & 0 deletions media-video/mkvtoolnix/mkvtoolnix-8.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,116 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
WX_GTK_VER="3.0"
inherit eutils multilib toolchain-funcs versionator multiprocessing autotools

DESCRIPTION="Tools to create, alter, and inspect Matroska files"
HOMEPAGE="http://www.bunkus.org/videotools/mkvtoolnix"
SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="curl debug pch test qt5"

ruby_atom() {
local ruby_slot=${1/ruby/}
ruby_slot="${ruby_slot:0:1}.${ruby_slot:1:2}"
echo "dev-lang/ruby:${ruby_slot}"
}

# hacks to avoid using the ruby eclasses since this requires something similar
# to the python-any-r1 eclass for ruby which currently doesn't exist
RUBY_IMPLS=( ruby22 ruby21 ruby20 )
RUBY_BDEPS="$(for ruby_impl in "${RUBY_IMPLS[@]}"; do
echo "( $(ruby_atom ${ruby_impl}) virtual/rubygems[ruby_targets_${ruby_impl}] )"; done)"

RDEPEND="
>=dev-libs/boost-1.46.0:=
>=dev-libs/libebml-1.3.3:=
dev-libs/pugixml
media-libs/flac
>=media-libs/libmatroska-1.4.4:=
media-libs/libogg
media-libs/libvorbis
sys-apps/file
sys-libs/zlib
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
)
"
DEPEND="${RDEPEND}
|| ( ${RUBY_BDEPS} )
sys-devel/gettext
virtual/pkgconfig
test? ( dev-cpp/gtest )
"

pkg_pretend() {
# https://bugs.gentoo.org/419257
local ver=4.6
local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
if ! version_is_at_least ${ver} $(gcc-version); then
eerror ${msg}
die ${msg}
fi
}

src_prepare() {
local ruby_impl
for ruby_impl in "${RUBY_IMPLS[@]}"; do
if has_version "$(ruby_atom ${ruby_impl})"; then
export RUBY=${ruby_impl}
break
fi
done
[[ -z ${RUBY} ]] && die "No available ruby implementations to build with"

epatch_user
eautoreconf
}

src_configure() {
local myconf

if use qt5 ; then
# ac/qt5.m4 finds default Qt version set by qtchooser, bug #532600
myconf+=(
--with-moc=/usr/$(get_libdir)/qt5/bin/moc
--with-uic=/usr/$(get_libdir)/qt5/bin/uic
--with-rcc=/usr/$(get_libdir)/qt5/bin/rcc
)
fi

econf \
$(use_enable debug) \
$(use_enable qt5 qt) \
$(use_with curl) \
$(usex pch "" --disable-precompiled-headers) \
"${myconf[@]}" \
--disable-optimization \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--with-boost="${EPREFIX}"/usr \
--with-boost-libdir="${EPREFIX}"/usr/$(get_libdir)
}

src_compile() {
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) || die
}

src_test() {
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) tests:unit || die
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) tests:run_unit || die
}

src_install() {
DESTDIR="${D}" "${RUBY}" ./drake -j$(makeopts_jobs) install || die

dodoc AUTHORS ChangeLog README.md
doman doc/man/*.1
}

0 comments on commit 879de8c

Please sign in to comment.