forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.23
- Loading branch information
Showing
2 changed files
with
147 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST darktable-1.6.6.tar.xz 3097760 SHA256 f85e4b8219677eba34f5a41e1a0784cc6ec06576326a99f04e460a4f41fd21a5 SHA512 96f0371c0044c40e22c0cf729076032e487fd0af30d27d28ed42ea8bcc3e29971b09d9f628e3b734147265b02fa0243217e687a8e6237b2c0c14b9db330df09c WHIRLPOOL d04e77777fdcfdd5933d7c915375b7418647918af7ef4a5b19703724a113ee5fdfe8db6bb839e9638eecca6c0c9c7542088d12b45634fca57d3b453fa120d7f6 | ||
DIST darktable-1.6.7.tar.xz 3113804 SHA256 a75073b49df0a30cd2686624feeb6210bc083bc37112ae6e045f8523db4c4c98 SHA512 6fadc62dc9ac0dd8b11d7d1a1ef1c23bd07abb7e66159d0bd26dd4bb9b36162e390c4f1559dd7c433c18dd55ebff98157234137567e12467995f7f26915b0ea0 WHIRLPOOL 69228b8c734b53b17483ae453df8cd73caf78b5fcbcee6b5cae5f8396c5dd1038ba6036048ab50e15c85cc35adeac0bd49de03f3acb30dbcb822fae2e02b73bf | ||
DIST darktable-1.6.8.tar.xz 3118776 SHA256 b676f81bd8cc661a8f76e03ad449da4444f770b6bec3e9accf013c636f690905 SHA512 8811e8f931299b4fb86d3611696061404253985328178231902e749dc55b4f02d5193ce2e2eaf8c6351f9f7374870bcbdc55b145dfb75cd7669556494b457bbb WHIRLPOOL acfe83ebcc697904246a11583d0ff521365639d2006629e76123db93c35ea7ed39cbd7fed54470e5ed0e27cc6b28d70559738d68f36c31be63391c539c5323cb | ||
DIST darktable-1.6.9.tar.xz 3124940 SHA256 0f721e9d298a9407f6c0325d9c95b9dc37fa60f3b6a2f2e3b5675ff97c423173 SHA512 c0e8e83cf1cb10b663e5486f2bdde3cba2db5dbaabacd260999be1173c67618023e785e9087a517959835459f8d54c245d190f63a9422a17f3472f5aa316d492 WHIRLPOOL 0a2446ff7f98cf0297c5948009414dbf828f1cc60a9fb117f1e110f454dd68df611310bd9ff287f1f2345a8ee9818c1918b4ac7791aeb094c01e71a1ecdfce9d | ||
DIST darktable-usermanual-1.6.0.pdf 12827069 SHA256 f5c46dbf0a2dd2d391f92555abdefe735c6362e51a755b296d71779492b7e945 SHA512 39ee8c1b4f23883025750416d9d1f73d1dfbec0e6ac3eeef0f15778ced66a373c00b0a46cb3a54b1cfd6e04313313f63e8e3cd3d0cbea011acaa07a725d0ab02 WHIRLPOOL 49a234e57c14d23ccb85eadf2ad03c52eae7f90b0371dce025c04019a7a5cca41858084f735fe0965f93958ab83601571ab3e33acd27c2bcbd381bb0c9da4794 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,146 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit cmake-utils flag-o-matic toolchain-funcs gnome2-utils fdo-mime pax-utils eutils | ||
|
||
DOC_PV="1.6.0" | ||
|
||
DESCRIPTION="A virtual lighttable and darkroom for photographers" | ||
HOMEPAGE="http://www.darktable.org/" | ||
SRC_URI="https://github.com/darktable-org/${PN}/releases/download/release-${PV}/${P}.tar.xz | ||
doc? ( https://github.com/darktable-org/${PN}/releases/download/release-${DOC_PV}/${PN}-usermanual.pdf -> ${PN}-usermanual-${DOC_PV}.pdf )" | ||
|
||
LICENSE="GPL-3 CC-BY-3.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
LANGS=" ca cs da de el es fr it ja nl pl pt_BR pt_PT ru sq sv uk" | ||
# TODO add lua once dev-lang/lua-5.2 is unmasked | ||
IUSE="colord cpu_flags_x86_sse3 doc flickr geo gphoto2 graphicsmagick jpeg2k kde libsecret | ||
nls opencl openmp openexr pax_kernel +rawspeed +slideshow +squish web-services webp | ||
${LANGS// / linguas_}" | ||
|
||
# sse3 support is required to build darktable | ||
REQUIRED_USE="cpu_flags_x86_sse3" | ||
|
||
CDEPEND=" | ||
dev-db/sqlite:3 | ||
>=dev-libs/glib-2.28:2 | ||
dev-libs/libxml2:2 | ||
gnome-base/librsvg:2 | ||
media-gfx/exiv2:0=[xmp] | ||
media-libs/lcms:2 | ||
>=media-libs/lensfun-0.2.3 | ||
media-libs/libpng:0= | ||
media-libs/tiff:0 | ||
net-misc/curl | ||
virtual/jpeg:0 | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/gtk+:2 | ||
x11-libs/pango | ||
colord? ( x11-misc/colord:0= ) | ||
flickr? ( media-libs/flickcurl ) | ||
geo? ( net-libs/libsoup:2.4 ) | ||
gphoto2? ( media-libs/libgphoto2:= ) | ||
graphicsmagick? ( media-gfx/graphicsmagick ) | ||
jpeg2k? ( media-libs/openjpeg:0 ) | ||
libsecret? ( | ||
>=app-crypt/libsecret-0.18 | ||
dev-libs/json-glib | ||
) | ||
opencl? ( virtual/opencl ) | ||
openexr? ( media-libs/openexr:0= ) | ||
slideshow? ( | ||
media-libs/libsdl | ||
virtual/glu | ||
virtual/opengl | ||
) | ||
web-services? ( dev-libs/json-glib ) | ||
webp? ( media-libs/libwebp:0= )" | ||
RDEPEND="${CDEPEND} | ||
x11-themes/gtk-engines:2 | ||
kde? ( kde-apps/kwalletd:4 )" | ||
DEPEND="${CDEPEND} | ||
dev-util/intltool | ||
virtual/pkgconfig | ||
nls? ( sys-devel/gettext )" | ||
|
||
pkg_pretend() { | ||
if use openmp ; then | ||
tc-has-openmp || die "Please switch to an openmp compatible compiler" | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
use cpu_flags_x86_sse3 && append-flags -msse3 | ||
|
||
sed -e "s:\(/share/doc/\)darktable:\1${PF}:" \ | ||
-e "s:\(\${SHARE_INSTALL}/doc/\)darktable:\1${PF}:" \ | ||
-e "s:LICENSE::" \ | ||
-i doc/CMakeLists.txt || die | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_use colord COLORD) | ||
$(cmake-utils_use_use flickr FLICKR) | ||
$(cmake-utils_use_use geo GEO) | ||
$(cmake-utils_use_use gphoto2 CAMERA_SUPPORT) | ||
$(cmake-utils_use_use graphicsmagick GRAPHICSMAGICK) | ||
$(cmake-utils_use_use jpeg2k OPENJPEG) | ||
$(cmake-utils_use_use kde KWALLET) | ||
$(cmake-utils_use_use libsecret LIBSECRET) | ||
$(cmake-utils_use_use libsecret GLIBJSON) | ||
$(cmake-utils_use_use nls NLS) | ||
$(cmake-utils_use_use opencl OPENCL) | ||
$(cmake-utils_use_use openexr OPENEXR) | ||
$(cmake-utils_use_use openmp OPENMP) | ||
$(cmake-utils_use !rawspeed DONT_USE_RAWSPEED) | ||
$(cmake-utils_use_use squish SQUISH) | ||
$(cmake-utils_use_build slideshow SLIDESHOW) | ||
$(cmake-utils_use_use web-services GLIBJSON) | ||
$(cmake-utils_use_use webp WEBP) | ||
-DUSE_LUA=OFF | ||
-DCUSTOM_CFLAGS=ON | ||
-DINSTALL_IOP_EXPERIMENTAL=ON | ||
-DINSTALL_IOP_LEGACY=ON | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
use doc && dodoc "${DISTDIR}"/${PN}-usermanual-${DOC_PV}.pdf | ||
|
||
for lang in ${LANGS} ; do | ||
use linguas_${lang} || rm -r "${ED}"/usr/share/locale/${lang} | ||
done | ||
|
||
if use pax_kernel && use opencl ; then | ||
pax-mark Cm "${ED}"/usr/bin/${PN} || die | ||
eqawarn "USE=pax_kernel is set meaning that ${PN} will be run" | ||
eqawarn "under a PaX enabled kernel. To do so, the ${PN} binary" | ||
eqawarn "must be modified and this *may* lead to breakage! If" | ||
eqawarn "you suspect that ${PN} is broken by this modification," | ||
eqawarn "please open a bug." | ||
fi | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_icon_cache_update | ||
fdo-mime_desktop_database_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
fdo-mime_desktop_database_update | ||
} |