Skip to content

Commit

Permalink
dev-util/debhelper: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Jeroen Roovers committed Jun 27, 2017
1 parent 5859e73 commit 87cbb7a
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/debhelper/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST debhelper_10.3.tar.xz 398764 SHA256 d17c6d1d672113cc869b079015517034516238ec83c447e3be39dd9f10ebf32c SHA512 795c53f966a43e5e9abdd28de121fba71bb07694b87b3dca7a0dd2b395655865397f5d4f0e6e2990638a1fcf7cad8cb75d2b30b803d5a9056fdb1e8604845591 WHIRLPOOL 9bc19c32b9ecbda16b610fcf0dea96835a9c159fe86c1b80cce7370ec17ce1d6e442b746033b2202c06e174369f73eee6d72c986a21cb398328093651068137b
DIST debhelper_10.4.tar.xz 399940 SHA256 c57f2813d84a5372e9aea6dca663cd4a04837adc0f2625114d172bcd1fa543b2 SHA512 c329202d1e9c8506d50028d5b7559d22277330c1f7c776f04891bf45ea52aec7354e9fdcd0a6e8f2c3b47a13ebc244295fe856d91ca8c98a635b5b7577eaf785 WHIRLPOOL e085453a54d511ec6b11f0dd5275a6f31e74b5230de6c7efb5fac9f432e6746429792b4d4c8b134dbbc9377ece659dbf0198a0cbe209056dc979eec4defa3280
DIST debhelper_10.5.tar.xz 402388 SHA256 9f551ddef6d8a3fdd87b9bda7bc1c6c9bc1d9d33e9fb906ca5429071ce85cd3e SHA512 f434eb03b2edda41aaca83aa5b08398daa1c233486d3098013471c9f4b0b58f5d883f023b4d20b07d6a700a778052e609aac328d4813fac09183a42b57d0bd8a WHIRLPOOL cd71543b752d766e04f55729318ebbbdcbe14df4a5b4e288c27d8b862ffff3777aa2662b187a5a2924f3acaf817c56fe1589fe6dd51f51daf64d3336ab5bc974
DIST debhelper_9.20150101.tar.gz 545089 SHA256 fd8d81d71d1bb0ba4b58c517465551231dd60811b98c867e4344bc55ec6a45f2 SHA512 62c85f751627cf0bdac392c6e8c5298995030962b7753047414e740b3767d722c209329c9f0c3c07c94e82bbb7250c163ce49b681e268a0decdbd19b72ea132a WHIRLPOOL 31315544c3ee695a53ef2310ad69e59c68fb0b73399305b9fe57ceb7b01faab72995e01aed270300dd0fbaed2686a5b565a8a08cfc31c720c5baa2a6c475ac4e
DIST debhelper_9.20160814.tar.xz 344328 SHA256 2834a7c1dbeafd9402ea68948c815dab19d903503c45fd70e676269fccd359c0 SHA512 63072ba35ec8c62ee4c4d44833712925264c808a91f1522ef6a73377f2da3d11b285a21ad39158fd44693c801916189261186c8c7b28096719328a81a0a65f62 WHIRLPOOL 334f0aa8075896ec13a061b9841adb5f2b7c5fa6996b507785f50389c86c48e3c89a84ff1049ae7d7cbe4876b649010f892f54f1074ecafd76061bf0588e65d6
73 changes: 73 additions & 0 deletions dev-util/debhelper/debhelper-10.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils toolchain-funcs

DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules"
HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html"
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
IUSE="test"
DH_LINGUAS=( de es fr )
IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"

NLS_DEPEND=$(
printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
)

RDEPEND="
>=dev-lang/perl-5.10:=
>=app-arch/dpkg-1.17
dev-perl/TimeDate
virtual/perl-Getopt-Long
"
DEPEND="
${RDEPEND}
${NLS_DEPEND}
test? (
dev-perl/Test-Pod
sys-apps/fakeroot
)
"

S=${WORKDIR}/${PN}

src_compile() {
tc-export CC

local LANGS="" USE_NLS=no lingua
for lingua in ${DH_LINGUAS[@]}; do
if use linguas_${lingua}; then
LANGS+=" ${lingua}"
USE_NLS=yes
fi
done

emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
}

src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
dodoc doc/* debian/changelog
docinto examples
dodoc examples/*
local lingua
for manfile in *.1 *.7 ; do
for lingua in ${DH_LINGUAS[@]}; do
case ${manfile} in
*.${lingua}.?)
use linguas_${lingua} \
&& cp ${manfile} "${T}"/${manfile/.${lingua}/} \
&& doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
;;
*)
doman ${manfile}
;;
esac
done
done
}

0 comments on commit 87cbb7a

Please sign in to comment.