Skip to content

Commit

Permalink
dev-python/pygpgme: Cleanup src_prepare
Browse files Browse the repository at this point in the history
The sed for tests is pointless since we don't run the tests.
The sed for gpgme.h is better handled by calling gpgme-config.

Package-Manager: portage-2.2.27_p49
  • Loading branch information
floppym committed Jan 23, 2016
1 parent b620476 commit 87d3807
Showing 1 changed file with 4 additions and 12 deletions.
16 changes: 4 additions & 12 deletions dev-python/pygpgme/pygpgme-0.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1
inherit distutils-r1 flag-o-matic

DESCRIPTION="A Python wrapper for the GPGME library"
HOMEPAGE="https://launchpad.net/pygpgme"
Expand All @@ -20,14 +20,6 @@ IUSE=""
DEPEND="app-crypt/gpgme"
RDEPEND="${DEPEND}"

python_prepare_all() {
sed \
-e 's/#include <gpgme\.h>/#include <gpgme\/gpgme\.h>/' \
-i "${S}/src/pygpgme.h" || die
sed \
-e 's/suite.addTest(tests.test_sign_verify.test_suite())/#\0/' \
-e 's/suite.addTest(tests.test_encrypt_decrypt.test_suite())/#\0/' \
-e 's/suite.addTest(tests.test_passphrase.test_suite())/#\0/' \
-i "${S}/tests/__init__.py" || die
distutils-r1_python_prepare_all
python_configure_all() {
append-cflags $(gpgme-config --cflags)
}

0 comments on commit 87d3807

Please sign in to comment.