forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-office/calligra: Fix build with >=app-text/poppler-24.05
Thanks-to: Attila Tóth Closes: https://bugs.gentoo.org/933490 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
42 changes: 42 additions & 0 deletions
42
app-office/calligra/files/calligra-3.2.1-poppler-24.05.0.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
diff '--color=auto' -urNp calligra-3.2.1-orig/CMakeLists.txt calligra-3.2.1-dwok/CMakeLists.txt | ||
--- calligra-3.2.1-orig/CMakeLists.txt 2024-06-05 13:06:55.730007129 +0200 | ||
+++ calligra-3.2.1-dwok/CMakeLists.txt 2024-06-05 13:08:00.587082911 +0200 | ||
@@ -104,7 +104,7 @@ if(NOT DEFINED RELEASE_BUILD) | ||
endif() | ||
message(STATUS "Release build: ${RELEASE_BUILD}") | ||
|
||
-set (CMAKE_CXX_STANDARD 17) # required for >=poppler-22.01 | ||
+set (CMAKE_CXX_STANDARD 20) # required for >=poppler-22.04 | ||
|
||
############ | ||
############# | ||
diff '--color=auto' -urNp calligra-3.2.1-orig/libs/pigment/lut.h calligra-3.2.1-dwok/libs/pigment/lut.h | ||
--- calligra-3.2.1-orig/libs/pigment/lut.h 2024-06-05 13:06:55.922010313 +0200 | ||
+++ calligra-3.2.1-dwok/libs/pigment/lut.h 2024-06-05 13:09:24.460474108 +0200 | ||
@@ -143,7 +143,7 @@ typedef uint32_t lut_uint32; | ||
template<> \ | ||
class LutKey<_INT_TYPE_> { \ | ||
public: \ | ||
- LutKey<_INT_TYPE_>(_INT_TYPE_ min, _INT_TYPE_ max) : m_min(min), m_max(max) \ | ||
+ LutKey(_INT_TYPE_ min, _INT_TYPE_ max) : m_min(min), m_max(max) \ | ||
{ \ | ||
} \ | ||
public: \ | ||
@@ -183,7 +183,7 @@ PARTIAL_LUT_INT_SPECIALIZATION(lut_uint3 | ||
template<> \ | ||
class FullLutKey<_INT_TYPE_> { \ | ||
public: \ | ||
- FullLutKey<_INT_TYPE_>() \ | ||
+ FullLutKey() \ | ||
{ \ | ||
} \ | ||
public: \ | ||
@@ -233,7 +233,7 @@ class LutKey<float> { | ||
float f; | ||
}; | ||
public: | ||
- LutKey<float>(float min, float max, float precision) : m_min(min), m_max(max), m_precision(precision) | ||
+ LutKey(float min, float max, float precision) : m_min(min), m_max(max), m_precision(precision) | ||
{ | ||
// Those values where computed using the test_linear and setting the shift and then using | ||
// the standard deviation. |