forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Gentoo-Bug: 626768 Package-Manager: Portage-2.3.6, Repoman-2.3.1
- Loading branch information
Showing
3 changed files
with
186 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ibus-1.5.12.tar.gz 2190284 SHA256 e24da95995f4aca5b96359eaba709487dc5ad4c732e9b01b9bcf9fb34be2442c SHA512 a443bf0d1b71a52c18e7d13a0c69f38c48f6924cfb1669912880b87be1bf41bcb7d8d6252aafd6799e43d41c081fd94cf334fd836a0505c93a4e5c5b68241c81 WHIRLPOOL 82354fc5006a0abe4cb431dda90a67dc1b775f0bac521b481eaeb7acd167ba6179cad14045c5141c57618845589094613bc489357ee8bf550f131ecfb1bf8293 | ||
DIST ibus-1.5.15.tar.gz 2259352 SHA256 41f7baad6f3aac0cdfaebef674a8731ae47950f140edfbeefebaeed78c93e385 SHA512 4e588acf2ca0172b365630dcfe2d9062e7583e50a44d435ec05c8e3976c6caf54c4708733f1f7dce5ef7724254469ee5c7ab3b086f0cbea18775c894863b0c3e WHIRLPOOL ba40cfe9f398963ce6122d4beabdccaa94c6ac7a7463fe3cea3dc967b19a4702996fd132372a167a02956e1340b4278c61ea19ed781203db33a4651ddd3824b1 | ||
DIST ibus-1.5.16.tar.gz 2375719 SHA256 36b57bfbe4f92e3281fb535cae65794b6f25164b2a3288e73e6d06b4a409fe1e SHA512 494ead69cf9c0111fd25fd1de27e796d89db4f08443afa1ec469f638469b25d8b19a59ea7ab0db0f3a130b9a89b3f2819667099ba38fc973d6efc61b367ce237 WHIRLPOOL 08fdab9971f2723b5cbacd0a5f3c6ab6c13ff8111abe2bdceab26113f304b20af38403313fa9819838e37805473489d629d3530ba1fc9739f2db991a85b89de7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,184 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} ) | ||
VALA_USE_DEPEND="vapigen" | ||
|
||
inherit autotools bash-completion-r1 gnome2-utils ltprune python-r1 vala virtualx | ||
|
||
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS" | ||
HOMEPAGE="https://github.com/ibus/ibus/wiki" | ||
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+emoji gconf +gtk +gtk2 +introspection kde +libnotify nls +python test vala wayland +X" | ||
REQUIRED_USE="emoji? ( gtk ) | ||
kde? ( gtk ) | ||
libnotify? ( gtk ) | ||
python? ( | ||
${PYTHON_REQUIRED_USE} | ||
gtk | ||
introspection | ||
) | ||
test? ( gtk ) | ||
vala? ( introspection )" | ||
|
||
CDEPEND="app-text/iso-codes | ||
dev-libs/glib:2 | ||
gnome-base/dconf | ||
gnome-base/librsvg:2 | ||
sys-apps/dbus[X?] | ||
gconf? ( gnome-base/gconf:2 ) | ||
gtk? ( | ||
x11-libs/gtk+:3 | ||
x11-libs/libX11 | ||
x11-libs/libXi | ||
gtk2? ( x11-libs/gtk+:2 ) | ||
) | ||
introspection? ( dev-libs/gobject-introspection ) | ||
kde? ( dev-qt/qtgui:5 ) | ||
libnotify? ( x11-libs/libnotify ) | ||
nls? ( virtual/libintl ) | ||
python? ( | ||
${PYTHON_DEPS} | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
) | ||
wayland? ( | ||
dev-libs/wayland | ||
x11-libs/libxkbcommon | ||
) | ||
X? ( | ||
|| ( | ||
x11-libs/gtk+:3 | ||
x11-libs/gtk+:2 | ||
) | ||
x11-libs/libX11 | ||
)" | ||
RDEPEND="${CDEPEND} | ||
python? ( | ||
gtk? ( | ||
x11-libs/gtk+:3[introspection] | ||
) | ||
)" | ||
DEPEND="${CDEPEND} | ||
$(vala_depend) | ||
dev-util/intltool | ||
virtual/pkgconfig | ||
emoji? ( | ||
app-i18n/unicode-cldr | ||
app-i18n/unicode-emoji | ||
) | ||
nls? ( sys-devel/gettext )" | ||
|
||
src_prepare() { | ||
vala_src_prepare --ignore-use | ||
if ! use emoji; then | ||
touch \ | ||
tools/main.vala \ | ||
ui/gtk3/panel.vala | ||
fi | ||
if ! use kde; then | ||
touch ui/gtk3/panel.vala | ||
fi | ||
if ! use libnotify; then | ||
touch ui/gtk3/panel.vala | ||
fi | ||
# for multiple Python implementations | ||
sed -i "s/^\(PYGOBJECT_DIR =\).*/\1/" bindings/Makefile.am | ||
# fix for parallel install | ||
sed -i \ | ||
-e "/^py2_compile/,/^$/d" \ | ||
-e "/^install-data-hook/,/^$/d" \ | ||
bindings/pygobject/Makefile.am | ||
# require user interaction | ||
sed -i "/^TESTS += ibus-compose/d" src/tests/Makefile.am | ||
|
||
sed -i "/^bash_completion/d" tools/Makefile.am | ||
|
||
default | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
local unicodedir="${EPREFIX}"/usr/share/unicode | ||
local python_conf=() | ||
if use python; then | ||
python_setup | ||
python_conf+=( | ||
$(use_enable gtk setup) | ||
--with-python=${EPYTHON} | ||
) | ||
else | ||
python_conf+=( --disable-setup ) | ||
fi | ||
|
||
econf \ | ||
$(use_enable emoji emoji-dict) \ | ||
$(use_with emoji unicode-emoji-dir "${unicodedir}"/emoji) \ | ||
$(use_with emoji emoji-annotation-dir "${unicodedir}"/cldr/common/annotations) \ | ||
$(use_enable gconf) \ | ||
$(use_enable gtk gtk3) \ | ||
$(use_enable gtk ui) \ | ||
$(use_enable gtk2) \ | ||
$(use_enable introspection) \ | ||
$(use_enable kde appindicator) \ | ||
$(use_enable libnotify) \ | ||
$(use_enable nls) \ | ||
$(use_enable test tests) \ | ||
$(use_enable vala) \ | ||
$(use_enable wayland) \ | ||
$(use_enable X xim) \ | ||
"${python_conf[@]}" | ||
} | ||
|
||
src_test() { | ||
unset DBUS_SESSION_BUS_ADDRESS | ||
virtx emake -j1 check | ||
} | ||
|
||
src_install() { | ||
default | ||
prune_libtool_files --modules | ||
|
||
if use python; then | ||
python_install() { | ||
emake -C bindings/pygobject \ | ||
pyoverridesdir="$(${EPYTHON} -c 'import gi; print(gi._overridesdir)')" \ | ||
DESTDIR="${D}" \ | ||
install | ||
} | ||
python_foreach_impl python_install | ||
fi | ||
|
||
keepdir /usr/share/ibus/engine | ||
|
||
newbashcomp tools/${PN}.bash ${PN} | ||
|
||
insinto /etc/X11/xinit/xinput.d | ||
newins xinput-${PN} ${PN}.conf | ||
} | ||
|
||
pkg_preinst() { | ||
use gconf && gnome2_gconf_savelist | ||
gnome2_icon_savelist | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
use gconf && gnome2_gconf_install | ||
use gtk && gnome2_query_immodules_gtk3 | ||
use gtk2 && gnome2_query_immodules_gtk2 | ||
gnome2_icon_cache_update | ||
gnome2_schemas_update | ||
dconf update | ||
} | ||
|
||
pkg_postrm() { | ||
use gtk && gnome2_query_immodules_gtk3 | ||
use gtk2 && gnome2_query_immodules_gtk2 | ||
gnome2_icon_cache_update | ||
gnome2_schemas_update | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters