Skip to content

Commit

Permalink
dev-python/hypothesis: Version bump to 3.74.3.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/668108
Closes: gentoo#10112
Signed-off-by: Michael Seifert <[email protected]>
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
seifertm authored and monsieurp committed Oct 10, 2018
1 parent 5014a62 commit 8831dbe
Show file tree
Hide file tree
Showing 3 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/hypothesis/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hypothesis-3.6.0.tar.gz 73586 BLAKE2B b0ec133e8c71f752114211061155c15a7d536e771ba85eab6489440b2063d3083018bf8502d9e9dbc73105ee5f03060e3189e64574a3dfa052b091040e7e7915 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389
DIST hypothesis-python-3.59.1.tar.gz 500529 BLAKE2B 5c171045e363f2337d7ca30797b9fc7f96430c805dd4b3ec78fe927247d2c2ba4a216789a82f1e956b89d66c5ecdb2050a5f93467f2d557a05d1d48507fc06db SHA512 c3aad4cc54152963806e09af5f351e60e30cd64ad48ba3d922451b10dbb1747ea3e5d432ebc611dcb0646687d7e8755051b967304e74798d091be0b2901c832f
DIST hypothesis-python-3.74.3.tar.gz 552616 BLAKE2B e19a0991e7ae2fa6208c81d336cc66e3392bb78663f567fe28b570a1463a5359ccf713776f1f9cbd19a27a53b9a71a5be6eedfa05599fa12c047c373aa339592 SHA512 f4927d6e908a9222fa06f82ad6e4cf90c62a0a3d0c7632c17ee57a3705239901fcb5dbbcfca402c153bf2bea9dde0e51c852d2024ed5a236888327963fe13a3e
12 changes: 12 additions & 0 deletions dev-python/hypothesis/files/hypothesis-3.74.3-no-werror.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- hypothesis-python/tests/common/setup.py 2018-10-09 15:41:19.106029968 +0200
+++ hypothesis-python/tests/common/setup.py 2018-10-09 15:42:09.464413825 +0200
@@ -33,6 +33,9 @@
filterwarnings('ignore', category=ImportWarning)
filterwarnings('ignore', category=FutureWarning, module='pandas._version')

+ # Fixed in recent versions but allowed by pytest=3.0.0; see #1630
+ filterwarnings('ignore', category=DeprecationWarning, module='pluggy')
+
# See https://github.com/numpy/numpy/pull/432
filterwarnings('ignore', message='numpy.dtype size changed')
filterwarnings('ignore', message='numpy.ufunc size changed')
51 changes: 51 additions & 0 deletions dev-python/hypothesis/hypothesis-3.74.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
PYTHON_REQ_USE="threads(+),sqlite"

inherit distutils-r1 eutils

DESCRIPTION="A library for property based testing"
HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
IUSE="test"

CDEPEND="
>=dev-python/attrs-16.0.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
"
RDEPEND="${CDEPEND}"
DEPEND="${CDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"

# See https://github.com/HypothesisWorks/hypothesis/issues/1630
PATCHES=( ${FILESDIR}/${P}-no-werror.patch )

python_test() {
pytest tests/cover/test_testdecorators.py || die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
optfeature "datetime support" dev-python/pytz
optfeature "dateutil support" dev-python/python-dateutil
optfeature "numpy support" dev-python/numpy
optfeature "django support" dev-python/django dev-python/pytz
optfeature "pandas support" dev-python/pandas
optfeature "pytest support" dev-python/pytest
}

0 comments on commit 8831dbe

Please sign in to comment.