forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-strategy/wesnoth: Bump to versions 1.14.9 and 1.15.2. Removed old
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Oct 22, 2019
1 parent
0da0ea1
commit 8832193
Showing
3 changed files
with
117 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST wesnoth-1.14.7.tar.gz 493837595 BLAKE2B a80781d4f9ec79514c6431c5d45a6cdcb913aabc6329cefe46e7980805d06b60d479110bb6432f2c35a058e551da6b6fa8e0e4f6f1bdf9a159f6329ddb74aa2a SHA512 dbca2b904147f592cc712b11d6414a47bd557d3c677e6b3eacb4fc1ca5420a264f15fdbe45c8c3469ecfb5d1ffa1ac19cceb58c1378aec0e8b4597baa348ca3b | ||
DIST wesnoth-1.15.1.tar.gz 499339559 BLAKE2B f382411ee01444b603edeaf1d64187716d0dce6a3fa99d18862818289b9f0e0a48bfe1dcd98cbad5cfe2099d1e51755a9bd9f3e847243a3cd193334a8589218c SHA512 abc76a1cd4b459ee28736d1160ba91d4c18b2ee1dbc68c2165f9c27b872e4c8b11246a85ece2c3aa7eeb1f0fc9d5817c56b2a211c0e49ad3952186bac433ecd2 | ||
DIST wesnoth-1.14.9.tar.gz 497393449 BLAKE2B b5235de6ce84164ef97a105339549a8a1009d7b7ed243ae355994610e56afc584b8a37b1275e0b929729a24cd2eb94d4c208e7bd22e79b76113a1e1b91c8f92d SHA512 b3e93956a40ffc48dd02e118be1d46854a2eed34ad0dca3fb34a28d0b58b4b563cb5cca588208f3525300bf075786bebe95a25c045c8098a0bdfe531a2d81e4f | ||
DIST wesnoth-1.15.2.tar.gz 500575489 BLAKE2B c94ff72034f0253c3a2ceb29f10617227c407baa6365116a8cd23c70dd960d9898f5a6291235347769780798438380fe78ada8fb75b4dd83e2d2831f495360ae SHA512 c15bdc214147a222ceb2e6243a75e2dbe4f10eb6153a32c10f37b1ec163a7e0b8f6fb12747917602773fd149d23dc8a6b3ed0b0c017f44f713388743126d6b94 |
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,115 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake-utils user xdg | ||
|
||
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game" | ||
HOMEPAGE="http://www.wesnoth.org | ||
https://github.com/wesnoth/wesnoth" | ||
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
# uneven minor versions are development versions | ||
if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
IUSE="dbus dedicated doc fribidi libressl nls server" | ||
|
||
RDEPEND=" | ||
>=dev-libs/boost-1.50:=[nls,threads,icu] | ||
>=media-libs/libsdl2-2.0.4:0[joystick,video,X] | ||
!dedicated? ( | ||
dev-libs/glib:2 | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
>=media-libs/fontconfig-2.4.1 | ||
>=media-libs/sdl2-image-2.0.0[jpeg,png] | ||
>=media-libs/sdl2-mixer-2.0.0[vorbis] | ||
>=media-libs/sdl2-ttf-2.0.12 | ||
media-libs/libvorbis | ||
>=x11-libs/pango-1.22.0 | ||
>=x11-libs/cairo-1.10.0 | ||
sys-libs/readline:0= | ||
dbus? ( sys-apps/dbus ) | ||
fribidi? ( dev-libs/fribidi ) | ||
)" | ||
DEPEND="${RDEPEND} | ||
x11-libs/libX11 | ||
" | ||
BDEPEND=" | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
" | ||
|
||
pkg_setup() { | ||
enewgroup ${PN} | ||
enewuser ${PN} -1 /bin/bash -1 ${PN} | ||
} | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
|
||
if ! use doc ; then | ||
sed -i \ | ||
-e '/manual/d' \ | ||
doc/CMakeLists.txt || die | ||
fi | ||
|
||
# respect LINGUAS (bug #483316) | ||
if [[ ${LINGUAS+set} ]] ; then | ||
local lang langs=() | ||
for lang in $(cat po/LINGUAS) ; do | ||
has ${lang} ${LINGUAS} && langs+=( ${lang} ) | ||
done | ||
echo "${langs[@]}" > po/LINGUAS || die | ||
fi | ||
} | ||
|
||
src_configure() { | ||
filter-flags -ftracer -fomit-frame-pointer | ||
if [[ $(gcc-major-version) -eq 3 ]] ; then | ||
filter-flags -fstack-protector | ||
append-flags -fno-stack-protector | ||
fi | ||
|
||
# Work around eclass | ||
append-flags -UNDEBUG | ||
|
||
if use dedicated || use server ; then | ||
mycmakeargs=( | ||
-DENABLE_CAMPAIGN_SERVER="ON" | ||
-DENABLE_SERVER="ON" | ||
-DSERVER_UID="${PN}" | ||
-DSERVER_GID="${PN}" | ||
-DFIFO_DIR="/run/wesnothd" | ||
) | ||
else | ||
mycmakeargs=( | ||
-DENABLE_CAMPAIGN_SERVER="OFF" | ||
-DENABLE_SERVER="OFF" | ||
) | ||
fi | ||
mycmakeargs+=( | ||
-Wno-dev | ||
-DENABLE_GAME="$(usex !dedicated)" | ||
-DENABLE_DESKTOP_ENTRY="$(usex !dedicated)" | ||
-DENABLE_NLS="$(usex nls)" | ||
-DENABLE_NOTIFICATIONS="$(usex dbus)" | ||
-DENABLE_FRIBIDI="$(usex fribidi)" | ||
-DENABLE_STRICT_COMPILATION="OFF" | ||
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr" | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
local DOCS=( README.md changelog.md ) | ||
cmake-utils_src_install | ||
if use dedicated || use server; then | ||
rmdir "${ED}/run/wesnothd" || die | ||
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd | ||
fi | ||
} |