Skip to content

Commit

Permalink
media-video/obs-studio: Version bump to 17.0.0.
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/603978

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Chiitoo authored and Michael Palimaka committed Dec 29, 2016
1 parent fd9029d commit 883a103
Show file tree
Hide file tree
Showing 2 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/obs-studio/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST obs-studio-0.15.3.tar.gz 4868410 SHA256 ba9ff4259408583aa1bb7ac2315865c1ef6331b0a240c2061460bc093011514b SHA512 165fcc9ab9fa498654cffa972f5cf728e7cf73e131b077c4f1a75994505d6e4b0149ab9a1b6034422cf5483f5f8ddc2d288a2700093eca0d77404a75068c8b81 WHIRLPOOL f09f105a369332db7a4f95624d09c8ad120984322ae6508a714cbd0de26bb36370ad00b9806ec2587bfbfdd7f708953a076e79e6b3e62e4d5156f524b1f617b2
DIST obs-studio-0.16.2.tar.gz 4979287 SHA256 f5b1a5a4e3900a2b2df4ec6f4a51e0816db1ceed432849ed58301da77ccf4f5c SHA512 ef74b20aa3927134d0deb9513af67abe5dc99199626245a93011bd69d41b811695bc1f071dcd6ed826c2bd5f35247906975f74638c9cd0a39b9415ac88aac425 WHIRLPOOL 5576c4da240ea65d84e195decb655b8774b1540bcde7d01060a38b47e1c561b485c24b88b2771a10b94fe8a0d6d77c05d25ee65313278879609474ff451b2628
DIST obs-studio-17.0.0.tar.gz 5243839 SHA256 5b7d9a6389011c74fec777667edeb1ac7d8ae7faff13f141650d295d7cd9181e SHA512 17c0b400762e4b12dc619ed7ef36bf364f2f7c3f350630dfcfd3b46c72ec488d08dea5a13ef177c24c2f52760170e3c0bef50cec80362e0d542eab096986db7b WHIRLPOOL cda17b9dc5f29084f2eab614136d59deda1dc7f4f6e15b3e9d67907716ecb580b402eddfb3e06ef9bfe76c9e59fa92a07adc16e30ed492f95b44766ad4a67526
104 changes: 104 additions & 0 deletions media-video/obs-studio/obs-studio-17.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit cmake-utils

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/jp9000/obs-studio.git"
EGIT_SUBMODULES=()
else
SRC_URI="https://github.com/jp9000/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Software for Recording and Streaming Live Video Content"
HOMEPAGE="https://obsproject.com"

LICENSE="GPL-2"
SLOT="0"
IUSE="+alsa fdk imagemagick jack pulseaudio truetype v4l"

DEPEND="
>=dev-libs/jansson-2.5
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5
dev-qt/qtquickcontrols:5
dev-qt/qtsql:5
dev-qt/qttest:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
media-video/ffmpeg:=[x264]
net-misc/curl
x11-libs/libXcomposite
x11-libs/libXinerama
x11-libs/libXrandr
alsa? ( media-libs/alsa-lib )
fdk? ( media-libs/fdk-aac:= )
imagemagick? ( media-gfx/imagemagick:= )
jack? ( virtual/jack )
pulseaudio? ( media-sound/pulseaudio )
truetype? (
media-libs/fontconfig
media-libs/freetype
)
v4l? ( media-libs/libv4l )
"
RDEPEND="${DEPEND}"

src_prepare() {
CMAKE_REMOVE_MODULES_LIST=(FindFreetype)

cmake-utils_src_prepare
}

src_configure() {
local libdir="$(get_libdir)"
local mycmakeargs=(
-DDISABLE_ALSA="$(usex !alsa)"
-DDISABLE_FREETYPE="$(usex !truetype)"
-DDISABLE_JACK="$(usex !jack)"
-DDISABLE_LIBFDK="$(usex !fdk)"
-DDISABLE_PULSEAUDIO="$(usex !pulseaudio)"
-DDISABLE_V4L2="$(usex !v4l)"
-DLIBOBS_PREFER_IMAGEMAGICK="$(usex imagemagick)"
-DOBS_MULTIARCH_SUFFIX="${libdir#lib}"
-DUNIX_STRUCTURE=1
)

cmake-utils_src_configure
}

pkg_postinst() {
if ! use alsa && ! use pulseaudio; then
elog
elog "For the audio capture features to be available,"
elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
elog "be enabled."
elog
fi

if ! has_version "sys-apps/dbus"; then
elog
elog "The 'sys-apps/dbus' package is not installed, but"
elog "could be used for disabling hibernating, screensaving,"
elog "and sleeping. Where it is not installed,"
elog "'xdg-screensaver reset' is used instead"
elog "(if 'x11-misc/xdg-utils' is installed)."
elog
fi

if ! has_version "media-libs/speex"; then
elog
elog "For the speexdsp-based noise suppression filter"
elog "to be available, the 'media-libs/speex' package needs"
elog "to be installed."
elog
fi
}

0 comments on commit 883a103

Please sign in to comment.