Skip to content

Commit

Permalink
media-sound/yarock: New package
Browse files Browse the repository at this point in the history
Happy listening!

Closes: https://bugs.gentoo.org/398483
Signed-off-by: Andreas Sturmlechner <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
a17r committed Oct 4, 2018
1 parent 411f426 commit 883d06b
Show file tree
Hide file tree
Showing 5 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/yarock/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST Yarock_1.3.1_Sources.tar.gz 734280 BLAKE2B 3bb8a452a3a7bd27792f67b6fcb2765494738c7a0149248b658333a64f38494880891e8a9d43ef7367d7748e5c0b6a2d9349dc1dd73dd0fecd94d88f21eec020 SHA512 a59837609c5004005360a272b45794143c64373d13c2783f84299ab0b849223aac2be3d87703e1925d66ed4301bcc2e7254228d34f556bce0447d949539acf2e
8 changes: 8 additions & 0 deletions media-sound/yarock/files/yarock-1.3.1-desktop.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
--- a/data/yarock.desktop 2017-12-24 08:48:55.000000000 +0100
+++ b/data/yarock.desktop 2018-10-04 18:18:37.700722758 +0200
@@ -1,5 +1,4 @@
[Desktop Entry]
-Version=1.3.0
Name=Yarock
Comment=Play your music collection
TryExec=yarock
36 changes: 36 additions & 0 deletions media-sound/yarock/files/yarock-1.3.1-phonon.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
--- a/src/core/player/phonon/engine_phonon.h 2017-11-04 17:06:43.000000000 +0100
+++ b/src/core/player/phonon/engine_phonon.h 2018-10-04 18:23:29.079923850 +0200
@@ -27,12 +27,12 @@
#include <QPixmap>

// Phonon
-#include <phonon/mediasource.h>
-#include <phonon/mediaobject.h>
-#include <phonon/audiooutput.h>
-#include <phonon/path.h>
-#include <phonon/effect.h>
-#include <phonon/volumefadereffect.h>
+#include <phonon4qt5/phonon/mediasource.h>
+#include <phonon4qt5/phonon/mediaobject.h>
+#include <phonon4qt5/phonon/audiooutput.h>
+#include <phonon4qt5/phonon/path.h>
+#include <phonon4qt5/phonon/effect.h>
+#include <phonon4qt5/phonon/volumefadereffect.h>

#include "core/player/engine_base.h"
#include "core/mediaitem/mediaitem.h"
--- a/src/core/player/phonon/engine_phonon.cpp 2017-11-11 07:29:42.000000000 +0100
+++ b/src/core/player/phonon/engine_phonon.cpp 2018-10-04 18:23:29.084923716 +0200
@@ -29,9 +29,9 @@
#include <QtPlugin>

// phonon
-#include <phonon/backendcapabilities.h>
-#include <phonon/effect.h>
-#include <phonon/effectparameter.h>
+#include <phonon4qt5/phonon/backendcapabilities.h>
+#include <phonon4qt5/phonon/effect.h>
+#include <phonon4qt5/phonon/effectparameter.h>

#include <cmath>

11 changes: 11 additions & 0 deletions media-sound/yarock/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Andreas Sturmlechner</name>
</maintainer>
<use>
<flag name="phonon">Use <pkg>media-libs/phonon</pkg> backend instead of <pkg>media-video/vlc</pkg></flag>
</use>
</pkgmetadata>
56 changes: 56 additions & 0 deletions media-sound/yarock/yarock-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

MY_P="Yarock_${PV}_Sources"
DESCRIPTION="Qt-based music player"
HOMEPAGE="https://seb-apps.github.io/yarock/"
SRC_URI="https://launchpad.net/${PN}/1.x/${PV}/+download/${MY_P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="phonon"

RDEPEND="
dev-cpp/htmlcxx
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsql:5[sqlite]
dev-qt/qtwidgets:5
dev-qt/qtxml:5
media-libs/taglib
x11-libs/libX11
!phonon? ( media-video/vlc:= )
phonon? ( >=media-libs/phonon-4.10.1 )
"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
dev-qt/qtconcurrent:5
dev-qt/qtx11extras:5
"

DOCS=( CHANGES.md README.md )

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}/${P}-desktop.patch"
"${FILESDIR}/${P}-phonon.patch"
)

src_configure() {
local mycmakeargs=(
-DENABLE_QT5=ON
-DENABLE_MPV=OFF
-DENABLE_PHONON=$(usex phonon ON OFF)
-DENABLE_VLC=$(usex phonon OFF ON)
)

cmake-utils_src_configure
}

0 comments on commit 883d06b

Please sign in to comment.