Skip to content

Commit

Permalink
media-libs/libuvc: new ebuild
Browse files Browse the repository at this point in the history
Closes: gentoo#5769
  • Loading branch information
reagentoo authored and mgorny committed Oct 18, 2017
1 parent 8d5da17 commit 88a417b
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libuvc/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST libuvc-0.0.6.tar.gz 95598 SHA256 42175a53c1c704365fdc782b44233925e40c9344fbb7f942181c1090f06e2873 SHA512 d8e52f5d062d2b4561562c9dc017d7f8d9d6734c4284e54b7bc58f9fc968cc8aec51dde938e8911a5c71d0c49fca4478c2fe08c9b7041d4fa26d7c6e1e653f1e WHIRLPOOL 470114ab1596ae8119a8d67c31d393f4919b85e42230027db58565e4369f322e5e7a6604bf29336e5c7bb7243714dca8a3d037854007cca1ac6606aa59161ecc
42 changes: 42 additions & 0 deletions media-libs/libuvc/libuvc-0.0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="A cross-platform library for USB video devices, built atop libusb"
HOMEPAGE="https://int80k.com/libuvc/"
SRC_URI="https://github.com/ktossell/libuvc/archive/v${PV}.tar.gz -> ${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND="
virtual/jpeg:62
virtual/libusb:1
virtual/udev
"
DEPEND="${RDEPEND}"

CMAKE_MIN_VERSION="2.8.0"

DOCS=( changelog.txt README.md )

src_prepare() {
sed -r -i \
-e 's/(\$\{CMAKE_INSTALL_PREFIX\}\/)lib/\1'"$(get_libdir)"'/' \
CMakeLists.txt || die

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DCMAKE_BUILD_TARGET=Shared
)

cmake-utils_src_configure
}
15 changes: 15 additions & 0 deletions media-libs/libuvc/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Dmitry Baranov</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
<remote-id type="github">ktossell/libuvc</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 88a417b

Please sign in to comment.