Skip to content

Commit

Permalink
dev-lang/elixir: block against sci-biology/phylip, bug #537514
Browse files Browse the repository at this point in the history
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/537514
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Sergei Trofimovich committed Feb 15, 2018
1 parent 16e42e5 commit 88aad58
Showing 1 changed file with 32 additions and 0 deletions.
32 changes: 32 additions & 0 deletions dev-lang/elixir/elixir-1.6.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit multilib

DESCRIPTION="Elixir programming language"
HOMEPAGE="https://elixir-lang.org"
SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 ErlPL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE=""

DEPEND=">=dev-lang/erlang-18[ssl]"
# 'mix' tool collides with sci-biology/phylip, bug #537514
RDEPEND="${DEPEND}
!!sci-biology/phylip
"

RESTRICT=test # needs debug symbols

src_compile() {
emake Q=""
}

src_install() {
emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
}

0 comments on commit 88aad58

Please sign in to comment.