Skip to content

Commit

Permalink
dev-python/mox3: PYTHON_COMPAT: add python3_6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
zmedico committed Feb 16, 2017
1 parent 0213bc4 commit 88ef761
Show file tree
Hide file tree
Showing 3 changed files with 24 additions and 4 deletions.
18 changes: 18 additions & 0 deletions dev-python/mox3/files/mox3-0.12.0-RegexTest-python3.6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
From: Zac Medico <[email protected]>
Subject: [PATCH] RegexTest: python3.6 compatibility

https://bugs.launchpad.net/python-mox3/+bug/1665266

--- mox3-0.12.0/mox3/tests/test_mox.py
+++ mox3-0.12.0/mox3/tests/test_mox.py
@@ -316,8 +316,8 @@

def testReprWithFlags(self):
"""repr should return the regular expression pattern and flags."""
- self.assertTrue(repr(mox.Regex(r"a\s+b", flags=4)) ==
- "<regular expression 'a\s+b', flags=4>")
+ self.assertTrue(repr(mox.Regex(r"a\s+b", flags=8)) ==
+ r"<regular expression 'a\s+b', flags=8>")


class IsTest(testtools.TestCase):
4 changes: 2 additions & 2 deletions dev-python/mox3/mox3-0.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
DISTUTILS_IN_SOURCE_BUILD=TRUE

inherit distutils-r1
Expand Down
6 changes: 4 additions & 2 deletions dev-python/mox3/mox3-0.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit distutils-r1

Expand Down Expand Up @@ -40,6 +40,8 @@ RDEPEND="
${CRDEPEND}
"

PATCHES=( "${FILESDIR}"/${P}-RegexTest-python3.6.patch )

python_compile_all() {
use doc && esetup.py build_sphinx
}
Expand Down

0 comments on commit 88ef761

Please sign in to comment.