forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-frameworks: Add KDE Frameworks 5.62.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
170 changed files
with
2,962 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST attica-5.60.0.tar.xz 63440 BLAKE2B e9aa0f3aa0a3e95c3db4a6d442f21db608caddc8c0f368dc453c308e2406d71714deda568b2edf97bf2a4e0256b2361d80fafcbd8cde9e76787d919a33871a55 SHA512 7473afaf2bf4d30feaf1948ea0e432af72090403ad53af48aa56dc30d1770ba1831aad7a106bf2f94ded33aa44c5269d4401ddbeb4126ba00f61af01e342829d | ||
DIST attica-5.61.0.tar.xz 63032 BLAKE2B 95cef42dce9fdd4bb9d94e839d2d5fbea2e59ab6641616e26af10eb03a072f681c3eccde6a939102d6158e873e715a7ae87d9ab4eab3c3eb630663c4332db322 SHA512 33bf7feced1d792b4f0b2b05642ac58e651fae68adee9eff33d2542e528a003d51682e1af27db3e9cef96545989f957e543dce64cf07a685efdf5b5056ba6bdd | ||
DIST attica-5.62.0.tar.xz 63216 BLAKE2B 127167f132da85e7ea212bbbf9b01a70c75cc0ba907e833c6529230174bb47893e69c95e065845f7d937551a0d2b876a30c90b9d8d3ef53bc1afefb18cbacd2b SHA512 3a16882d272b888cf1eef5816336ac7119bb5da46ac84cd7a0b86b8d0858fdef6816c995864eb6717bbc8817cf26bdc4d47fea1c7bf946fb696e304abce9d6cc |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kde5 | ||
|
||
DESCRIPTION="Framework providing access to Open Collaboration Services" | ||
LICENSE="LGPL-2.1+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
$(add_qt_dep qtnetwork) | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_test() { | ||
# requires network access, bug #661230 | ||
local myctestargs=( | ||
-E "(providertest)" | ||
) | ||
|
||
kde5_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST baloo-5.60.0.tar.xz 268268 BLAKE2B 120f7497539384bc6f18683f9dbe8a6c209ce70902499936ac2668efc9bf35140195374ad9c13500f352db38e06015f8ee29fec1ffcf8b63bf1726997d856bf6 SHA512 a25b0cb80f7744c5aa9d22d4b4a8da3e228fb994f659dd04373cef86f45322a4d625d7390e32b3d1d0c178f40d56e9ce5a3263e2e997272e255d52f2adeb82ee | ||
DIST baloo-5.61.0.tar.xz 270040 BLAKE2B 6b2ee5cddd6a3526151ce6bd3b2983e30395d10799e7d3948d9697fd625a3b0ee099c672e9459afa91f2d642e17f4e279771f441ee98f4710c6bbe5f64805976 SHA512 036807ab27bd8173ea39ff89a62a38577b624300766d0e8ce6195a5187aa911eaa14f36532478f44c60366b2078b8a439bda6f5109752166ee47bfc57ee87f18 | ||
DIST baloo-5.62.0.tar.xz 273412 BLAKE2B 310a652e22b6b506a122a3447ecef851ab1acaaea9aaf427df598d165cb9266acaa259108ca6610d52bf490e454f3453836e898e619aa8e64b384a59ad3d5d63 SHA512 f72193f4a75a2feebadd9006461bdf194842783f3ad93c16243fe6a1251cf5f761f352b585e6628f2dc23e543bf58d6ff5630e6ae5bb0a916ed0732a520c2ba0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_TEST="forceoptional" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for searching and managing metadata" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kfilemetadata) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kidletime) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep solid) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
>=dev-db/lmdb-0.9.17 | ||
" | ||
RDEPEND="${DEPEND} | ||
!kde-frameworks/baloo:4[-minimal(+)] | ||
" | ||
|
||
RESTRICT+=" test" # bug 624250 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST bluez-qt-5.60.0.tar.xz 99064 BLAKE2B 2895a9836fbacfc23a9c557cdb10e9f8aaac1c13fa5a8a9c158aec148d56d33730092f5f875d931bdae195263274ef8b64c0753e182356ddecb5badd2059928b SHA512 7a1ef70f2c95e51d0b9c8583f23c9bb07af02087bf291e90ff8f4b9d1702d3a12d38247950aef56ee6409bebfe94bc2ddf91da1fa0bb1ec75afa10b54a6cfd1a | ||
DIST bluez-qt-5.61.0.tar.xz 99160 BLAKE2B 9259721cbed7cca5e36b2df014047ba49d9203c93066d3d062260072d90c162784ec08286aeee47cc536e3db773e3442006f8f394012788bdeb6863a20e3594e SHA512 ea630a7c6b4e0da5231ad7b577bb7e5a5f12f186ee754442d451d8efb3a72c9f08e06ed814e151e28c10f99623dfdd2aeba144be43e9105b14ba62c12b206dab | ||
DIST bluez-qt-5.62.0.tar.xz 99036 BLAKE2B 31b172594060a7abd8557dd2aadf2b3abbebd4000a57630fbc34addfe4a42d959ee049de2a25fc035518cf4530ba81bb851edbe9c6bce796932cfc71e39323b6 SHA512 beb83a0d19a55770e2892b43b1afaf808c2905d3d35d8116c9f270c63bddbb6e5c6ae35b3c933e5551084f341364d3cd73bd5e5834afab48f9d289a18b108cf8 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 udev | ||
|
||
DESCRIPTION="Qt wrapper for Bluez 5 DBus API" | ||
LICENSE="LGPL-2" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtnetwork) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d" | ||
) | ||
|
||
kde5_src_configure | ||
} | ||
|
||
src_test() { | ||
# parallel tests fail, bug 609248; managertest hangs, bug 668196 | ||
local myctestargs=( | ||
-j1 | ||
-E "(managertest)" | ||
) | ||
|
||
kde5_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.60.0.tar.xz 2528776 BLAKE2B b2c1d762e3ec5a0523245daec6892a2b55cdaa6947792d389181c0310db592fbaec9e7dbf5eb8841623dffa82a62d286a72a11e2b99ce7640733b60d2bba6434 SHA512 ffed5778099ac6b735e80d24a8020871bb50c13a04fd437ab619fc8abc07ccd488a46fe7da0c67826ce5b2297a43e86ccbf38c79ffc1a86c5b6a11b72ea8108e | ||
DIST breeze-icons-5.61.0.tar.xz 2525640 BLAKE2B 86ea287b326f3e539723f5518ed63c82e0a99865b0e80db1b56fad5b55aad6ea70b5b47d33bc79e60c29e9e127bbd5aca4984441c6c6c9a9f16b0306e8a1850a SHA512 aa983b41d0c05fe7235bfff45f094caa909bcf96ce40f1df163f078671014c289f24b1fd695bcea2b51f92101dfa0e94b1ebd54dbfc4ec88c24499c61d2d92b2 | ||
DIST breeze-icons-5.62.0.tar.xz 2679576 BLAKE2B bd9bd906225fe86e9d9df9fd301177ccfe9b24ef0afe8e75a8b5db2dd4855ae3b9a6fc5acf6cf921e7ef346203467556adb7b31a888111f74f54e22f2a6b94a5 SHA512 6d1c67b5c92e8cec44c934383cad185f4d32dd1fd5f37214ea95536175bed7e4f39c1d7ce7737022fe0a891e0f8f15b650ad75ba078ad1abc2deb69dc145d343 |
30 changes: 30 additions & 0 deletions
30
kde-frameworks/breeze-icons-rcc/breeze-icons-rcc-5.62.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
KDE_QTHELP="false" | ||
KMNAME="breeze-icons" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Breeze SVG icon theme binary resource" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="" | ||
|
||
BDEPEND=" | ||
$(add_frameworks_dep extra-cmake-modules) | ||
$(add_qt_dep qtcore) | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( $(add_qt_dep qttest) )" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=ON | ||
-DSKIP_INSTALL_ICONS=ON | ||
) | ||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.60.0.tar.xz 2528776 BLAKE2B b2c1d762e3ec5a0523245daec6892a2b55cdaa6947792d389181c0310db592fbaec9e7dbf5eb8841623dffa82a62d286a72a11e2b99ce7640733b60d2bba6434 SHA512 ffed5778099ac6b735e80d24a8020871bb50c13a04fd437ab619fc8abc07ccd488a46fe7da0c67826ce5b2297a43e86ccbf38c79ffc1a86c5b6a11b72ea8108e | ||
DIST breeze-icons-5.61.0.tar.xz 2525640 BLAKE2B 86ea287b326f3e539723f5518ed63c82e0a99865b0e80db1b56fad5b55aad6ea70b5b47d33bc79e60c29e9e127bbd5aca4984441c6c6c9a9f16b0306e8a1850a SHA512 aa983b41d0c05fe7235bfff45f094caa909bcf96ce40f1df163f078671014c289f24b1fd695bcea2b51f92101dfa0e94b1ebd54dbfc4ec88c24499c61d2d92b2 | ||
DIST breeze-icons-5.62.0.tar.xz 2679576 BLAKE2B bd9bd906225fe86e9d9df9fd301177ccfe9b24ef0afe8e75a8b5db2dd4855ae3b9a6fc5acf6cf921e7ef346203467556adb7b31a888111f74f54e22f2a6b94a5 SHA512 6d1c67b5c92e8cec44c934383cad185f4d32dd1fd5f37214ea95536175bed7e4f39c1d7ce7737022fe0a891e0f8f15b650ad75ba078ad1abc2deb69dc145d343 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
KDE_QTHELP="false" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Breeze SVG icon theme" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
BDEPEND=" | ||
$(add_frameworks_dep extra-cmake-modules) | ||
$(add_qt_dep qtcore) | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( $(add_qt_dep qttest) )" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=OFF | ||
) | ||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST extra-cmake-modules-5.60.0.tar.xz 325768 BLAKE2B de99c37171d298ef8168403b9b27275171db142f204a2c2b3ff82942390b91510e16a19f0d366242f03259c0c045186a8a8f5bd598ef6051709a307423972fab SHA512 c505f765169d4e77a836d971cabe513f5fbda6c772bff10a97013dd14fb91167b461c7e01382e41c4e9ca050a20ab828f3090ef7cd64625fa784d81f2cbf2743 | ||
DIST extra-cmake-modules-5.61.0.tar.xz 326988 BLAKE2B d8db007377d23892459bbd9fca72b05301213bc9958cbb12d230685b301895d5a62e26235aeda78b8de3e1ae3a105e5b5b6b370d528bc29d02ca46fbb83235b3 SHA512 3f78b35de928f622ec5475cd264da7e66db007ef4d2d618f30d1847f271db0dd2540dacfdde09d932683063662deb8df43c2f06b1e131426535accf922c325e5 | ||
DIST extra-cmake-modules-5.62.0.tar.xz 330696 BLAKE2B d13ef20d9e7b148a5c75dbae5cb04ae704925a09ed136b9cba29cf7bfeae4316f8237e9a4d9eb528340a941853a14d265bc029cf1b8f1152254e095f05de6eee SHA512 9a9453fe25f5213e4f7349734486da61301b71198820318a1362bdc8ea95322f4900eb3781a311d5c250c3a4ca52ef88ec19a97122eb089ba6bdafca921facd8 |
72 changes: 72 additions & 0 deletions
72
kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.62.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} ) | ||
ECM_KDEINSTALLDIRS="false" | ||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
KDE_QTHELP="false" | ||
KDE_TEST="false" | ||
inherit kde5 python-any-r1 | ||
|
||
DESCRIPTION="Extra modules and scripts for CMake" | ||
HOMEPAGE="https://cgit.kde.org/extra-cmake-modules.git" | ||
|
||
LICENSE="BSD" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd" | ||
IUSE="doc test" | ||
|
||
BDEPEND=" | ||
doc? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') | ||
$(add_qt_dep qthelp) | ||
) | ||
test? ( | ||
$(add_qt_dep qtcore) | ||
$(add_qt_dep linguist-tools) | ||
) | ||
" | ||
RDEPEND=" | ||
app-arch/libarchive[bzip2] | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch" ) | ||
|
||
python_check_deps() { | ||
has_version "dev-python/sphinx[${PYTHON_USEDEP}]" | ||
} | ||
|
||
pkg_setup() { | ||
use doc && python-any-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
# Requires PyQt5, bug #680256 | ||
sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \ | ||
tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests" | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_QTHELP_DOCS=$(usex doc) | ||
-DBUILD_HTML_DOCS=$(usex doc) | ||
-DBUILD_MAN_DOCS=$(usex doc) | ||
-DDOC_INSTALL_DIR=/usr/share/doc/"${PF}" | ||
) | ||
|
||
kde5_src_configure | ||
} | ||
|
||
src_test() { | ||
# ECMToolchainAndroidTest passes but then breaks src_install | ||
# ECMPoQmToolsTest is broken, bug #627806 | ||
local myctestargs=( | ||
-E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)" | ||
) | ||
|
||
kde5_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST frameworkintegration-5.60.0.tar.xz 1753424 BLAKE2B f0752ba701ad1bc3c447f1d7c17ab22b922efc570bf6ef84c51ef58ee9e3f32f68f0ef222c88991252db60a0b0e63cdec672b20b693807d50b3bed2b1b7c95b3 SHA512 4313e31789046e49d644a8613c0274c44f15ce7bfdee1e66240a1cbf6c625eba093fa0a2d922833a336c208aa75af8c949d0881bd17efe2c1007045d3a9288a5 | ||
DIST frameworkintegration-5.61.0.tar.xz 1753264 BLAKE2B 3db63e29c65ed49df7140f9cc058044ff9f78ee12221447843d5d5b1b6d4063d18f3c099221788af35ee6dd946a22fb43a265370561cbadff2476c4b97adf692 SHA512 9781e1d977713b2c7e604a30bb35a53e33f85002755d03615d501db101ac7ce718fcd50a83510f17806462998ddc11a88d38083d43a8a645643010ed17b06057 | ||
DIST frameworkintegration-5.62.0.tar.xz 1754660 BLAKE2B ffb435d47c9e006f62be2c64caf69ef1c6aed97f47223a6e8ee29c0ac101c628e880f202ccfcd66f285d24749a675bc922dc59f240e4825ed2f0c9f86b25d9d9 SHA512 918ecb9ddf50cfa8b8fce3fb218a8b80a97d3e440e3c6faf5bb76e74ff1752448244da19da0367a6e077ee8f7e4599328da667d63d45c35490a0a7436570e336 |
53 changes: 53 additions & 0 deletions
53
kde-frameworks/frameworkintegration/frameworkintegration-5.62.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_QTHELP="false" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="appstream X" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep knotifications) | ||
$(add_frameworks_dep kpackage) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
appstream? ( | ||
app-admin/packagekit-qt | ||
dev-libs/appstream[qt5] | ||
) | ||
X? ( | ||
$(add_qt_dep qtx11extras) | ||
x11-libs/libxcb | ||
) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
# requires running kde environment | ||
RESTRICT+=" test" | ||
|
||
src_prepare() { | ||
punt_bogus_dep Qt5 DBus | ||
kde5_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package appstream AppStreamQt) | ||
$(cmake-utils_use_find_package appstream packagekitqt5) | ||
$(cmake-utils_use_find_package X XCB) | ||
) | ||
|
||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-stats-5.60.0.tar.xz 61072 BLAKE2B 1c43005e77c07bbb9c2f362c72426f89d7f55b9b185bc56036b7643889077cbdf94fdb691188c979a123d82ba25adbc97406c3116ab4f398e20e7f068cb913cd SHA512 b3de38928c6e191962dfbc4ff25e21c5dcfabc41b9c5b13b49ef495981ac8437e126ac7d72cea578d191eff7c66f9b07b915103186a77db0b46f75e432c095e7 | ||
DIST kactivities-stats-5.61.0.tar.xz 61900 BLAKE2B 59d81ca8fb46c74ad728d3ad64f3fb7905bf6d4b22ba29acc68fd4cf99c0168afc5c4e79f773732804da1b924d4452498b91edcfe2871bdc1c151931dde7fcdc SHA512 68dcce6f4986426d68f7d238aa48861c3621e78faa7e902facfa9ef6a5d7a4c105211443ef07f33fef5fa38d9af979220a4b1d98bdc2f19028d7cff14d5185aa | ||
DIST kactivities-stats-5.62.0.tar.xz 62920 BLAKE2B 1445d189239365a6f9225905b4dc05cf765dc7b173b47deacdb740cb743f0863cdb5d0ac291a767a3862c3f3957a49ab5aa89c0408fbd8d0dd7587670ad5336b SHA512 2ac404cfbadede0382a3ee012a987335b16b0b258ea4add0ce205268664e34b43c06e91181652842bc27a8fbbea5b7550d0f8c9b25fdd2626d71cf32cbab9402 |
21 changes: 21 additions & 0 deletions
21
kde-frameworks/kactivities-stats/kactivities-stats-5.62.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for getting the usage statistics collected by the activities service" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtsql) | ||
$(add_frameworks_dep kactivities) | ||
$(add_frameworks_dep kconfig) | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-5.60.0.tar.xz 61224 BLAKE2B 777b7357184baa1d5d34b1de033bf4c855db2fd55107d03a4e2ff69a167c48fbfa63f4d14da1ffeb4487d535cbea409d90c22bf32e0204065c1b4508b0c44aa7 SHA512 5b8f4b3165a40f43cd3c7cb8716a5d5d8a72fb754cb82c0d3ad8f36e765aea09d0b634bfdc8bc317556b8d14baec99f8f7f0efc16ab6ef575c611dc0f36b9e2b | ||
DIST kactivities-5.61.0.tar.xz 61456 BLAKE2B 3a5fe4167cf22c7b09715561eb6a7c7935731e4d5960985032a4f0bdbd8cff7c8ebfa345195018309da9cc8f1677ef66cc187dbb6f2a37b48df89df2fe3664bc SHA512 c12dda1458808bd7ce54d14a6701aa3fc270549a8896e31d67739027add838551023965072db9f67ecd41e583504099aa2a55fab4152524a8afeb2992cfaddc3 | ||
DIST kactivities-5.62.0.tar.xz 61424 BLAKE2B 5ee7ae65568a7cef258f5722f0d9473a35b65e1544fb00058457ec60f340f41cb468bd9d52fe057c92d1b9e67c84dfcafdfadbe3250847e7bc52a5cb6f1cfe29 SHA512 f452873b3aafd5665740588a3ee4b9740dc145a3a97714b3b560ca900a52ee63fe4f8cd541ae263e08c2486ab51e84a72051f4379e53f9de39c33f3f6a5e9f8e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for working with KDE activities" | ||
LICENSE="|| ( LGPL-2.1 LGPL-3 )" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
COMMON_DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative widgets) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtsql) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
$(add_plasma_dep kactivitymanagerd) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kapidox-5.60.0.tar.xz 396600 BLAKE2B e0bf009bb59de72f1bc7aba021c8c2751e4322702eea6912da55c745522d4981ad116a5baa22bf0a98148699d0fd738850a71e08989691101fad5d02eefdceec SHA512 f2ee7a486a3740ad2124f95264f83242b07454f189defc8eefac1cb20e7b6b1c37c579fd8b620148ee2197b8473d3a5a80e773fb0f0abd2f6cdfca7a4a1bcea6 | ||
DIST kapidox-5.61.0.tar.xz 396908 BLAKE2B ebb437323ed534922c6c27a84ffded94c219eb11e40b9f6274fc173f70fca68bfc26ce00af0c3890b5cf3378dea82cc9dbfd01426f04dd1951752c10fb16cb5e SHA512 28ccaafe8e9c36d54c657bcd89a1ffd596cb4787a540da67a6f3867a5a566516aa2bf09492ac342a39639d692cc7817ca8b1e9f33df49874b32aa432f89fc07b | ||
DIST kapidox-5.62.0.tar.xz 397028 BLAKE2B bb38a66194977444a854e0aa3ad2dc5d60462fd72b4957b1330edd6b1e31e06369c047d42e1db729030ff423304692736de9ca8ffcb2b03b63a65d64780f2547 SHA512 d962d374530fcb264d83fc223b055a86a7bec6cc11c192cc8972e703a4a505520547c9eac2be758847cbfcf73ab63d6ba09dd70c7f1fa3ec5437d7ca844ec6da |
Oops, something went wrong.