Skip to content

Commit

Permalink
app-crypt/gnupg: New upstream version 2.2.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
krifisk committed May 7, 2018
1 parent c5360e6 commit 89d69be
Show file tree
Hide file tree
Showing 2 changed files with 131 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/gnupg/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST gnupg-2.2.3.tar.bz2 6547069 BLAKE2B a5ac44f696cce2ffbac72b80f0efcd19fe09934
DIST gnupg-2.2.4.tar.bz2 6571487 BLAKE2B ec678470e574fdc9f057cc727cbb902ce525f76adae740722731e318032707d0f72873628024c2070a72c21321f2b8da16153edeafcb4ddeba72de59ff5c73bd SHA512 3d5c93b7662433103e9549d066a6b1a0c09d595851fab712d2ee844a55157e952a8a2dd5deff70fa8dd6817481f81c3fe5135603bca03206857310d04c1067a8
DIST gnupg-2.2.5.tar.bz2 6584756 BLAKE2B d19358caf65627243c37afbf348acb2ea91f785272f318aed9e95e097c34cf3b3b1a223919a86e3ff09c045cb0b56d8aed7c746ed1223dd6a6aa072d24c44bce SHA512 675d2acc2ba95d14b14f4c83364663d88c982332fb4c35a4cf32af19a6bd4453ad89905c80d45007adb50c01816247df84d1f525e94bb668b962a84815e49bf1
DIST gnupg-2.2.6.tar.bz2 6605028 BLAKE2B 2de6f8d32e551a8af5c41b7e6220a43645472b3b7f25b168a54343c4279f412d5d8f7a5142451504192259b3fe4a3e3242d12520dadc385f466dd701a803073a SHA512 ad0861c86c1886f701ae05e7cd439449cf0684a7bf461ca2b729c5e93833ee36f8438cd4d7f73a4c60e57060f3d8f4890a809b2bbc31b083f9f61d2f66ccacc4
DIST gnupg-2.2.7.tar.bz2 6631100 BLAKE2B 81a66a8f738fc2b42d923ccda7d6cbfffc8e938970c04fe02c0146202f2e97fa88d5263aee2f3051e141169f4f02f72ccc53ac831bb57d42740130e3122fa454 SHA512 f858b275876d38b9d3a60e5428574f1008a73a948f67a2fa43bcf1970a5dbb60ec3f0e2b2271243229465eb9b22124e216894f0b3d72004acf3ed0c3481da33d
130 changes: 130 additions & 0 deletions app-crypt/gnupg/gnupg-2.2.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,130 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit systemd toolchain-funcs

MY_P="${P/_/-}"

DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
HOMEPAGE="http://www.gnupg.org/"
SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl tofu tools usb wks-server"

COMMON_DEPEND_LIBS="
>=dev-libs/npth-1.2
>=dev-libs/libassuan-2.5.0
>=dev-libs/libgcrypt-1.7.3
>=dev-libs/libgpg-error-1.24
>=dev-libs/libksba-1.3.4
>=net-misc/curl-7.10
ssl? ( >=net-libs/gnutls-3.0:0= )
sys-libs/zlib
ldap? ( net-nds/openldap )
bzip2? ( app-arch/bzip2 )
readline? ( sys-libs/readline:0= )
smartcard? ( usb? ( virtual/libusb:0 ) )
tofu? ( >=dev-db/sqlite-3.7 )
virtual/mta
"
COMMON_DEPEND_BINS="app-crypt/pinentry
!app-crypt/dirmngr"

# Existence of executables is checked during configuration.
DEPEND="${COMMON_DEPEND_LIBS}
${COMMON_DEPEND_BINS}
nls? ( sys-devel/gettext )
doc? ( sys-apps/texinfo )"

RDEPEND="${COMMON_DEPEND_LIBS}
${COMMON_DEPEND_BINS}
selinux? ( sec-policy/selinux-gpg )
nls? ( virtual/libintl )"

S="${WORKDIR}/${MY_P}"

DOCS=(
ChangeLog NEWS README THANKS TODO VERSION
doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
)

PATCHES=(
"${FILESDIR}/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
)

src_configure() {
local myconf=()

if use smartcard; then
myconf+=(
--enable-scdaemon
$(use_enable usb ccid-driver)
)
else
myconf+=( --disable-scdaemon )
fi

if use elibc_SunOS || use elibc_AIX; then
myconf+=( --disable-symcryptrun )
else
myconf+=( --enable-symcryptrun )
fi

# glib fails and picks up clang's internal stdint.h causing weird errors
[[ ${CC} == *clang ]] && \
export gl_cv_absolute_stdint_h=/usr/include/stdint.h

econf \
"${myconf[@]}" \
$(use_enable bzip2) \
$(use_enable ssl gnutls) \
$(use_enable nls) \
$(use_enable tofu) \
$(use_enable wks-server wks-tools) \
$(use_with ldap) \
$(use_with readline) \
--enable-gpg \
--enable-gpgsm \
--enable-large-secmem \
--enable-all-tests \
CC_FOR_BUILD="$(tc-getBUILD_CC)"
}

src_compile() {
default

use doc && emake -C doc html
}

src_test() {
#Bug: 638574
use tofu && export TESTFLAGS=--parallel
default
}

src_install() {
default

use tools &&
dobin \
tools/{convert-from-106,gpg-check-pattern} \
tools/{gpg-zip,gpgconf,gpgsplit,lspgpot,mail-signed-keys} \
tools/make-dns-cert

dosym gpg /usr/bin/gpg2
dosym gpgv /usr/bin/gpgv2
echo ".so man1/gpg.1" > "${ED}"/usr/share/man/man1/gpg2.1 || die
echo ".so man1/gpgv.1" > "${ED}"/usr/share/man/man1/gpgv2.1 || die

dodir /etc/env.d
echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >> "${ED}"/etc/env.d/30gnupg || die

use doc && dodoc doc/gnupg.html/* doc/*.png

systemd_douserunit doc/examples/systemd-user/*.{service,socket}
}

0 comments on commit 89d69be

Please sign in to comment.