Skip to content

Commit

Permalink
dev-vcs/mercurial: Bump to version 4.0.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Lars Wendler committed Dec 2, 2016
1 parent 981fa99 commit 89d768a
Show file tree
Hide file tree
Showing 2 changed files with 136 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/mercurial/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST mercurial-3.7.3.tar.gz 4636732 SHA256 c099c42d74e2d520b61dd372cd996b0fa7605
DIST mercurial-3.8.4.tar.gz 4775341 SHA256 4b2e3ef19d34fa1d781cb7425506a05d4b6b1172bab69d6ea78874175fdf3da6 SHA512 2ee785f631f9ae346e10ca77251a9ce6d3dacd598588c39f1a69ce1f4b668866f6109d682428512c37c300b26741b74672195538d66845e85cfff5ead886cf4c WHIRLPOOL 1f0a12cc6d00f3544ab00e011a9ff9308fe1652c0598045ddba2a41ba17b55c291da200bce85d4c600d673b8746e936c441ffa7398ad810d1069bd97fb32f2db
DIST mercurial-3.9.1.tar.gz 4797967 SHA256 625e4fc7e85ec2278c2828bdc547fce74091b3bbe4d9eeeba2d61af51195df74 SHA512 d96e45cafd36be692d6ce5259e18140641c24f73d4731ff767df0f39af425b0630c687436fc0f53d5882495ceacacaadd5e19f8f7c701b4b94c48631123b4666 WHIRLPOOL ba4e9374b592d294767046fe7d4297df837d9e92ea2279a7a3654054c058a6b994cade2358d2c35a7d30b6985abd0f7afe55af586ccafbe1dc5b50059bc2712f
DIST mercurial-3.9.2.tar.gz 4798958 SHA256 69046a427c05e83097bf0145a1e37975ae0b6ba4430456e2beca3d2fd96583cf SHA512 2217b492216bc640366bf4bfa65bb50d2b7f384d70c59fd1fb138482cbee4768c83a444233958a7ad95e9cd0dcbe3e676d7ff4a8a4019b9773205f8f2500235e WHIRLPOOL 11763311c2df0a235a8401ea0ea59d06797bbfaa420f9c900a39fa127e34f94cefc27dde96e57449cc659da7e13813ad146c17f5db011068bed5f0f7215e331c
DIST mercurial-4.0.1.tar.gz 4851421 SHA256 6aa4ade93c1b5e11937820880a466ebf1c824086d443cd799fc46e2617250d40 SHA512 145bb80d5dbefb5b770a8d74ce31929fafbd235bb3f641bcaa54b1f5278b2abef4298025152aaba212f639c307741d3aaf75be83e3fc52eaf440c86e4a804459 WHIRLPOOL d1cc3786e16d5a11b7d0a1a10e30190199c72cc281a6e2f3dd9c12829fc967d2b28fce902fb226dfc72531770db042333c5a23565a8c01129fab3a348b11a6f1
DIST mercurial-4.0.tar.gz 4850316 SHA256 24be080745230840f214d93e9f9fb4e25510f9abbbec2e56fab18543fedc43a7 SHA512 8c1974a00efc4d0bcdaca1ce86a172528de58857ac0a78d8cac5c1182dcdd340c7f0f680c8dba82d384ffd3557abbfbdc2e473b5b0b8f05160bd6dbb915e76e4 WHIRLPOOL b4dad09ee488a2630ba37e4f24454de0d171a5b480bd5d161c28a1ec03f60f05efdc25c66c9626d638becebae1ace420312660f66cc9fbd834efca9824c5fbd6
135 changes: 135 additions & 0 deletions dev-vcs/mercurial/mercurial-4.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,135 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic

DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"

RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments[${PYTHON_USEDEP}] )"

SITEFILE="70${PN}-gentoo.el"

PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )

python_prepare_all() {
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die

distutils-r1_python_prepare_all
}

python_configure_all() {
strip-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing

"${PYTHON}" setup.py build_mo || die
}

python_compile_all() {
rm -r contrib/{win32,macosx} || die
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
}

python_install_all() {
distutils-r1_python_install_all

newbashcomp contrib/bash_completion hg

insinto /usr/share/zsh/site-functions
newins contrib/zsh_completion _hg

rm -f doc/*.?.txt
dodoc CONTRIBUTORS
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die

dobin hgeditor
dobin contrib/hgk
python_foreach_impl python_doscript contrib/hg-ssh

if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi

local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
*.el mercurial.spec)
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/$f || die
done

dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib
doman doc/*.?

insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}

src_test() {
pushd tests &>/dev/null || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive* # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz
rm -f test-convert-cvs* # CVS
rm -f test-convert-darcs* # Darcs
rm -f test-convert-git* # git
rm -f test-convert-mtn* # monotone
rm -f test-convert-tla* # GNU Arch tla
#rm -f test-doctest* # doctest always fails with python 2.5.x
rm -f test-largefiles* # tends to time out

popd &>/dev/null || die
distutils-r1_src_test
}

python_test() {
local TEST_DIR

rm -rf "${TMPDIR}"/test
distutils_install_for_testing
cd tests || die
"${PYTHON}" run-tests.py --verbose \
--tmpdir="${TMPDIR}"/test \
--with-hg="${TEST_DIR}"/scripts/hg \
|| die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
use emacs && elisp-site-regen

elog "If you want to convert repositories from other tools using convert"
elog "extension please install correct tool:"
elog " dev-vcs/cvs"
elog " dev-vcs/darcs"
elog " dev-vcs/git"
elog " dev-vcs/monotone"
elog " dev-vcs/subversion"
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 89d768a

Please sign in to comment.