Skip to content

Commit

Permalink
Merge remote-tracking branch 'github/pr/266'
Browse files Browse the repository at this point in the history
  • Loading branch information
aballier committed Oct 30, 2015
2 parents dc18308 + 8d7cd07 commit 8a124c8
Show file tree
Hide file tree
Showing 3 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/libres3/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST libres3-1.1.tar.gz 7025033 SHA256 d4b3199db31844811290e8e9674bccd82c05e204537c499ac7d10d385b1cea13 SHA512 cdbefef90076f9f94f3b1635639a4b64e7666532ae6f51434d344e5c4ef1d4dce2787c52903ee5f0d6630ff84d8e79e14c843ac84d9e1affd2c1f16a41ffcfa3 WHIRLPOOL 015f7af705a58a21e8392661ca3ac9c0373803f4b588140af27f2d7706a8e0948fffeed26201ee9bd58f8e71bc0cde4557aaedbfc54f769c9564ebf7c6115a8d
79 changes: 79 additions & 0 deletions net-misc/libres3/libres3-1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

OASIS_BUILD_TESTS=1
inherit oasis findlib

DESCRIPTION="Skylable LibreS3 - Amazon S3 open source replacement"
HOMEPAGE="http://www.skylable.com/products/libres3"
SRC_URI="http://cdn.skylable.com/source/${P}.tar.gz"

LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
OASIS_DOC_DIR="/usr/share/doc/${PF}"

RDEPEND="
>=dev-lang/ocaml-4:=
dev-ml/camlp4:=
dev-ml/jsonm:=
dev-ml/lwt:=[react,ssl]
dev-ml/ocaml-base64:=
dev-ml/ocaml-dns:=[lwt(-)]
dev-ml/ocaml-ipaddr:=
dev-ml/ocaml-re:=
dev-ml/ocaml-ssl:=
>=dev-ml/ocamlnet-3.7.4:=[pcre]
<dev-ml/ocamlnet-4:=[pcre]
dev-ml/optcomp:=
dev-ml/ounit:=
dev-ml/pcre-ocaml:=
dev-ml/tyxml:=
dev-ml/uutf:=
dev-ml/xmlm:=
www-servers/ocsigenserver:=[sqlite]
"
DEPEND="
dev-ml/oasis
virtual/pkgconfig
${RDEPEND}
"

S="${WORKDIR}/${P}/libres3"

src_prepare() {
sed -e '/..\/..\/COPYING/d' -i _oasis || die
rm setup.ml || die
emake update
}

src_configure() {
oasis_configure_opts="
--sysconfdir ${EPREFIX}/etc/${PN}
--localstatedir ${EPREFIX}/var" oasis_src_configure
}

src_install() {
emake DESTDIR="${D}" install

if [[ -d /etc/logrotate.d ]]; then
insinto /etc/logrotate.d
doins src/files/conf/logrotate.d/libres3
fi
}

pkg_postinst() {
elog "*******************************************************************************"
elog "Just as a heads-up: LibreS3 requires a working SX cluster (net-misc/sx) to be"
elog "of any use. Since LibreS3 is capable of connecting to a remote SX cluster it"
elog "doesn't depend on it. Hence you will likely want to install it."
elog ""
elog "Standard S3 client libraries and tools (for example s3cmd, python-boto,"
elog "ocaml-aws, etc.) can be used to access it."
elog "Enjoy."
elog "*******************************************************************************"
}
12 changes: 12 additions & 0 deletions net-misc/libres3/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ml</herd>
<herd>proxy-maintainers</herd>
<maintainer>
<email>[email protected]</email>
</maintainer>
<longdescription lang="en">
LibreS3 adds an S3-compatibility layer over SX Cluster. With LibreS3 you access the data stored in your storage cluster using any existing S3 client.
</longdescription>
</pkgmetadata>

0 comments on commit 8a124c8

Please sign in to comment.