Skip to content

Commit

Permalink
dev-lang/go: 1.15.11 bump
Browse files Browse the repository at this point in the history
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
williamh committed Apr 2, 2021
1 parent d7048f7 commit 8a1eb68
Show file tree
Hide file tree
Showing 2 changed files with 198 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/go/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST go1.15.10.src.tar.gz 23021993 BLAKE2B 8143f7703d07d4793521bbb6b935b87ecd87df451cc5d03370a01bddabc284e85ec94a16fed378ee9ac8e3f0d6999402025bb1d6afa3c1810c6343205c4eb2d4 SHA512 4f0ceff8dc035ec50cd0d136678573f4d624bca6a19293d5ffd75868d94d264291e44519bc450e40e8de486ee44d720555550eecf86cbae1f0d64dee00f90764
DIST go1.15.11.src.tar.gz 23029946 BLAKE2B b937a8e350b6a30e71427d8cbc52edb73e11f055c16890c81ba4bf2f6aa90fd223f0af9517021741e791c22b78f840b3485ea8df4853865dceae354f4803c55d SHA512 52a107220f02197f07c0d3afef403c3762428c1f69107fa7123bc6cdf6b47dd4e65f2ab3979ad7d12a265b0c9bd0b66e6e50eb91f7fa994ba22882f117afe289
DIST go1.16.2.src.tar.gz 20905135 BLAKE2B 35fccc72604bf8cc7b1b5677d995b88e3232559e32af51f96a63bfc8cabecec09d885b5b8aa4b2ba03c481254da20dbf9bd83387091931c08a1c5c180c071931 SHA512 d14858a75cc7411975aaca705e66145287dc96b4fac1b1b06b95377dc5e5d2762f060973744114f42c780b34ea4baef7038c94616649c2dcc5c97e261cefc6bd
DIST go1.16.3.src.tar.gz 20912861 BLAKE2B da6752d06b86a5349a1bc11e7e4c61543fa75cf72d971fb7559c059b3d5d7721d4cba16ad63eeb00398c6e0c8b1b1d42f07c665182b4b70da83fe648f813eee0 SHA512 8808a3112a5bc89799491ed1aa1cb8744a5cc8d3cb5caa2a7dd711405266925093f90d437fccb66a48e5f994c7339077814f495a88baa7961e9cc9b0a6a838c7
197 changes: 197 additions & 0 deletions dev-lang/go/go-1.15.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,197 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}

MY_PV=${PV/_/}

inherit toolchain-funcs

case ${PV} in
*9999*)
EGIT_REPO_URI="https://github.com/golang/go.git"
inherit git-r3
;;
*)
SRC_URI="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz "
S="${WORKDIR}"/go
case ${PV} in
*_beta*|*_rc*) ;;
*)
KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
;;
esac
esac

DESCRIPTION="A concurrent garbage collected and typesafe programming language"
HOMEPAGE="https://golang.org"

LICENSE="BSD"
SLOT="0/${PV}"

BDEPEND="|| (
dev-lang/go
dev-lang/go-bootstrap )"
RDEPEND="!<dev-go/go-tools-0_pre20150902"

# Do not complain about CFLAGS, etc, since Go doesn't use them.
QA_FLAGS_IGNORED='.*'

# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"

# Do not strip this package. Stripping is unsupported upstream and may
# fail.
RESTRICT+=" strip"

DOCS=(
AUTHORS
CONTRIBUTING.md
CONTRIBUTORS
PATENTS
README.md
)

go_arch()
{
# By chance most portage arch names match Go
local portage_arch=$(tc-arch $@)
case "${portage_arch}" in
x86) echo 386;;
x64-*) echo amd64;;
ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
s390) echo s390x ;;
*) echo "${portage_arch}";;
esac
}

go_arm()
{
case "${1:-${CHOST}}" in
armv5*) echo 5;;
armv6*) echo 6;;
armv7*) echo 7;;
*)
die "unknown GOARM for ${1:-${CHOST}}"
;;
esac
}

go_os()
{
case "${1:-${CHOST}}" in
*-linux*) echo linux;;
*-darwin*) echo darwin;;
*-freebsd*) echo freebsd;;
*-netbsd*) echo netbsd;;
*-openbsd*) echo openbsd;;
*-solaris*) echo solaris;;
*-cygwin*|*-interix*|*-winnt*)
echo windows
;;
*)
die "unknown GOOS for ${1:-${CHOST}}"
;;
esac
}

go_tuple()
{
echo "$(go_os $@)_$(go_arch $@)"
}

go_cross_compile()
{
[[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
}

src_compile()
{
if has_version -b dev-lang/go; then
export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go"
elif has_version -b dev-lang/go-bootstrap; then
export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go-bootstrap"
else
eerror "Go cannot be built without go or go-bootstrap installed"
die "Should not be here, please report a bug"
fi

export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
export GOROOT="$(pwd)"
export GOBIN="${GOROOT}/bin"

# Go's build script does not use BUILD/HOST/TARGET consistently. :(
export GOHOSTARCH=$(go_arch ${CBUILD})
export GOHOSTOS=$(go_os ${CBUILD})
export CC=$(tc-getBUILD_CC)

export GOARCH=$(go_arch)
export GOOS=$(go_os)
export CC_FOR_TARGET=$(tc-getCC)
export CXX_FOR_TARGET=$(tc-getCXX)
if [[ ${ARCH} == arm ]]; then
export GOARM=$(go_arm)
fi

cd src
bash -x ./make.bash || die "build failed"
}

src_test()
{
go_cross_compile && return 0

cd src
PATH="${GOBIN}:${PATH}" \
./run.bash -no-rebuild || die "tests failed"
cd ..
rm -fr pkg/*_race || die
rm -fr pkg/obj/go-build || die
}

src_install()
{
# There is a known issue which requires the source tree to be installed [1].
# Once this is fixed, we can consider using the doc use flag to control
# installing the doc and src directories.
# The use of cp is deliberate in order to retain permissions
# [1] https://golang.org/issue/2775
dodir /usr/lib/go
cp -R api bin doc lib pkg misc src test "${ED}"/usr/lib/go
einstalldocs

# testdata directories are not needed on the installed system
rm -fr $(find "${ED}"/usr/lib/go -iname testdata -type d -print)

local bin_path
if go_cross_compile; then
bin_path="bin/$(go_tuple)"
else
bin_path=bin
fi
local f x
for x in ${bin_path}/*; do
f=${x##*/}
dosym ../lib/go/${bin_path}/${f} /usr/bin/${f}
done

# install the @golang-rebuild set for Portage
insinto /usr/share/portage/config/sets
newins "${FILESDIR}"/go-sets.conf go.conf
}

pkg_postinst() {
[[ -z ${REPLACING_VERSIONS} ]] && return
einfo "After ${CATEGORY}/${PN} is updated it is recommended to rebuild"
einfo "all packages compiled with previous versions of ${CATEGORY}/${PN}"
einfo "due to the static linking nature of go."
einfo "If this is not done, the packages compiled with the older"
einfo "version of the compiler will not be updated until they are"
einfo "updated individually, which could mean they will have"
einfo "vulnerabilities."
einfo "Run 'emerge @golang-rebuild' to rebuild all 'go' packages"
einfo "See https://bugs.gentoo.org/752153 for more info"
}

0 comments on commit 8a1eb68

Please sign in to comment.