Skip to content

Commit

Permalink
app-emulation/spice-vdagent: bump to 0.17.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
tamiko committed Jun 14, 2016
1 parent 6bb3a43 commit 8a280a2
Show file tree
Hide file tree
Showing 4 changed files with 72 additions and 11 deletions.
1 change: 1 addition & 0 deletions app-emulation/spice-vdagent/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST spice-vdagent-0.16.0.tar.bz2 128174 SHA256 5b951646e0bd996afda2d063e706fa2aad2655af5bdd1b6525260ab50be30f7d SHA512 033fe60f152daceb05b51963b78daf6f757d0ad26398f47479c957c5c0f1735e26019c05ef30e485317ba75dd1a57ee1bffbab20eb2c46614d88ed7401795a97 WHIRLPOOL b94a60e15eb0ea107e974ad68bd07296eec9e08840afb2e57da64b35f26a613637975791e1a615af260acf9345ec016564ab15d96a00443665b5d1880b267d71
DIST spice-vdagent-0.17.0.tar.bz2 130413 SHA256 f14a8bd8cdee10641aabd9ba32461a5844eab0fddb2a10c1d31386e7a9f7b33d SHA512 b26e44f6463ba70d5815956b301cc2351db22de41ed2ce8b2828d9bfa1cc581c86acd433f8f0d35d552d20f6ca140f88fa39b079ba26e9166dc07ad35bee502e WHIRLPOOL b83d034897c0a9ebc224072214081847ab0276edde82ad0d94d107421971fe64afc03ba3f7464735911fd57cf7a05b0cfcb0ecbb32eb4d55adc8abcf23fe8d09
7 changes: 0 additions & 7 deletions app-emulation/spice-vdagent/files/spice-vdagent.confd

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
# Copyright 1999-2011 Gentoo Foundation
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -10,22 +10,33 @@ depend() {
PIDFILE="/var/run/spice-vdagentd/spice-vdagentd.pid"

start() {
PORT="${PORT:-/dev/virtio-ports/com.redhat.spice.0}"
DEVICE="${DEVICE:-/dev/uinput}"

ebegin "Checking for required modules and devices"

if [[ ! -d /sys/module/uinput ]] ; then
if [ ! -d /sys/module/uinput ]; then
modprobe -q uinput
fi

if [ ! -d /sys/module/uinput ]; then
eerror "Module 'uinput' not loaded or not enabled in the kernel"
eend 1
return 1
fi

if [[ ! -c "${PORT}" ]] ; then
if [ ! -c "${PORT}" ] ; then
eerror "Required virtio port does not exist. Make sure you"
eerror "started the virtual machine with appropriate parameters."
eend 1
return 1
fi
eend 0

if [ ! -c ${DEVICE} -a -c /dev/input/uinput ]; then
DEVICE=/dev/input/uinput
fi

# recreate the directory since /var/run may reside on a ramdisk
mkdir -p /var/run/spice-vdagentd

Expand All @@ -37,7 +48,7 @@ start() {
--start \
--pidfile "${PIDFILE}" \
--exec /usr/sbin/spice-vdagentd \
-- ${SPICE_VDAGENT_ARGS}
-- -u "${DEVICE}" ${SPICE_VDAGENT_ARGS}
eend $?
}

Expand Down
56 changes: 56 additions & 0 deletions app-emulation/spice-vdagent/spice-vdagent-0.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit linux-info

DESCRIPTION="SPICE VD Linux Guest Agent"
HOMEPAGE="http://spice-space.org/"
SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+consolekit selinux systemd"

CDEPEND="media-libs/alsa-lib
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libX11
x11-libs/libXinerama
>=x11-libs/libpciaccess-0.10
>=app-emulation/spice-protocol-0.12.8
consolekit? ( sys-auth/consolekit sys-apps/dbus )
systemd? ( sys-apps/systemd )"
DEPEND="virtual/pkgconfig
${CDEPEND}"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-vdagent )"

CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
ERROR_INPUT_UINPUT="User level input support is required"
ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support is required"

src_configure() {
local opt="--with-session-info=none --with-init-script=systemd"

use systemd && opt+=" --with-session-info=systemd"
use consolekit && opt+=" --with-session-info=console-kit"

econf \
--localstatedir=/var \
${opt}
}

src_install() {
default

rm -rf "${D}"/etc/{rc,tmpfiles}.d

keepdir /var/log/spice-vdagentd

newinitd "${FILESDIR}/${PN}.initd-3" "${PN}"
newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
}

0 comments on commit 8a280a2

Please sign in to comment.