Skip to content

Commit

Permalink
dev-php/pecl-mongodb: bump to v1.10.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.21, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jul 24, 2021
1 parent 5fe6703 commit 8a298ff
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-mongodb/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mongodb-1.10.0.tgz 1331177 BLAKE2B 8593392d50fce99059888e25d6400d2e7a35e93a1e4b74abf9b427ff43dbd2484380ecdbd7b7ce6abec643351a9c3bba572e2e0b551a88b18efbcf4c2b133767 SHA512 72527087dc3d1e1d48d6236592c1fbafa68354e2b8e070e85180d79ffcaa82740641450808a235bb711ded16ff65ec0cbd53fb66f0da18837351a3d402c3976f
DIST mongodb-1.7.4.tgz 1223416 BLAKE2B 9db40284eb2b70e242f26c1661923c5f33de8ab1e33a7e816863b61fcbc49040204ca556b1f384cab958f9dc2cf4e49e97840b78bd520a4e374b83210a964e5d SHA512 6805ce1d0958e24e1edf3bc9698bc1f4a9d31c26250624fd35aebf7a7d310af30050e1974cd9571f989303fce4c5522e793a8cb41388397df66e8f5fe0a648f2
DIST mongodb-1.7.5.tgz 1223892 BLAKE2B c30a217d1170c31be00259f4bb58cfea186947fa0bf1653de32e228a8eb8d3fb25b52d7a5a9e16f6b311418d977f7aa00bf96ca9d7e9ac9a8fa7b6fe05eace8f SHA512 f0565adc42659d4070e42122d02a8306f29d6d70fe0b5e9a92144df346a8c672aafdf36613435b9dc8d50db5e98c2359fdf97408c45439d4d447257b85e93122
DIST mongodb-1.8.0.tgz 1292928 BLAKE2B 3bd9e5eb6b981010637b9e478928fa21268e1d1447f3ff345bfdb45c93637990e261c46b2ce09560cd4e284df73494dac210436cf700b588803e4ceffb8dc67c SHA512 7fd54dabde8df9533abd36d159c3da1c2b4606e7788b8a6d41faf83d0710b74885e8bfb4e1f4837a50248f3af1df2e7414b90f99227fc92c9084f779c7e68698
Expand Down
54 changes: 54 additions & 0 deletions dev-php/pecl-mongodb/pecl-mongodb-1.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PHP_EXT_NAME="mongodb"
USE_PHP="php7-3 php7-4 php8-0"

inherit php-ext-pecl-r3

DESCRIPTION="MongoDB database driver for PHP"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="sasl test"

PHP_DEPEND="
php_targets_php7-3? ( dev-lang/php:7.3[json,ssl,zlib] )
php_targets_php7-4? ( dev-lang/php:7.4[json,ssl,zlib] )
php_targets_php8-0? ( dev-lang/php:8.0[ssl,zlib] )"
COMMON_DEPEND="${PHP_DEPEND}
>=dev-libs/libbson-1.18.0
>=dev-libs/mongo-c-driver-1.18.0[sasl?,ssl]
dev-libs/openssl:0=
sasl? ( dev-libs/cyrus-sasl )"
DEPEND="${COMMON_DEPEND}
test? ( dev-db/mongodb )"
RDEPEND="${COMMON_DEPEND}"
BDEPEND="${PHP_DEPEND}
virtual/pkgconfig"

# No tests on x86 because tests require dev-db/mongodb which don't support
# x86 anymore (bug #645994)
RESTRICT="x86? ( test )
!test? ( test )"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-mongodb
--with-libbson
--with-libmongoc
--with-mongodb-sasl=$(usex sasl)
)
php-ext-source-r3_src_configure
}

src_test() {
local PORT=27017
mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
--dbpath="${T}" --logpath="${T}/mongod.log" || die
php-ext-pecl-r3_src_test
kill $(<"${T}/mongod.lock")
}

0 comments on commit 8a298ff

Please sign in to comment.