Skip to content

Commit

Permalink
dev-python/lmdb: Bump to 1.1.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 5, 2021
1 parent 37d3c22 commit 8a70a7a
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/lmdb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lmdb-1.0.0.tar.gz 876673 BLAKE2B 33fdf7dd344e42412b756f7c6d42c291f94bb2410366802b22b8045c8ae5ff4f73f41cdc655e750f0ccb9f547f70b190bb9b584d7858edd07c1fb274bff684eb SHA512 3a4dba711ce5a3795a7f916cf04d5c7e9d4b5df30161dcbd02b53bcec73b96450865fb2bd8fe4a9ca2b5060531d03cefd9ea19aa09f139f93c3d03b2516f5632
DIST lmdb-1.1.0.tar.gz 880212 BLAKE2B 5f038c704061bb7915b0b0926c2dc60a5dd4931a70a1bf1041508363e036ae0553e22c52f8c956bebb05a27fad751c3b84c4a2b9fd6158fd8b6bd346e3efe7b4 SHA512 19573626a24fcea17c72641ce4491cf9e0901fa4a463ad5da6244191f28e4d9680d903fc2f87fe4a6b607f2a6a3a6bc644d5c1fc6e568394eb9822face30dfae
35 changes: 35 additions & 0 deletions dev-python/lmdb/lmdb-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( pypy3 python3_{7..9} )

inherit distutils-r1

DESCRIPTION="Python bindings for the Lightning Database"
HOMEPAGE="https://github.com/jnwatson/py-lmdb/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="OPENLDAP"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"

RDEPEND="dev-db/lmdb:="
DEPEND="${RDEPEND}"

distutils_enable_sphinx docs
distutils_enable_tests pytest

python_compile() {
LMDB_FORCE_SYSTEM=1 distutils-r1_python_compile
}

python_test() {
pytest tests -vv || die "Tests fail with ${EPYTHON}"
}

python_install() {
# This is required when the CFFI extension is used (for PyPy3)
LMDB_FORCE_SYSTEM=1 distutils-r1_python_install
}

0 comments on commit 8a70a7a

Please sign in to comment.