Skip to content

Commit

Permalink
media-plugins/grilo-plugins: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
pacho2 committed Nov 15, 2015
1 parent cc34394 commit 8a99cb4
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/grilo-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST grilo-plugins-0.2.12.tar.xz 721592 SHA256 15bed8a633c81b251920ab677d455433e641388f605277ca88e549cc89012b48 SHA512 37865fea88b2927482490481f07d830e6cbd89c886e20b2986931215099bc9b6b46600ac45e0c72c6ff2d8f9e273ca5cd4ad42195436b540118c483d1cb5bd8e WHIRLPOOL 27006aa66002770c55be9c8f9d4302f1b60524096a11ad27731a3fcb57e4e4a55a0be6809808d14c441e4bdc005753fd55657fb9df83c149a420eacc29276c91
DIST grilo-plugins-0.2.13.tar.xz 999896 SHA256 a5544831ba81a4e7caea30da89874fd20142a362d389366e1113d0e64be51201 SHA512 5ec97ea16fc13c13090d58067bc982176967f49b7f996b2ee75fe2c915bfdaf96fb780730b9aeca3ba1e7d566526b7c7423a238b0285b0f60b97ad66b1cb0e03 WHIRLPOOL ef0cadaf229d02083efe6375db2ef335b88b9f46a29d671713957625868a30294952e538cb280de387d5078823ebd2f6d80ddb76d2ebed81008d53b44d3e62f5
DIST grilo-plugins-0.2.14.tar.xz 1036824 SHA256 d0f18116675058c7e8c178b1fe26d6d73998a0452f85a73b1696df740c83d3ab SHA512 d4caddb5a710f19365d1d9e890b1d525b96e78cf2228a886f1b2c66e60601c2bef61791007d0d9cc8d3b306aac3065c0ff618ef522c7971885c95ca2e365c69b WHIRLPOOL 40899069c626a4183a9cf2afe94f8290dd39bd0bed8475b5d0732d3aa2521eb6fb6f275fba38d47b0614a9e16501f63ee0c5180dd88082ceb14bff0867f7cfe5
DIST grilo-plugins-0.2.16.tar.xz 1027924 SHA256 80b4571f9db6df0d5f0873d30f2ee475204f5831d2974b89c58423d6ffac5203 SHA512 5f06c15a8cdaecca06d87f2c079d5b9b21de8aca2f0c78432225edda0dcf114403e42245cd3c300b63303b7f03defe53b3067fa24d17896a04bd4dfa9cce0000 WHIRLPOOL 10377791776b006def732c22f3f956b51d7d427f13368bd738a03c3e4ce058ec562a2d0f3f99159a7264fa51b93bfbd99196ceba7d4268758360f4573adde06a
93 changes: 93 additions & 0 deletions media-plugins/grilo-plugins/grilo-plugins-0.2.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
GNOME2_LA_PUNT="yes"

inherit gnome2

DESCRIPTION="A framework for easy media discovery and browsing"
HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"

LICENSE="LGPL-2.1+"
SLOT="0.2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="daap +dvd flickr freebox gnome-online-accounts lua subtitles thetvdb tracker upnp-av +vimeo +youtube"

# Bump gom requirement to avoid segfaults
RDEPEND="
>=dev-libs/glib-2.36:2
>=media-libs/grilo-0.2.12:${SLOT}[network,playlist]
media-libs/libmediaart:2.0
>=dev-libs/gom-0.3.1
dev-libs/gmime:2.6
dev-libs/json-glib
dev-libs/libxml2:2
dev-db/sqlite:3
daap? ( >=net-libs/libdmapsharing-2.9.12:3.0 )
dvd? ( >=dev-libs/totem-pl-parser-3.4.1 )
flickr? ( net-libs/liboauth )
freebox? ( net-dns/avahi )
gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.91 )
lua? (
>=dev-lang/lua-5.3
app-arch/libarchive )
subtitles? ( net-libs/libsoup:2.4 )
thetvdb? (
app-arch/libarchive
dev-libs/libxml2 )
tracker? ( >=app-misc/tracker-0.10.5:= )
youtube? (
>=dev-libs/libgdata-0.9.1:=
dev-libs/totem-pl-parser )
upnp-av? (
net-libs/libsoup:2.4
net-libs/dleyna-connector-dbus )
vimeo? (
dev-libs/totem-pl-parser )
"
DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.5
app-text/yelp-tools
>=dev-util/intltool-0.40.0
virtual/pkgconfig
"

# FIXME: some unittests required python-dbusmock
src_configure() {
# --enable-debug only changes CFLAGS, useless for us
# Plugins
# shoutcast seems to be broken
gnome2_src_configure \
--disable-static \
--disable-debug \
--disable-uninstalled \
--enable-bookmarks \
--enable-filesystem \
--enable-gravatar \
--enable-jamendo \
--enable-lastfm-albumart \
--enable-localmetadata \
--enable-magnatune \
--enable-metadata-store \
--enable-podcasts \
--enable-raitv \
--disable-shoutcast \
--enable-tmdb \
$(use_enable daap dmap) \
$(use_enable dvd optical-media) \
$(use_enable flickr) \
$(use_enable freebox) \
$(use_enable gnome-online-accounts goa) \
$(use_enable lua lua-factory) \
$(use_enable subtitles opensubtitles) \
$(use_enable thetvdb) \
$(use_enable tracker) \
$(use_enable upnp-av dleyna) \
$(use_enable vimeo) \
$(use_enable youtube)
}

0 comments on commit 8a99cb4

Please sign in to comment.