Skip to content

Commit

Permalink
dev-python/ply: Add python3.5 support
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 11, 2015
1 parent 7ef3814 commit 8ad387a
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-python/ply/ply-3.8-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Python Lex-Yacc library"
HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.python.org/pypi/ply"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
IUSE="examples"

RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

# See bug #458648 for reference
RESTRICT="test"

DOCS=( ANNOUNCE CHANGES TODO )

PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )

python_test() {
cp -r -l test "${BUILD_DIR}"/ || die
cd "${BUILD_DIR}"/test || die

local t
for t in testlex.py testyacc.py; do
"${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
done
}

python_install_all() {
local HTML_DOCS=( doc/. )
use examples && local EXAMPLES=( example/. )
distutils-r1_python_install_all
}

0 comments on commit 8ad387a

Please sign in to comment.