forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/indent: Add Debian patch level, use strip-linguas, convert s…
…ed scripts. Package-Manager: Portage-2.3.11, Repoman-2.3.3
- Loading branch information
Jeroen Roovers
committed
Oct 13, 2017
1 parent
45ff74c
commit 8af2819
Showing
4 changed files
with
78 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST indent-2.2.11.tar.gz 778563 SHA256 aaff60ce4d255efb985f0eb78cca4d1ad766c6e051666073050656b6753a0893 SHA512 f5670e5edc76b9d599ef9e8cc498e13ac15e10eb6a8d674e1612918c4b67ffb15c94d73b9590434e0cdea6ead4b8d1f5bcda1c2f3838acbdeb4d732a0bea89be WHIRLPOOL b50d6af34af8e08febde01fc70a280e8fdce0eb25b2e7e23f9d20bf08afc055c98b01c28f971c05bf4f8f52d9a70af10265329b5e146b2c6e64481aecb9fb8ad | ||
DIST indent_2.2.11-5.debian.tar.xz 6540 SHA256 74accb95981a28b823f9b3d582b4a01daa3500fd0bf2596218f99db4a1a950e1 SHA512 f89f04bb3b9772c5428ef6df939b5cbe92761f3a39869020dad4f98a5e48c57c34de526803141258c9d55ba6edaedf05127009530aa09b1a54cfa15c8a421a31 WHIRLPOOL d2fd540285de5dcccf207c867dcef05b99861da123cf6bc2b717f91e9e2ba0e498b31f8d1b45cfcce6b29bbd2a2a1ddbad20b4b3d1c2976ed47a7bbd07222722 |
11 changes: 11 additions & 0 deletions
11
dev-util/indent/files/indent-2.2.11-ac_config_headers.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -3,7 +3,7 @@ | ||
AC_CONFIG_SRCDIR(src/indent.c) | ||
AC_CONFIG_AUX_DIR(config) | ||
AM_INIT_AUTOMAKE(indent, 2.2.11) | ||
-AM_CONFIG_HEADER(config.h) | ||
+AC_CONFIG_HEADERS(config.h) | ||
|
||
AM_MAINTAINER_MODE | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
--- a/po/LINGUAS | ||
+++ b/po/LINGUAS | ||
@@ -1 +1 @@ | ||
-ca da de eo et fi fr gl hu it ja ko nl pl pt_BR ru sk sv tr zh_TW.Big5 | ||
+ca da de eo et fi fr gl hu it ja ko nl pl pt_BR ru sk sv tr zh_TW |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit autotools eutils | ||
|
||
DESCRIPTION="Indent program source files" | ||
HOMEPAGE="https://www.gentoo.org/" | ||
SRC_URI=" | ||
https://dev.gentoo.org/~jer/${P/_p*/}.tar.gz | ||
http://http.debian.net/debian/pool/main/i/${PN}/${PN}_${PV/_p*/}-${PV/*_p/}.debian.tar.xz | ||
" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris" | ||
IUSE="nls" | ||
|
||
DEPEND=" | ||
nls? ( sys-devel/gettext ) | ||
app-text/texi2html | ||
" | ||
RDEPEND=" | ||
nls? ( virtual/libintl ) | ||
" | ||
PATCHES=( | ||
"${FILESDIR}"/${P/_p*/}-segfault.patch | ||
"${FILESDIR}"/${P/_p*/}-texi2html-5.patch | ||
"${FILESDIR}"/${P/_p*/}-ac_config_headers.patch | ||
"${FILESDIR}"/${P/_p*/}-linguas.patch | ||
) | ||
S=${WORKDIR}/${P/_p*/} | ||
|
||
src_prepare() { | ||
default | ||
|
||
eapply "${WORKDIR}"/debian/patches/*.patch | ||
|
||
local pofile | ||
for pofile in po/zh_TW*; do | ||
mv ${pofile} ${pofile/.Big5} || die | ||
done | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
strip-linguas -i po/ | ||
|
||
econf $(use_enable nls) | ||
} | ||
|
||
src_test() { | ||
emake -C regression/ | ||
} | ||
|
||
src_install() { | ||
# htmldir as set in configure is ignored in doc/Makefile* | ||
emake DESTDIR="${D}" htmldir="${EPREFIX}/usr/share/doc/${PF}/html" install | ||
dodoc AUTHORS NEWS README ChangeLog ChangeLog-1990 ChangeLog-1998 ChangeLog-2001 | ||
} |