Skip to content

Commit

Permalink
dev-libs/wayland: version bump to 1.8.1 #556880
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Aug 16, 2015
1 parent ef84bdb commit 8aff38e
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/wayland/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,3 +9,4 @@ DIST wayland-1.5.0.tar.xz 404644 SHA256 0069e1e9af888b3e05384380ad8cc6c976ea3e81
DIST wayland-1.6.0.tar.xz 415192 SHA256 a7d5102dcf53d08c059d24bc62de491d7cd482070abeb6737a20d0d86ba6fc7f SHA512 11fc8cb90f00a07b9952c073f1d18bf53284a46b4cc3aa5c71ed33cf509fca0cdf45afbdb852461a7fae236424b1be0e5314a2bbde8a59de2ab81246960da055 WHIRLPOOL 376a4023e47cf5ce624b4d724386b5b8e6cce0696bed8103301cf72fa816bd144e5f3f346a71a3776a1ee922f52fd26060d5b021bf0c7d2ee68fefbe0fe4ea1e
DIST wayland-1.6.1.tar.xz 418628 SHA256 d1aeb95b433cab33a928b56cb80efa551802e0a064adb4a8ea1517249d3c10b0 SHA512 28a0980ece2fb4ba0ca688f3913ffba34c2741167d7686be80cfbc9cb56f995282a68173d69d2849eb5c2986684ebe6d5cfaca04518ab74a4512c8dfb4d8d0c2 WHIRLPOOL be307a292c8f939921700fc85c9ad1675c491fdc3e1a16ffc52512e39d971f6afdbd378c60c57a64781cdccb364ed77271e07b64f5c3b7b96abd45a1595dfc4e
DIST wayland-1.7.0.tar.xz 372004 SHA256 bdea47a2db96f7e53f1ce0351559c0af5b7f7aae7e95f0a884a78af9f1057c9c SHA512 2475a5e8c2ef5c4bc97d90f946a89e4155d840a342886a7634df5423e5764973dbf5d721e1a8a941b7bd2305017cdcb74af7a29bee7bb8b58373306e5c03add7 WHIRLPOOL 152be0d1c3ac314cd3dcd765e6a04eaa71b618b1577c423147ccb5b1d82cdeaf09d09c8933746e6bd100b2d59374749084eede36b9075a153328fda179955ea2
DIST wayland-1.8.1.tar.xz 374116 SHA256 f17c938d1c24fd0a10f650a623a2775d329db3168b5732e498b08388ec776fc8 SHA512 392edd22203fc44a37a66d7a099d0534f047f49e91b28614092346f0167c07a39431c5919f2ea1deaf460dc53a77fba8504a7a7f5d03af638267c767bb07ae19 WHIRLPOOL f15ea109324c0c84b848f458acb6786248fb1c7ee8dafd6ef945d4f80f5b87b911dd2d2c0485b1ceeeed95454990e186e7d8b04d366f903954dd8998a1f3999f
62 changes: 62 additions & 0 deletions dev-libs/wayland/wayland-1.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
AUTOTOOLS_AUTORECONF=1
fi

inherit autotools-multilib toolchain-funcs $GIT_ECLASS

DESCRIPTION="Wayland protocol libraries"
HOMEPAGE="http://wayland.freedesktop.org/"

if [[ ${PV} == 9999* ]]; then
SRC_URI="${SRC_PATCHES}"
else
SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
fi

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="doc static-libs"

RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
>=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
doc? (
>=app-doc/doxygen-1.6[dot]
app-text/xmlto
>=media-gfx/graphviz-2.26.0
sys-apps/grep[pcre]
)
virtual/pkgconfig"

src_configure() {
local myeconfargs=(
$(use_enable static-libs static)
$(use_enable doc documentation)
)
if tc-is-cross-compiler ; then
myeconfargs+=( --disable-scanner )
fi
if ! multilib_is_native_abi; then
myeconfargs+=( --disable-documentation )
fi

autotools-multilib_src_configure
}

src_test() {
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die

autotools-multilib_src_test
}

0 comments on commit 8aff38e

Please sign in to comment.