forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Ben Kohler <[email protected]>
- Loading branch information
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST udiskie-1.7.7.tar.gz 91858 BLAKE2B 7d9729f8c66e0d9afdf2b89f5cc2a941ce6726c809af1069146f13466eccdfa54ed45f43535d84592f1b09ccf6454814d7ff62d453781c547ebfb989fcab7767 SHA512 ea192cc8a50c742e96d5163bb1378a7cd110599cfe731d676343766a1ce3ee1102ab43322c5f9666d6c6a232e310fd494e0f76ad33aeab1fd8225a3267f3193a | ||
DIST udiskie-2.0.0.tar.gz 85363 BLAKE2B d8f02f3fe865781b5a398235d1aea537c4828e72d01953e50a640389cfae64efc34421c6fdcce17b278b356629abac2ed54de9d27ae7b361b014b719ca6581cb SHA512 ca9a20d6095cbf4d53f94aacfe3284c5145f395be1d2fbcb1183522ea91428b7840d41b11f885b97b24ca70f0bdb7139b5c34039c35e0b690fa3be24c258bf9d | ||
DIST udiskie-2.0.1.tar.gz 85512 BLAKE2B 7e01c2d38c24b21c5b8f715dc0427295948958d20ac170798e5ffd119063f54992b6f9d9066e6ad587147d76795505b82e6a2d7f56cd4dbe65871f203a37b22f SHA512 91f2ea9efb13c535c1235cd0e7cfc8f083845b4c9ac6f37ca52be4b652b4be9d89486f72b7584d07b2eef19ce1b7f4a6248bcafdaec0bc50cc338ccf47c1f410 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python3_{6,7} ) | ||
inherit distutils-r1 gnome2-utils | ||
|
||
DESCRIPTION="An automatic disk mounting service using udisks" | ||
HOMEPAGE="https://pypi.org/project/udiskie/ https://github.com/coldfix/udiskie" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="dev-python/docopt[${PYTHON_USEDEP}] | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
dev-python/pyxdg[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
sys-fs/udisks:2" | ||
DEPEND="app-text/asciidoc | ||
dev-python/setuptools[${PYTHON_USEDEP}]" | ||
|
||
src_prepare() { | ||
sed -i -e 's:gtk-update-icon-cache:true:' setup.py || die | ||
default | ||
|
||
distutils-r1_src_prepare | ||
} | ||
|
||
src_compile() { | ||
distutils-r1_src_compile | ||
emake -C doc | ||
} | ||
|
||
src_install() { | ||
distutils-r1_src_install | ||
doman doc/${PN}.8 | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |