forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-plugins/vdr-epgsearch: bump; closed bug 623576, thx to M.Brakem…
…eier Package-Manager: Portage-2.3.48, Repoman-2.3.10
- Loading branch information
Showing
3 changed files
with
109 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST vdr-epgsearch-1.0.1_p20141227.tar.gz 472802 BLAKE2B 9ffc067c2aff29e3d79b620edf88ff7aca64ad5d1de3aa32b19fbc1889673e2439a6d65b46e2f3ff5fd3d416ff24cbafd6d41f562b3775210f0234c6990f03ab SHA512 952d58f6f03d2804f97be14779faf37c3788b42d78a6460102e2f1c74f6a58d7d68639e7e95e40f27417ce3658c0d5bf856399b6e8e8c214ea143d2865507562 | ||
DIST vdr-epgsearch-2.2.0.tgz 472502 BLAKE2B f98053d95a6fe56aff48bd3e86ae8a37166b3b8556fe3500c956901cb3f8d19c5792b157606d372392b7387c05a72f4d664881a27bbd5b9484640d8de73b8673 SHA512 c0fef60069addc3cca82535c22b7e1f73f01de7466bc6d0b837ba34df7a7dd0fe2cbf7e9b9bc36a523a75a3db18889a1ff9040fb2647c889ea74666067c3a1e4 |
25 changes: 25 additions & 0 deletions
25
media-plugins/vdr-epgsearch/files/vdr-epgsearch-2.2.0_makefile.diff
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
diff -Naur vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile | ||
--- vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile 2015-02-21 21:01:08.926052710 +0100 | ||
+++ vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile 2015-02-21 21:03:42.768052710 +0100 | ||
@@ -255,9 +255,9 @@ | ||
docs: | ||
./docsrc2man.sh | ||
./docsrc2html.sh | ||
- ln -sf ./doc/en/epgsearch.4.txt MANUAL | ||
- ln -sf ./doc/en/epgsearch.1.txt README | ||
- ln -sf ./doc/de/epgsearch.1.txt README.DE | ||
+# ln -sf ./doc/en/epgsearch.4.txt MANUAL | ||
+# ln -sf ./doc/en/epgsearch.1.txt README | ||
+# ln -sf ./doc/de/epgsearch.1.txt README.DE | ||
|
||
install-$(PLUGIN): libvdr-$(PLUGIN).so | ||
install -D libvdr-$(PLUGIN).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) | ||
@@ -272,7 +272,7 @@ | ||
install -D libvdr-$(PLUGIN4).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN4).so.$(APIVERSION) | ||
|
||
install-conf: | ||
- mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)/conf.d | ||
+ mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN) | ||
cp -n conf/* $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN) | ||
|
||
install-doc: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,83 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit vdr-plugin-2 | ||
|
||
DESCRIPTION="VDR plugin: create timers from epg content based on saved search expressions" | ||
HOMEPAGE="https://projects.vdr-developer.org/git/vdr-plugin-epgsearch.git" | ||
SRC_URI="https://projects.vdr-developer.org/git/vdr-plugin-${VDRPLUGIN}.git/snapshot/vdr-plugin-${VDRPLUGIN}-${PV}.tar.gz -> ${P}.tgz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+conflictcheckonly +epgsearchonly pcre +quicksearch tre" | ||
|
||
DEPEND="=media-video/vdr-2.2* | ||
pcre? ( dev-libs/libpcre ) | ||
tre? ( dev-libs/tre )" | ||
RDEPEND="${DEPEND}" | ||
|
||
REQUIRED_USE="?? ( pcre tre )" | ||
|
||
S="${WORKDIR}/vdr-plugin-${VDRPLUGIN}-${PV}" | ||
|
||
src_prepare() { | ||
# make detection in vdr-plugin-2.eclass for new Makefile handling happy | ||
echo "# SOFILE" >> Makefile | ||
|
||
# remove untranslated .po files | ||
rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po | ||
|
||
eapply "${FILESDIR}/${P}_makefile.diff" | ||
|
||
use conflictcheckonly || sed -e "s:install-\$(PLUGIN3)::" -i Makefile | ||
use epgsearchonly || sed -e "s:install-\$(PLUGIN2)::" -i Makefile | ||
use quicksearch || sed -e "s:install-\$(PLUGIN4)::" -i Makefile | ||
|
||
vdr-plugin-2_src_prepare | ||
|
||
fix_vdr_libsi_include conflictcheck.c | ||
|
||
# install conf-file disabled | ||
sed -e '/^Menu/s:^:#:' -i conf/epgsearchmenu.conf | ||
|
||
# Get rid of the broken symlinks | ||
rm -f README{,.DE} MANUAL | ||
} | ||
|
||
src_compile() { | ||
BUILD_PARAMS="SENDMAIL=/usr/sbin/sendmail AUTOCONFIG=0" | ||
|
||
if use pcre; then | ||
BUILD_PARAMS+=" REGEXLIB=pcre" | ||
einfo "Using pcre for regexp searches" | ||
fi | ||
|
||
if use tre; then | ||
BUILD_PARAMS+=" REGEXLIB=tre" | ||
einfo "Using tre for unlimited fuzzy searches" | ||
fi | ||
|
||
vdr-plugin-2_src_compile | ||
} | ||
|
||
src_install() { | ||
vdr-plugin-2_src_install | ||
|
||
diropts "-m755 -o vdr -g vdr" | ||
keepdir /etc/vdr/plugins/epgsearch | ||
insinto /etc/vdr/plugins/epgsearch | ||
|
||
doins conf/epgsearchmenu.conf | ||
doins conf/epgsearchconflmail.templ conf/epgsearchupdmail.templ | ||
|
||
nonfatal dodoc conf/*.templ HISTORY* | ||
|
||
gunzip -f man/en/*.gz | ||
doman man/en/*.[0-9] | ||
|
||
gunzip -f man/de/*.gz | ||
doman -i18n=de man/de/*.[0-9] | ||
} |