Skip to content

Commit

Permalink
sci-geosciences/routino: making QA checks happy
Browse files Browse the repository at this point in the history
Suggested-by:  Fabio Rossi <[email protected]>
Closes: https://bugs.gentoo.org/628398
Package-Manager: Portage-2.3.11, Repoman-2.3.3
  • Loading branch information
Andrey Grozin committed Oct 24, 2017
1 parent 784e7fa commit 8b549d5
Show file tree
Hide file tree
Showing 4 changed files with 89 additions and 23 deletions.
38 changes: 30 additions & 8 deletions sci-geosciences/routino/files/routino-3.1.1.patch
Original file line number Diff line number Diff line change
@@ -1,17 +1,22 @@
diff -r -U1 routino-3.1.1.orig/Makefile.conf routino-3.1.1/Makefile.conf
--- routino-3.1.1.orig/Makefile.conf 2016-03-05 19:49:21.000000000 +0600
+++ routino-3.1.1/Makefile.conf 2016-07-16 20:09:22.208869580 +0600
@@ -47,3 +47,3 @@
--- routino-3.1.1/Makefile.conf 2017-10-22 15:55:10.420531850 +0200
+++ routino-3.1.1/Makefile.conf.new 2017-10-22 15:55:32.180533067 +0200
@@ -45,11 +45,11 @@
# Installation locations (edit if required)

ifneq ($(HOST),MINGW)
-prefix=/usr/local
+prefix=/usr
bindir=$(prefix)/bin
@@ -51,3 +51,3 @@
incdir=$(prefix)/include
libdir=$(prefix)/lib
-docdir=$(prefix)/doc/routino
+docdir=$(prefix)/share/doc/$(PF)
datadir=$(prefix)/share/routino
@@ -76,6 +76,6 @@
else
prefix="c:/Program Files/Routino"
@@ -74,16 +74,16 @@


# Maths library
-LDFLAGS=-lm
+LDFLAGS+=-lm
Expand All @@ -20,15 +25,32 @@ diff -r -U1 routino-3.1.1.orig/Makefile.conf routino-3.1.1/Makefile.conf
-CFLAGS=-std=c99
+CFLAGS+=-std=c99

@@ -85,3 +85,3 @@
# Warning options
CFLAGS+=-Wall -Wmissing-prototypes -Wextra -Wno-unused-parameter -pedantic

# Optimisation options
-CFLAGS+=-O3
+#CFLAGS+=-O3
CFLAGS+=-ffast-math
@@ -141,4 +141,4 @@

# Optimisation option (only works if compilation and execution use exactly the same CPU architecture).
@@ -118,7 +118,7 @@
endif

# Put the current directory in the shared library path for the router using libroutino
-LDFLAGS_LDSO=-Wl,-R.
+#LDFLAGS_LDSO=-Wl,-R.


# Required for multi-threaded support (comment these two lines out if not required)
@@ -139,8 +139,8 @@


# Required for xz support (uncomment these two lines if required)
-#CFLAGS+=-DUSE_XZ
-#LDFLAGS+=-llzma
+CFLAGS+=-DUSE_XZ
+LDFLAGS+=-llzma


# Required to use stdio with files > 2GiB on 32-bit system.
42 changes: 34 additions & 8 deletions sci-geosciences/routino/files/routino-3.2.patch
Original file line number Diff line number Diff line change
@@ -1,30 +1,56 @@
diff -r -U1 routino-3.2.orig/Makefile.conf routino-3.2/Makefile.conf
--- routino-3.2.orig/Makefile.conf 2016-11-22 20:22:52.000000000 +0100
+++ routino-3.2/Makefile.conf 2017-04-01 23:58:23.835905270 +0200
@@ -47,3 +47,3 @@
--- routino-3.2/Makefile.conf 2017-10-22 16:03:29.917559780 +0200
+++ routino-3.2/Makefile.conf.new 2017-10-22 16:04:23.877562797 +0200
@@ -45,11 +45,11 @@
# Installation locations (edit if required)

ifneq ($(HOST),MINGW)
-prefix=/usr/local
+prefix=/usr
bindir=$(prefix)/bin
@@ -51,3 +51,3 @@
incdir=$(prefix)/include
libdir=$(prefix)/lib
-docdir=$(prefix)/doc/routino
+docdir=$(prefix)/share/doc/$(PF)
datadir=$(prefix)/share/routino
@@ -79,3 +79,3 @@
else
prefix="c:/Program Files/Routino"
@@ -74,16 +74,16 @@


# Maths library
-LDFLAGS=-lm
+LDFLAGS+=-lm

# Language dialect selection
-CFLAGS=-std=c99
+CFLAGS+=-std=c99

@@ -85,3 +85,3 @@
# Warning options
CFLAGS+=-Wall -Wmissing-prototypes -Wextra -Wno-unused-parameter -pedantic

# Optimisation options
-CFLAGS+=-O3
+#CFLAGS+=-O3
CFLAGS+=-ffast-math
@@ -141,4 +141,4 @@

# Optimisation option (only works if compilation and execution use exactly the same CPU architecture).
@@ -118,7 +118,7 @@
endif

# Put the current directory in the shared library path for the router using libroutino
-LDFLAGS_LDSO=-Wl,-R.
+#LDFLAGS_LDSO=-Wl,-R.


# Required for multi-threaded support (comment these two lines out if not required)
@@ -139,8 +139,8 @@


# Required for xz support (uncomment these two lines if required)
-#CFLAGS+=-DUSE_XZ
-#LDFLAGS+=-llzma
+CFLAGS+=-DUSE_XZ
+LDFLAGS+=-llzma


# Required to use stdio with files > 2GiB on 32-bit system.
17 changes: 13 additions & 4 deletions sci-geosciences/routino/routino-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,10 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Routing application based on openstreetmap data"
HOMEPAGE="http://www.routino.org/"
SRC_URI="http://www.routino.org/download/${P}.tgz"
Expand All @@ -10,10 +13,16 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
PATCHES=( "${FILESDIR}"/${P}.patch )

src_configure() {
:
src_prepare() {
eapply "${FILESDIR}"/${P}.patch

sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
-e "s@CC=gcc@CC=$(tc-getCC)@" \
-e "s@LD=gcc@LD=$(tc-getCC)@" \
Makefile.conf || die "failed sed"

eapply_user
}

src_compile() {
Expand Down
15 changes: 12 additions & 3 deletions sci-geosciences/routino/routino-3.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Routing application based on openstreetmap data"
HOMEPAGE="http://www.routino.org/"
SRC_URI="http://www.routino.org/download/${P}.tgz"
Expand All @@ -10,10 +13,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
PATCHES=( "${FILESDIR}"/${P}.patch )

src_configure() {
:
src_prepare() {
eapply "${FILESDIR}"/${P}.patch

sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
-e "s@CC=gcc@CC=$(tc-getCC)@" \
-e "s@LD=gcc@LD=$(tc-getCC)@" \
Makefile.conf || die "failed sed"

eapply_user
}

src_compile() {
Expand Down

0 comments on commit 8b549d5

Please sign in to comment.