Skip to content

Commit

Permalink
dev-python/botocore: Bump to 1.35.7
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 28, 2024
1 parent 9777826 commit 8b6a193
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/botocore/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST botocore-1.34.158.gh.tar.gz 13282704 BLAKE2B c244a36093cdaf57ac82dc11a3e9d4
DIST botocore-1.35.0.gh.tar.gz 13294975 BLAKE2B a0cbafd1b0da5cd7150ea7a2e21b1209b206b7afcb86ad3ff004ca1c96f47da34eff29a43568f0e9a2dca3443516fdb6adf7bd3778835b908fa5fb3a8d22f79a SHA512 7d0c9815703ef49a8958ed1a5159018320108ae86efe20e6dff182db24ceeb67968db7027ee75809a1ebd1c835709d0d758b0699742bca2e435888dbe5e15a97
DIST botocore-1.35.5.gh.tar.gz 13303437 BLAKE2B 0a95351fbc93074bb0398871773120a194fe581a26f9a74c1101a5ea57bb3acb9a33937fc2d5a39a065988cdcc6dbe253bd2227cf93e670602ccc67ab82d8845 SHA512 5527420017a4a23d5593f5b3a0eb8caf15357642ed90cd73e0fe22774cc8f9f3637028286063e3e2810e5dafe52e882928269e5c82f6369be9af99bef18fb365
DIST botocore-1.35.6.gh.tar.gz 13305231 BLAKE2B 1c3716883b2cc8dd98e4391ff60039f14e0e0fcd076a3780b6ee18c216f004d6f1ed2e916681d28133ae9788fd5c721abbba6c44354442a6d7862074e7f8956a SHA512 6d2ab4264886e231cb0b65ea34d2757b29ba71fe227bf8dbff3474074d612f13b3e9fcfe17b9cb2f8f420bd962f1eefe7b8038ef5017060c6732ec5ed927906e
DIST botocore-1.35.7.gh.tar.gz 13308318 BLAKE2B 4e92e22dde9a4b414a1cace9a21f8a536a0f386dd4b14bd594dc08dff3d05e8aa17c669222b07617db8b883ec79ab48a18d669619ff14400c09df26c0d3101fe SHA512 5188b485db0db1fdaf51ae1ff5c57caa114d0f08b04ef20cd821b5b13b661374dc4463694cf027c1ac25f903ea74be81464d0041c856e93315781398cfde611c
76 changes: 76 additions & 0 deletions dev-python/botocore/botocore-1.35.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )

inherit distutils-r1

DESCRIPTION="Low-level, data-driven core of boto 3"
HOMEPAGE="
https://github.com/boto/botocore/
https://pypi.org/project/botocore/
"
SRC_URI="
https://github.com/boto/botocore/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
<dev-python/jmespath-2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
"
# unbundled packages
RDEPEND+="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/jsonschema[${PYTHON_USEDEP}]
)
"

EPYTEST_XDIST=1
distutils_enable_tests pytest

src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die

# unbundle deps
rm -r botocore/vendored || die
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die

distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# rely on bundled six
tests/functional/test_six_imports.py::test_no_bare_six_imports
tests/functional/test_six_threading.py::test_six_thread_safety
)

case ${EPYTHON} in
python3.13)
EPYTEST_DESELECT+=(
# memory use tests, probably fragile
tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
)
;;
esac

local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest tests/{functional,unit}
}

0 comments on commit 8b6a193

Please sign in to comment.