Skip to content

Commit

Permalink
net-dns/pdns-recursor: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
swegener committed Sep 6, 2016
1 parent db4cca4 commit 8b8909e
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-dns/pdns-recursor/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST pdns-recursor-3.7.3.tar.bz2 245192 SHA256 859ca6071147dd2e2ac1b2a5c3d5c2cbf
DIST pdns-recursor-4.0.0.tar.bz2 1034944 SHA256 900a5d5858c9caa825afd9df657dadebcc1842e3068754c19562eeaab8c791fd SHA512 1a0a9ce39e5540a79308721bb47cccde54679570a218cef9740be06cfe9971af88f1cf82b3daabc4c1733484446a4432ffaf4e875ae9532cbb4a9264fcac7798 WHIRLPOOL 0a8577f582390844f0ad7d4aafce977383ed6984f4d4543f442b3b029d68c86c9d41742488edd4dec31fdc38a63bc6bf1333445dab626b9cc714e90589e7579e
DIST pdns-recursor-4.0.1.tar.bz2 1035584 SHA256 472db541307c8ca83a846d260ecfc854fd8e879c1bb2ce5683a8df5d21e860b0 SHA512 3e69606bda3d296b0c3fd9212afa2a098ab04637718356d220a9490bc3e2a0ca97210934d398ad740509cea9e8f8d2ab2e16a1ba75d559f6b82bf64a729ad018 WHIRLPOOL 5702272c34835238b7a63de6bc4bae0836d9879e8e98d97d7f79e08397f5c2f2d75f10878b94c44fdf862ad924635b6f86a65b31312e0fb16ab38f30c4646bac
DIST pdns-recursor-4.0.2.tar.bz2 1045767 SHA256 d0c46bf47a3f9b3100043319ef9cdec83eba2c35f0a268d704d5c3a3facfea41 SHA512 74dea771deb0bcce6209c256f4c2c82a76d34a80a4a67497b58bf8889166a51864c2649527475aa6e6355af8bba86a68d599828274eaa7521006384223f2e937 WHIRLPOOL 4eda1d13a888f31e1dc90ff3238acee8999423197d514a7ba49ce1fc623512d13694ffd0cf8891d4141e34907cc2ff9f30607b327179f4257a8ed89b4d9973d4
DIST pdns-recursor-4.0.3.tar.bz2 1045041 SHA256 ae9813a64d13d9ebe4b44e89e8e4e44fc438693b6ce4c3a98e4cab1af22d9627 SHA512 03c77cff58851f9802eba434fb674d9cbd19b849620996df84b8dccc97539607895e06c1beb662b1ce08146bbc2b51a72bde2d6d90ef88c929ab645d9b5a33c4 WHIRLPOOL 25a6f40bca7575ffa07a87be15c0f6d6943878ed5f9b5cd28fa4eb782048a82aed56e5f76b578be78b5d9078dbd4a2838a1b07da22e125903e677d7e7e60bb8f
75 changes: 75 additions & 0 deletions net-dns/pdns-recursor/pdns-recursor-4.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit toolchain-funcs flag-o-matic eutils versionator

DESCRIPTION="The PowerDNS Recursor"
HOMEPAGE="http://www.powerdns.com/"
SRC_URI="http://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="lua luajit protobuf systemd"
REQUIRED_USE="?? ( lua luajit )"

DEPEND="lua? ( >=dev-lang/lua-5.1:= )
luajit? ( dev-lang/luajit:= )
protobuf? (
dev-libs/protobuf
>=dev-libs/boost-1.42
)
>=dev-libs/boost-1.35"
RDEPEND="${DEPEND}
!<net-dns/pdns-2.9.20-r1"
DEPEND="${DEPEND}
virtual/pkgconfig"

S="${WORKDIR}"/${P/_/-}

pkg_setup() {
filter-flags -ftree-vectorize
}

src_configure() {
econf \
--sysconfdir=/etc/powerdns \
$(use_enable systemd) \
$(use_with lua) \
$(use_with luajit) \
$(use_with protobuf)
}

src_install() {
default

mv "${D}"/etc/powerdns/recursor.conf{-dist,}

# set defaults: setuid=nobody, setgid=nobody
sed -i \
-e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
-e 's/^# quiet=$/quiet=on/' \
-e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
"${D}"/etc/powerdns/recursor.conf

doinitd "${FILESDIR}"/pdns-recursor

keepdir /var/lib/powerdns
}

pkg_postinst() {
local old

for old in ${REPLACING_VERSIONS}; do
version_compare ${old} 4.0.0-r1
[[ $? -eq 1 ]] || continue

ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
ewarn "to pdns-recursor, please update your runlevels accordingly."

break
done
}

0 comments on commit 8b8909e

Please sign in to comment.