forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-backup/dar: Bump to version 2.5.15
Package-Manager: Portage-2.3.31, Repoman-2.3.9
- Loading branch information
Lars Wendler
committed
Apr 29, 2018
1 parent
a36098c
commit 8b8bf03
Showing
2 changed files
with
99 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST dar-2.5.11.tar.gz 1891928 BLAKE2B 536cccca2533f7ddbc8b95972fe00e9c87a404481e6afbd7aa3634c00598403c18950eb876aefe71a818c3bf4df75bff5f3904dc69bd1d75880f6c8a349911a5 SHA512 36b90218a34ac7f41ce9ca0a2167cfb2fd243b23b8e84350153e8804f0faabf87291b4e4b061533bcb0ca079f087c074eeaa12a54ee8084dd386a072ac503847 | ||
DIST dar-2.5.13.tar.gz 1903994 BLAKE2B 9e58e2d86d38203364f23b506d957fb78b1b6d33df780a2711aab13913e50ce83726fed9301bcfe7975987bef6b3b8de45a30ad32c4e0b9a2d3b5db14e8a108e SHA512 759a54c07bee787a02f751db4ecb4036fa578224ba69779e784ea4edebf3d9feb3547414fe605c0f655bb4ac364575638ae35aab952df1f6610dd436bc70b444 | ||
DIST dar-2.5.14.tar.gz 1904398 BLAKE2B 073423b338be6e6f31bb31f0fe29980670a62ab6e6f768b31d99c464763e6598adecfe2446ab08f7e6543dff74b9f4a978a56da309ce61168c1629d22e112c6a SHA512 035866bd891ff12adbcd18a78fa6f2475c232182b24e35aaf7c3c41c30e6298c4e655ea5a93b9be050c6dee332e2b7913f75e3d399cbee96a1f1d3101d33fbbc | ||
DIST dar-2.5.15.tar.gz 1905085 BLAKE2B 05dae478e140d9d86ffacbcff62ad612f8ae403e39cbf04fe64162722da4ee5feee1c6f826d4466de5a40f4ce8c24ca258ebaa26cd6eac851d34b946c3464f99 SHA512 0e583cd4dd920a3684364fbdea3bb882dfda2ca27f431a23146dc0c7d1e6ae74dd6245ba6983fc7f8073e9c9c9c496345c9645d1099eed7c75ac1e69381972c4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,98 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit flag-o-matic | ||
|
||
DESCRIPTION="A full featured backup tool, aimed for disks" | ||
HOMEPAGE="http://dar.linux.free.fr/" | ||
SRC_URI="mirror://sourceforge/dar/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux" | ||
IUSE="dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr" | ||
|
||
RESTRICT="test" # need to be run as root | ||
|
||
RDEPEND=">=sys-libs/zlib-1.2.3:= | ||
!static? ( | ||
app-arch/bzip2:= | ||
app-arch/xz-utils:= | ||
sys-libs/libcap | ||
gcrypt? ( dev-libs/libgcrypt:0= ) | ||
gpg? ( app-crypt/gpgme ) | ||
lzo? ( dev-libs/lzo:= ) | ||
xattr? ( sys-apps/attr:= ) | ||
)" | ||
|
||
DEPEND="${RDEPEND} | ||
static? ( | ||
app-arch/bzip2[static-libs] | ||
app-arch/xz-utils[static-libs] | ||
sys-libs/libcap[static-libs] | ||
sys-libs/zlib[static-libs] | ||
gcrypt? ( dev-libs/libgcrypt:0=[static-libs] ) | ||
gpg? ( | ||
app-crypt/gpgme[static-libs] | ||
dev-libs/libassuan[static-libs] | ||
dev-libs/libgpg-error[static-libs] | ||
) | ||
lzo? ( dev-libs/lzo[static-libs] ) | ||
xattr? ( sys-apps/attr[static-libs] ) | ||
) | ||
nls? ( | ||
sys-devel/gettext | ||
virtual/libintl | ||
) | ||
doc? ( app-doc/doxygen )" | ||
|
||
REQUIRED_USE="?? ( dar32 dar64 ) | ||
gpg? ( gcrypt )" | ||
|
||
#PATCHES=( | ||
#) | ||
|
||
src_configure() { | ||
# configure.ac is totally funked up regarding the AC_ARG_ENABLE | ||
# logic. | ||
# For example "--enable-dar-static" causes configure to DISABLE | ||
# static builds of dar. | ||
# Do _not_ use $(use_enable) until you have verified that the | ||
# logic has been fixed by upstream. | ||
local myconf=( | ||
--disable-upx | ||
$(usex dar32 --enable-mode=32 '') | ||
$(usex dar64 --enable-mode=64 '') | ||
$(usex doc '' --disable-build-html) | ||
#$(usex examples --enable-examples '') | ||
$(usex gcrypt '' --disable-libgcrypt-linking) | ||
$(usex gpg '' --disable-gpgme-linking) | ||
$(usex lzo '' --disable-liblzo2-linking) | ||
$(usex nls '' --disable-nls) | ||
$(usex xattr '' --disable-ea-support) | ||
) | ||
|
||
# Bug 103741 | ||
filter-flags -fomit-frame-pointer | ||
|
||
if ! use static ; then | ||
myconf+=( --disable-dar-static ) | ||
if ! use static-libs ; then | ||
myconf+=( --disable-static ) | ||
fi | ||
fi | ||
|
||
econf ${myconf[@]} | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install | ||
|
||
local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) | ||
einstalldocs | ||
|
||
if ! use static-libs ; then | ||
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die | ||
fi | ||
} |