Skip to content

Commit

Permalink
dev-python/pyopencl: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
patricklauer committed Jun 13, 2016
1 parent d4a4b89 commit 8bc16f0
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyopencl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pyopencl-2014.1.tar.gz 1642825 SHA256 7c8df4f22ef49516a1444760dc622a037c83079ff60ff81779e60cb9fc5410e7 SHA512 da3e4e8d95605381d87db482f61fe7030fe244611a3c35d84c88210bcfb3472dc197be721f92e46e6828cc5d0245981ae004331a7c19e7fd8011a0aab593072f WHIRLPOOL e9d3c742c6ef217cf1f223990f852ae5b5ef50b7eae3513955da00f41134d9805e2078c16cd31429e327ea64a7ea16c15c014a749a3a532c3a11e4babdb91202
DIST pyopencl-2015.1.tar.gz 1652046 SHA256 823b8c5ae438a70de87b3675c3896d04d785261cb0cbd45c01c7dd0fe9d9f6ff SHA512 0236237b1f21283aa2fa7edf86d4c7a275df508e2bdd833ad83d333f3a070b00b125310bfbf8e0fd7308b47d94c565642f87645cc91c8d7020f1e377cdd8bec5 WHIRLPOOL 2b581e4a02c8f5f77085c87c5e8b63ada0b86c58d04e62e665144be00447a9cdd69e8befecc3effe8b6253f3cace2920e8158417c940d08f89ff2985c479753b
DIST pyopencl-2015.2.4.tar.gz 284648 SHA256 f67d0099add79c6baae2359872dec82d1472bd4df42523d1604afcd10ed87398 SHA512 19ae397adb357da2e04d8aade987471b7c83b902750aeb67bf5303e758b720d78ce05a130b1930478ccc47ff6c3cdf4484b85d4bf60dfb36aaf6e2f050a4af9e WHIRLPOOL b0fa45f68ccc05d45036ead1c9e6be0aff06c06f45d6c53f1dcbce2a1c70acf5e4ccbcbffea1966a3aa4a752f909c306296a2905bf7331cfd36d9b083d263f61
DIST pyopencl-2016.1.tar.gz 311327 SHA256 54b6e8ad02dc437807739bd53e43851efe979bd51ec87996e44b94ab67238297 SHA512 3be8da315f9b4a4e03071152bb5968c5c7b102cbae6c70f358438cfd7951d12970a76dd8e922187ff73e47f7d0ce7a070e6f303dbe364c016796fa65d7e1de71 WHIRLPOOL 23514d2ff8b578d623506033c749df5fd1d5604f5deefda72e817c688df9337c608d291f5ae8efc0e227e857ef16b65adb51ebc20773d0f8e636665990902ea9
51 changes: 51 additions & 0 deletions dev-python/pyopencl/pyopencl-2016.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1

DESCRIPTION="Python wrapper for OpenCL"
HOMEPAGE="http://mathema.tician.de/software/pyopencl https://pypi.python.org/pypi/pyopencl"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples opengl"

RDEPEND="
>=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
>=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
>=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=virtual/opencl-0-r1"
DEPEND="${RDEPEND}"

src_configure() {
local myconf=()
if use opengl; then
myconf+=(--cl-enable-gl)
fi

"${PYTHON}" configure.py \
--boost-compiler=gcc \
--boost-python-libname=boost_python-${PYTHON_ABI}-mt \
--no-use-shipped-boost \
"${myconf[@]}"
}

python_install_all() {
if use examples; then
local EXAMPLES=( examples/. )
einfo "Some of the examples provided by this package require dev-python/matplotlib."
fi
distutils-r1_python_install_all
}

0 comments on commit 8bc16f0

Please sign in to comment.