Skip to content

Commit

Permalink
dev-libs/libowfat: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
patricklauer committed Oct 20, 2016
1 parent a7296de commit 8bc9208
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libowfat/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libowfat-0.29.tar.bz2 139489 SHA256 4badbdeed6bef4337f1edd6b86fb7154c5592509c272dcdc09c693161cbc6427 SHA512 35b3be01f288a24ebf01e1f860bc2bba7431db890be1b117f9a7f0702532610d283f6e569b1a1d1e625a4fec3394d2c6ed5c2bf512a11c38ecf89cf89ec72136 WHIRLPOOL cc23d2c0a643b6a65b5d07a555bb1bd32d5f5f572e1fe414725e28e51614c53f538e4c7a7a24022c10784ae8097714549624b5f548700970c8aa34ad3b926dfe
DIST libowfat-0.30.tar.xz 177368 SHA256 db4a3a853cfbb9e83b27f565b580f6fdc519475b162edc1a656043e1c126e993 SHA512 ce7b13266dbb0360aaeac62882e7138437507ea23b811c49a92b698a08ffb3afe9be6762c74cc1de7236c3d135c3cfaaa9236c7536e4183108747fc82bbb911b WHIRLPOOL fbe4c63c781d104d55c6cc2d480191335088965eb287916ccbae3313d16fcdd93bdba56d1f01d38b0c17d89c1ef1b4706a75644e64b28e49df34da2b20525509
DIST libowfat-0.31.tar.xz 183684 SHA256 d1e4ac1cfccbb7dc51d77d96398e6302d229ba7538158826c84cb4254c7e8a12 SHA512 b3ce973d6edc501ddaa6caa84dc3b74e3e31ced92e4f707038858cd36c977863251a7eaeababdad34ffe6b8ad13c9702118464f6f9fd827e05f6fbc5004408b5 WHIRLPOOL c7156a324d9b94f35cefa3523c95bcd41a5f60bbbb973a6431fbed23d81eaa7ddfd4547c54073e9125c6e5148e294c102c630e435f178a35b65ce9bbb305c120
45 changes: 45 additions & 0 deletions dev-libs/libowfat/libowfat-0.31.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit flag-o-matic toolchain-funcs eutils

DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein"
SRC_URI="http://www.fefe.de/libowfat/${P}.tar.xz"
HOMEPAGE="http://www.fefe.de/libowfat/"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~sparc ~x86"
IUSE="diet"

RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"

pkg_setup() {
# Required for mult/umult64.c to be usable
append-flags -fomit-frame-pointer
}

src_compile() {
emake -j1 \
CC=$(tc-getCC) \
CFLAGS="-I. ${CFLAGS}" \
DIET="/usr/bin/diet -Os" \
prefix=/usr \
INCLUDEDIR=/usr/include/libowfat \
$( use diet || echo 'DIET=' )
}

src_install () {
emake -j1 \
LIBDIR="${D}/usr/lib" \
MAN3DIR="${D}/usr/share/man/man3" \
INCLUDEDIR="${D}/usr/include/libowfat" \
install || die "emake install failed"

cd "${D}"/usr/share/man
mv man3/buffer.3 man3/owfat-buffer.3
}

0 comments on commit 8bc9208

Please sign in to comment.