Skip to content

Commit

Permalink
app-text/groonga: add 13.0.1
Browse files Browse the repository at this point in the history
  • Loading branch information
thesamesam committed Apr 10, 2023
1 parent 4a3d3c4 commit 8c3bf1c
Show file tree
Hide file tree
Showing 2 changed files with 108 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/groonga/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST groonga-13.0.1.tar.gz 24694524 BLAKE2B 326ca810bdf4634b778eb6efc7a6c56626b0c5b563d9b896da23a103399e51ca57e8d1dd87aa05dbbe527f67cb6875924ca073f007698f5077437e2b191b995a SHA512 54eda0c70f932f249dbf58f01367d9a05a9d8e6e9a1df92e0a9070f452596cfc38da59b02c5128a585f9e19d460ce8100dd2677aaba7049e129a963491b22362
DIST groonga-8.0.2.tar.gz 15095427 BLAKE2B fa83034a434edaa35dede08cb042e48f15e1e2edd78a121f9341f53f53a5eef863d02e2ea6384428c720c4ff9acf1083504046c8c11a1ea8d7bfc4b541db66b5 SHA512 bc5590604054c4adfbc80b39c7cf367e8a989c47d80c37c48feffb9a427b4b4e360289f3d732f6affa7d26a1c8559f23bda1c70b6736a06601398fce9a53acf1
107 changes: 107 additions & 0 deletions app-text/groonga/groonga-13.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,107 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit libtool

DESCRIPTION="An Embeddable Fulltext Search Engine"
HOMEPAGE="https://groonga.org/"
SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="benchmark debug doc +exact-alloc-count examples futex jemalloc libedit libevent lzo +mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib zstd"
REQUIRED_USE="
sphinx? ( doc )
"

DEPEND="
>=dev-libs/onigmo-6.1.1:0=
dev-libs/rapidjson
dev-libs/xxhash
benchmark? ( >=dev-libs/glib-2.8 )
jemalloc? ( dev-libs/jemalloc:0= )
libedit? ( >=dev-libs/libedit-3 )
libevent? ( dev-libs/libevent:0= )
lzo? ( dev-libs/lzo )
mecab? ( >=app-text/mecab-0.80 )
msgpack? ( dev-libs/msgpack:= )
sphinx? ( >=dev-python/sphinx-1.0.1 )
zeromq? ( net-libs/zeromq:0= )
zlib? ( sys-libs/zlib:0= )
zstd? ( app-arch/zstd:0= )
"
RDEPEND="
${DEPEND}
acct-group/groonga
acct-user/groonga
"
BDEPEND="
virtual/pkgconfig
sphinx? ( dev-python/sphinx )
"

src_prepare() {
default

elibtoolize
}

src_configure() {
# httpd is a bundled copy of nginx; disabled for security reasons
# prce only is used with httpd
# Apache arrow, kytea and libstemmer are not available in Gentoo repo
# ruby is only used for an http test
local econfopts=(
--disable-groonga-httpd
--without-pcre
--without-kytea
--without-libstemmer
--disable-arrow
--with-log-path="${EPREFIX}"/var/log/${PN}.log
--without-luajit
--without-ruby
--with-shared-onigmo
--with-onigmo=system
--with-xxhash
$(use_enable benchmark)
$(use_enable debug memory-debug)
$(use_enable doc document)
$(use_enable exact-alloc-count)
$(use_enable futex)
$(use_with jemalloc)
$(use_enable libedit)
$(use_with libevent)
$(use_with lzo)
$(use_with mecab)
$(use_enable msgpack message-pack)
$(use_with msgpack message-pack "${ESYSROOT}/usr")
$(use_enable nfkc)
$(use_with sphinx sphinx-build)
$(use_enable static-libs static)
$(use_enable uyield)
$(use_enable zeromq)
$(use_with zlib)
$(use_with zstd)
)

econf "${econfopts[@]}"
}

src_install() {
default

find "${ED}" -name '*.la' -delete || die

newinitd "${FILESDIR}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}

keepdir /var/{log,lib}/${PN}
fowners groonga:groonga /var/{log,lib}/${PN}

if ! use examples ; then
rm -r "${ED}/usr/share/${PN}" || die
fi
}

0 comments on commit 8c3bf1c

Please sign in to comment.