Skip to content

Commit

Permalink
dev-java/tomcat-native: version bump, added static-libs use flag
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
fordfrog committed Dec 4, 2017
1 parent 5427585 commit 8c59784
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/tomcat-native/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tomcat-native-1.2.14-src.tar.gz 404159 SHA256 a7f1649f7c384b2d4e6c4c96f20aea980efeba327dba874d4bc7c765b6229f5e SHA512 ddfc44f07dc4200f8ef20b5425355d2737a7510e41660002553c04e7451c48e4f54f4cfb462ed6bea1fad1ea60525a7ce3787af74e6a4b795f9dd1862b75c633 WHIRLPOOL 33b4d60a9895645b049d69c8b70105fd54ec48f1d0b14e96b1ade96973473842f4b447824d3e2b9985ec73235b72c94cf70e7a089620c3ed424cb4dc16a79db7
DIST tomcat-native-1.2.16-src.tar.gz 405109 BLAKE2B e153caeb82c4ac4d2a8c7c24373204edf6e691068e70c858618caf72faaee1f4d10c4529ba758e24422e8580e8b3e95d28cc942998568106ec60b8de7c196c51 SHA512 0345f85fbab406f25c25c8fc06bf55f3d166fa14bfcf542bddb5dc5db4c8c7bd0c5b71603d85261d71152ead3023b112144f2ffa5ede14ae8595013f79c802aa
59 changes: 59 additions & 0 deletions dev-java/tomcat-native/tomcat-native-1.2.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

inherit eutils java-pkg-2 java-ant-2

DESCRIPTION="Native APR library for Tomcat"

SLOT="0"
SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
HOMEPAGE="https://tomcat.apache.org/"
KEYWORDS="~amd64 ~x86"
LICENSE="Apache-2.0"
IUSE="static-libs test"

RDEPEND="dev-libs/apr:1
dev-libs/openssl:=
>=virtual/jre-1.7"

DEPEND=">=virtual/jdk-1.7
test? ( dev-java/ant-junit:0 )"

S=${WORKDIR}/${P}-src

src_configure(){
cd native || die
econf --with-apr=/usr/bin/apr-1-config \
--with-ssl=/usr || die "Could not configure native sources"
}

src_compile() {
eant jar -f build.xml

cd native || die
default
}

src_install() {
java-pkg_newjar "dist/${P}.jar" "${PN}.jar"

cd native
emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"

! use static-libs && prune_libtool_files --modules
}

src_test() {
java-pkg-2_src_test
}

pkg_postinst() {
elog
elog " APR should be available with Tomcat, for more information"
elog " please see https://tomcat.apache.org/tomcat-6.0-doc/apr.html"
elog
elog " Please report any bugs to https://bugs.gentoo.org/"
elog
}

0 comments on commit 8c59784

Please sign in to comment.