Skip to content

Commit

Permalink
media-radio/wsjtx: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
dl1jbe committed Jun 14, 2018
1 parent d9f250f commit 8c847d8
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-radio/wsjtx/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST wsjtx-1.8.0.tgz 29041865 BLAKE2B 3eb3d4e2711443a9e895c1b5771ae6378b13cccbe9b50dce97e9551218700a4e22ae10b618e346b52d2037ee26c5d41f1cf2376d8cc19d143d263db5c683a482 SHA512 793e88604661b03e2e6d5a910ea4045f800b9c59174af3286fd8afdaf65d8a3ca7d1aeae557c6afc66d9bbe398be8c7030950dda03d6bc6279061c3a3107beaa
DIST wsjtx-1.9.1.tgz 29264406 BLAKE2B 0eb00737851a7877d894a21218c6a408eac30caa4114a0edd69400701f0c8c702d4c373adc5c9f7896a4d8f96c338a92e0a997e0270240917b5e236db36c9aa0 SHA512 16c84e7bb8cf9e6eff288b74ee1f9083e0133ff69fdefca7fbc986c912663f744a75db353242024fe8c64ff9e6e8558fd825b9b106abf02cdd4b43be91680557
54 changes: 54 additions & 0 deletions media-radio/wsjtx/wsjtx-1.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit cmake-utils

MY_P=${P/_/-}

DESCRIPTION="Weak signal ham radio communication"
HOMEPAGE="http://physics.princeton.edu/pulsar/K1JT/wsjtx.html"
SRC_URI="mirror://sourceforge/wsjt/${MY_P}.tgz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"

RDEPEND="dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtconcurrent:5
dev-qt/qtserialport:5
dev-qt/qtprintsupport:5
virtual/libusb:1
media-libs/portaudio
sci-libs/fftw:3.0[threads,fortran]
virtual/fortran
app-text/asciidoc
doc? ( dev-ruby/asciidoctor )"
DEPEND="${RDEPEND}"

S=${WORKDIR}/${MY_P}

src_configure() {
local mycmakeargs=(
-DWSJT_GENERATE_DOCS="$(usex doc)"
-DWSJT_DOC_DESTINATION="/doc/${PF}"
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
cmake-utils_src_install
rm "${D}"/usr/bin/rigctl{,d}-wsjtx || die
rm "${D}"/usr/share/man/man1/rigctl{,d}-wsjtx.1.gz || die
rm "${D}"/usr/share/doc/WSJT-X -R || die

}

0 comments on commit 8c847d8

Please sign in to comment.