forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
1 parent
c81f5e7
commit 8cd7448
Showing
2 changed files
with
50 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST oslosphinx-3.0.0.tar.gz 25644 SHA256 d39129be6b6076e087ab9a108c1b17f67cbb233ffc2481528df3d76b612cc1f6 SHA512 f2b5f35124bac9bf661ba45af1f18703725d5b5432cc708689a548bde6918975722729f321fb4c1fc8a146011c7e86c1c6abfdc746806d4bf7fa7d640e057a0c WHIRLPOOL 8ccc00a71a3d5f67a33a989120ad2591977169b93a5d81fd2c7798a6b93ad33ce45e6ebd2be69c7e0b0e4fa2e79719e393e63f9a250b50e7b5b9d4621bf03e94 | ||
DIST oslosphinx-4.15.1.tar.gz 33218 SHA256 b5cb9524b938c1c7353b3bd52d1af4e92fa9a8af9c0ec44bfafaf8f1964cd3b9 SHA512 c5039f119e5a144c137c13423f42230fcebfcd527538737e3c3fd50fc9b094a1ef0af15e0fb1ce195a6d5013f6cc736cd2b9c856bbbeee8a68ef3849573b9bbb WHIRLPOOL bfeec21373b0a7fccce0c2e426a450358a5608879b7fba5f1f9e093e31072e3b6f9d3c05f145dc26c8c3416b1c4e2a6b39c9a0704fd2aff47315a60a353b7d06 | ||
DIST oslosphinx-4.15.2.tar.gz 33362 SHA256 139ab33275c61022842a7c596e7af44908b4aa2f5e7b001ccd3c63e73afb4183 SHA512 cf8fce033f97c0334fc076568720fe3b7903e780d4b839c452f33d02378470263891d01e553e4f2463484895c689532f95f4aa81ac3dcb0d6137b463bcc7e08a WHIRLPOOL 074ad2c6180ce78c8ec8eb067c8e171efbd5c505785258fd7343c215a24589340c71dcdfef641d2402e117c38f15e0a83e48ee6a87d480571d88959073e31d0a | ||
DIST oslosphinx-4.7.0.tar.gz 27786 SHA256 f8d353445d96c667c95a07c052694a31906c6a36a8305918d63f855f9040b7d1 SHA512 e7334c17bea387898c6c9943ca79c5073927885bdefaba9cdbac01b21a4dd96bcaa0c539c3907508bee5db5959f161d0a8421c688c6592b691edbd7f9013da75 WHIRLPOOL 8cee688ae62f2f16a753fb18c1c8699ce819715a612b3c549b7cb0b07e7cd5e7822c52b9d8f3189d335e26fc036e28012cb7155ed71d01ec7a1cb5d860ad2aaa |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} ) | ||
|
||
inherit distutils-r1 | ||
|
||
MY_PN="${PN//-/}" | ||
|
||
DESCRIPTION="OpenStack Sphinx Extensions and Theme" | ||
HOMEPAGE="http://www.openstack.org/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="doc" | ||
|
||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=dev-python/pbr-1.6[${PYTHON_USEDEP}] | ||
doc? ( | ||
>=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}] | ||
<dev-python/sphinx-1.3[${PYTHON_USEDEP}] | ||
) | ||
" | ||
RDEPEND=" | ||
>=dev-python/requests-2.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
" | ||
|
||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
python_prepare_all() { | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
use doc && esetup.py build_sphinx | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
|
||
distutils-r1_python_install_all | ||
} |