forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-im/signal-desktop-bin: add 7.22.0
Signed-off-by: Robert Siebeck <[email protected]> Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
Showing
2 changed files
with
97 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST signal-desktop_7.21.0_amd64.deb 122387548 BLAKE2B a335b4406c0ee59ffd0ec8af0c2c1b8b79df10c2768fdbe8b0f382156f7f10ff2eb18322d865552aad9320f6fdddb916677132ce3d61c04eed27b91c330d5b0a SHA512 7361ffa114fac6c31eb3fb59a1ea66196612907d6eb48ae882ace7a286fed0f1a5ab1b05ea0de11fc97f9ef6aeea290f36e59ff04d39e2d04f55afa44cfcfa56 | ||
DIST signal-desktop_7.22.0_amd64.deb 122256870 BLAKE2B 39822a5bba412e389aea670ce315d71d503b2d82ea3209d11c8e4a95c503ea1aa15310153388ab7c2bad9ed5c960d6e0ada45efc2b3452c59156c9f76b230bcd SHA512 d3f45872af6318185ab7c732cabb72b1c193756e8d055ca3964284f37c94a6076eafcb11760ad7880dc1fe29a18ec598f5432a05da2046c95c633b70c5390e89 |
96 changes: 96 additions & 0 deletions
96
net-im/signal-desktop-bin/signal-desktop-bin-7.22.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,96 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
MY_PN="${PN/-bin/}" | ||
|
||
inherit pax-utils unpacker xdg | ||
|
||
DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer" | ||
HOMEPAGE="https://signal.org/ | ||
https://github.com/signalapp/Signal-Desktop" | ||
SRC_URI="https://updates.signal.org/desktop/apt/pool/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb" | ||
S="${WORKDIR}" | ||
|
||
LICENSE="GPL-3 MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 ISC openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="-* amd64" | ||
IUSE="+sound" | ||
RESTRICT="splitdebug" | ||
|
||
RDEPEND=" | ||
>=app-accessibility/at-spi2-core-2.46.0:2 | ||
dev-libs/expat | ||
dev-libs/glib:2 | ||
dev-libs/nspr | ||
dev-libs/nss | ||
>=media-fonts/noto-emoji-20231130 | ||
media-libs/alsa-lib | ||
media-libs/mesa[X(+)] | ||
net-print/cups | ||
sys-apps/dbus[X] | ||
x11-libs/cairo | ||
x11-libs/gtk+:3[X] | ||
x11-libs/libdrm | ||
x11-libs/libX11 | ||
x11-libs/libxcb | ||
x11-libs/libxkbcommon | ||
x11-libs/libXcomposite | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXrandr | ||
x11-libs/pango | ||
sound? ( | ||
|| ( | ||
media-libs/libpulse | ||
media-sound/apulse | ||
) | ||
) | ||
" | ||
|
||
QA_PREBUILT=" | ||
opt/Signal/chrome_crashpad_handler | ||
opt/Signal/chrome-sandbox | ||
opt/Signal/libEGL.so | ||
opt/Signal/libGLESv2.so | ||
opt/Signal/libffmpeg.so | ||
opt/Signal/libvk_swiftshader.so | ||
opt/Signal/libvulkan.so.1 | ||
opt/Signal/resources/app.asar.unpacked/node_modules/* | ||
opt/Signal/signal-desktop | ||
opt/Signal/swiftshader/libEGL.so | ||
opt/Signal/swiftshader/libGLESv2.so" | ||
|
||
src_prepare() { | ||
default | ||
sed -e 's| --no-sandbox||g' \ | ||
-i usr/share/applications/signal-desktop.desktop || die | ||
unpack usr/share/doc/signal-desktop/changelog.gz | ||
} | ||
|
||
src_install() { | ||
insinto / | ||
dodoc changelog | ||
doins -r opt | ||
insinto /usr/share | ||
|
||
if has_version media-sound/apulse[-sdk] && ! has_version media-sound/pulseaudio; then | ||
sed -i 's/Exec=/Exec=apulse /g' usr/share/applications/signal-desktop.desktop || die | ||
fi | ||
|
||
doins -r usr/share/applications | ||
doins -r usr/share/icons | ||
fperms +x /opt/Signal/signal-desktop /opt/Signal/chrome-sandbox /opt/Signal/chrome_crashpad_handler | ||
fperms u+s /opt/Signal/chrome-sandbox | ||
pax-mark m opt/Signal/signal-desktop opt/Signal/chrome-sandbox opt/Signal/chrome_crashpad_handler | ||
|
||
dosym -r /opt/Signal/${MY_PN} /usr/bin/${MY_PN} | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
elog "For using the tray icon on compatible desktop environments, start Signal with" | ||
elog " '--start-in-tray' or '--use-tray-icon'." | ||
} |