Skip to content

Commit

Permalink
dev-python/nuitka: Bump to 1.2.4
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 4, 2022
1 parent 0ee6910 commit 8d06468
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/nuitka/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Nuitka-1.2.3.tar.gz 3958335 BLAKE2B c2d47e7ff355492fb72f224be92445849c3fce13768ba7957cf4bbbbc9cd4e0ec7c3904e5465ad543e16d1419a01b42cd4399b816e1ff56e2c8ea5c57fddbc04 SHA512 1c842c21764bd0dc9bf68bb26506959b35e54d03c1d6d6b9c179289ec073ed07b75d6709a3c73ac3e14bb988a7b2f5a88f7dfcce55a25eab1c5e4b294b15d4f4
DIST Nuitka-1.2.4.tar.gz 3958942 BLAKE2B ca3be2453815949b05f8a74dc783c58125ebbda038a86f22d273c6e4ef6c8b3fe3d238b3abedb0062ace59a0f60545312f8ad8af056b13c975106ee0c7563fa7 SHA512 7a160f7b12ba9dd66af2d3c798bafd4b2d4f60068acb18be5dc9246c811df58b6f2e6b1c3610ed045d7a73042728b53b92c36b239cb88931d500c904e7018847
55 changes: 55 additions & 0 deletions dev-python/nuitka/nuitka-1.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )

inherit distutils-r1 flag-o-matic optfeature

DESCRIPTION="Python to native compiler"
HOMEPAGE="
https://www.nuitka.net/
https://github.com/Nuitka/Nuitka/
https://pypi.org/project/Nuitka/
"
SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
S=${WORKDIR}/${P^}

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~loong ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-util/scons[${PYTHON_USEDEP}]
"
BDEPEND="
${RDEPEND}
test? ( dev-util/ccache )
"

DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )

distutils-r1_src_prepare() {
# remove vendored version of SCons that is Python2 only
# this should be removed when upstream removes support for Python2
rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
eapply_user
}

python_install() {
distutils-r1_python_install
doman doc/nuitka3.1 doc/nuitka3-run.1
}

python_test() {
append-ldflags -Wl,--no-warn-search-mismatch
./tests/basics/run_all.py search || die
}

pkg_postinst() {
optfeature "support for stand-alone executables" app-admin/chrpath
}

0 comments on commit 8d06468

Please sign in to comment.