Skip to content

Commit

Permalink
games-puzzle/galaxis: Fix call to undeclared library function bzero
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/895986
Signed-off-by: Brahmajit Das <[email protected]>
Closes: gentoo#33170
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
listout authored and chewi committed Oct 9, 2023
1 parent d0e8c93 commit 8d0922f
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
11 changes: 11 additions & 0 deletions games-puzzle/galaxis/files/galaxis-1.10-clang16-build-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
Bug: https://bugs.gentoo.org/895986
--- a/galaxis.c
+++ b/galaxis.c
@@ -6,6 +6,7 @@
* SPDX-License-Identifier: BSD-2-Clause
*/
#define _POSIX_SOURCE
+#define _GNU_SOURCE

#include <stdio.h>
#include <termios.h>
39 changes: 39 additions & 0 deletions games-puzzle/galaxis/galaxis-1.10-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit desktop flag-o-matic toolchain-funcs

DESCRIPTION="Curses-based clone of the nifty little Macintosh freeware game Galaxis"
HOMEPAGE="http://www.catb.org/~esr/galaxis/"
SRC_URI="http://www.catb.org/~esr/galaxis/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"

DEPEND="sys-libs/ncurses:="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"

PATCHES=(
"${FILESDIR}"/${P}-c2x.patch
"${FILESDIR}"/${P}-clang16-build-fix.patch
)

src_compile() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags ncurses || die) -DNDEBUG
append-libs $($(tc-getPKG_CONFIG) --libs ncurses || die)

emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" TERMLIB="${LIBS}"
}

src_install() {
dobin ${PN}
doman ${PN}.6
einstalldocs

doicon ${PN}.png
domenu ${PN}.desktop
}

0 comments on commit 8d0922f

Please sign in to comment.