Skip to content

Commit

Permalink
app-mobilephone/gammu: bump version to 1.38.4
Browse files Browse the repository at this point in the history
Switch to EAPI=6, exclude unneeded patches, fix automagic to ODBC.

Closes: https://bugs.gentoo.org/608002
  • Loading branch information
coyote authored and Michael Palimaka committed Oct 16, 2017
1 parent 97b8344 commit 8d0bc93
Show file tree
Hide file tree
Showing 3 changed files with 86 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-mobilephone/gammu/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gammu-1.33.0.tar.bz2 6535262 SHA256 b326223e36a334dbaed68252a9cf2d90fd898d6de4d1085dcf9c2320881aece3 SHA512 42252a36c7ad5a2945fcf23fcb1b5bb0201d27e8830d3b4a7f4c36bf00f12f5a0f7797e17098bda8d526d4ddc3b1808c0786dfae0feef9424516fa68bf2f3f1e WHIRLPOOL 27c0110da7b686bc7dd19f4f897c59d4e66aa6dbec78dec208fa8c90f70b80c1375c7b8a4b54fe40295d388de61efb11695823a503d1f85a46797c97ddf988fa
DIST gammu-1.36.8.tar.bz2 2095289 SHA256 0ed9c91b4cc5844cad04531e765bc1194cb02bc3e69e6658cd88bfb1cad74f80 SHA512 4ac86b783570db0105e18ef05fc9408e85d1234ab7de720a232a416ad867d3afbe89db7ed408c06d57f8bb38a2e272f86386f11a89e56f1d750da9e9b579ba09 WHIRLPOOL 36172cbf129647b2de48dbbe14122e71fc4f46e2f6ddb29ce546a1e37ea5c2ee0cad28ee37b29b7ddfb9605e6984c6d80d50108bfe0962417da35a1c5b2688ef
DIST gammu-1.38.4.tar.bz2 2132767 SHA256 31ca9ce966841a9aba1af8397d22d2ae0ab00a6fc9e30211ea040ef4303ad767 SHA512 1d4a8e34d3bbc7e4d9797db1acd9be2e92eaec57a87e856ebd168444228a1e89942e69baf1569a0e5645dadea6947338d9e55ae96f632885e95ec1ce74d121ff WHIRLPOOL 731fb8f6d7e04d0040b59ba62485ed3ea1cb8a8b0e6d1009579bb80f6c39109d1b9cbc54ce0c40a1fdb00dbd2e6bede60bef03188e36bcbb5f464483b1decfe9
22 changes: 22 additions & 0 deletions app-mobilephone/gammu/files/gammu-1.38.4-smsd.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
diff -BurpN gammu-1.36.8.orig/smsd/uid.c gammu-1.38.4/smsd/uid.c
--- gammu-1.38.4.orig/smsd/uid.c 2017-06-18 14:33:32.000000000 +0300
+++ gammu-1.38.4/smsd/uid.c 2017-10-10 01:48:20.696098522 +0300
@@ -54,7 +54,7 @@
if (pwd == NULL) {
/* Try to handle it as a number */
uid = strtol(name, &endptr, 10);
- if (*endptr == 0 && uid > 0) {
+ if (*endptr == 0 && uid >= 0) {
pwd = getpwuid(uid);
}
}
@@ -85,7 +85,7 @@
/* Try to handle it as a number */
if (grp == NULL) {
gid = strtol(name, &endptr, 10);
- if (*endptr == 0 && gid > 0) {
+ if (*endptr == 0 && gid >= 0) {
grp = getgrgid(gid);
}
}

63 changes: 63 additions & 0 deletions app-mobilephone/gammu/gammu-1.38.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils eutils

DESCRIPTION="A tool to handle your cellular phone"
HOMEPAGE="https://wammu.eu/gammu/"
SRC_URI="https://dl.cihar.com/${PN}/releases/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth curl dbi debug irda mysql nls odbc postgres usb"

COMMON_DEPEND="
dev-libs/glib:2=
virtual/libgudev:=
bluetooth? ( net-wireless/bluez:= )
curl? ( net-misc/curl:= )
dbi? ( >=dev-db/libdbi-0.8.3:= )
mysql? ( virtual/mysql:= )
postgres? ( dev-db/postgresql:= )
usb? ( virtual/libusb:1= )
"
DEPEND="
${COMMON_DEPEND}
irda? ( virtual/os-headers )
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC )
"
RDEPEND="
${COMMON_DEPEND}
dev-util/dialog
virtual/libiconv
"
PATCHES=(
"${FILESDIR}/${P}-smsd.patch"
)

src_configure() {
local mycmakeargs=(
-DWITH_BLUETOOTH=$(usex bluetooth)
-DWITH_CURL=$(usex curl)
-DWITH_Gettext=$(usex nls)
-DWITH_Iconv=$(usex nls)
-DWITH_IRDA=$(usex irda)
-DWITH_LibDBI=$(usex dbi)
-DWITH_MySQL=$(usex mysql)
-DWITH_ODBC=$(usex odbc)
-DWITH_Postgres=$(usex postgres)
-DWITH_USB=$(usex usb)
-DBUILD_SHARED_LIBS=ON
-DINSTALL_DOC_DIR="share/doc/${PF}"
)
cmake-utils_src_configure
}

src_test() {
addwrite "/run/lock/LCK..bar"
MAKEOPTS+=" -j1" LD_LIBRARY_PATH="${BUILD_DIR}/libgammu" cmake-utils_src_test
}

0 comments on commit 8d0bc93

Please sign in to comment.