Skip to content

Commit

Permalink
gui-wm/hikari: version bump to 2.2.2
Browse files Browse the repository at this point in the history
should really fix the direct CC calls

Closes: https://bugs.gentoo.org/745375
Closes: https://bugs.gentoo.org/745399

Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Aisha Tammy <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
epsilon-0 authored and juippis committed Oct 31, 2020
1 parent 5c8f96e commit 8d4c409
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-wm/hikari/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST hikari-2.2.1.tar.gz 1019168 BLAKE2B aa2ea50b665b3e5d62deba9565cab0d24694046d37dcd9aaa85d3581efbce339ea3f02630155fc731a7eb20dc7b4e4a301e5c6abfd1499ef962e6ef012184ca6 SHA512 640d4ef19cb445613e43fb3363ff00f13937ab256155129bbeba7adcd5f8aed1e4ddbcc6af13809c54ce14dc0d51933cc2763c8a990f44e49d6bfbf9daf62d80
DIST hikari-2.2.2.tar.gz 1019277 BLAKE2B 3cf76f0849cbc80493b6f078ec32b2a6f8e47f12ff3a015132e662dc2382f4071661126bf111550e5ab31eee69c54adaf10ec6ef64b681d7859771a180d30652 SHA512 53b1cb8b8e5fdbabcdcb5ba8af31f1cc66e89c8e94d217b7d1f89f0c733fb7969a251ef5090296b7aeca064aafc60d12878f3f2dbffa17e1fb24609e5549b4f1
66 changes: 66 additions & 0 deletions gui-wm/hikari/hikari-2.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit multiprocessing toolchain-funcs

DESCRIPTION="Wayland compositor inspired by CWM"
HOMEPAGE="https://hikari.acmelabs.space/"
SRC_URI="https://hikari.acmelabs.space/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"

LICENSE="MIT"
SLOT="0"
IUSE="gamma layershell screencopy suid virtual-io +X"

DEPEND="
dev-libs/libinput:=
dev-libs/libucl
>=gui-libs/wlroots-0.11.0[X?]
media-libs/libglvnd
x11-libs/cairo[X?,svg]
x11-libs/libxkbcommon[X?]
x11-libs/pango[X?]
x11-libs/pixman
sys-libs/pam
"

RDEPEND="
${DEPEND}
x11-misc/xkeyboard-config
"

BDEPEND="
dev-libs/wayland-protocols
sys-devel/bmake
virtual/pkgconfig
"

PATCHES=( "${FILESDIR}"/${PN}-2.2.1-pkgconfig.patch )

pkg_setup() {
export MAKE=bmake
tc-export CC PKG_CONFIG
}

src_compile() {

${MAKE} -j$(makeopts_jobs) VERSION="{PV}" \
CC="$(tc-getCC)" \
CFLAGS_EXTRA="${CFLAGS}" \
LDFLAGS_EXTRA="${LDFLAGS}" \
-DWITH_POSIX_C_SOURCE \
$(usex gamma -DWITH_GAMMACONTROL "") \
$(usex layershell -DWITH_LAYERSHELL "") \
$(usex screencopy -DWITH_SCREENCOPY "") \
$(usex suid -DWITH_SUID "") \
$(usex virtual-io -DWITH_VIRTUAL_INPUT "") \
$(usex X -DWITH_XWAYLAND "") \
all || die
}

src_install() {
${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ install || die
doman share/man/man1/hikari.1
}

0 comments on commit 8d4c409

Please sign in to comment.