Skip to content

Commit

Permalink
net-wireless/soapysdr: import from pentoo
Browse files Browse the repository at this point in the history
needed dep for soapy_power and gr-osmosdr

Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
ZeroChaos- committed Feb 19, 2018
1 parent dce16c9 commit 8d81387
Show file tree
Hide file tree
Showing 4 changed files with 126 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-wireless/soapysdr/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST soapysdr-0.6.1.tar.gz 112820 BLAKE2B 42376a7a43c0d5a87a5b17b7d901cc7c74885083051c433c1f22427fe07a4fb0f111ddb460867bd7f748cb3ac6858b15e3dc69ba3ecca4574802c6bd0856a8cc SHA512 80ae8d0b096139e0df70524a1ff05fa1954755177d7920dbd8acb37e45cf86729e2745dcfd4e9c7ae2d7aa564335c2f197ca25ea387daa8f376d6c3e93234106
21 changes: 21 additions & 0 deletions net-wireless/soapysdr/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Rick Farina</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Radio</name>
</maintainer>
<use>
<flag name="bladerf">Add support for bladerf hardware</flag>
<flag name="hackrf">Add support for hackrf hardware</flag>
<flag name="rtlsdr">Add support for rtlsdr hardware</flag>
<flag name="uhd">Add support for Ettus USRP hardware</flag>
</use>
<upstream>
<remote-id type="github">cpothosware/SoapySDR</remote-id>
</upstream>
</pkgmetadata>
52 changes: 52 additions & 0 deletions net-wireless/soapysdr/soapysdr-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit cmake-utils python-r1

DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"

if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
KEYWORDS=""
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
fi

LICENSE="Boost-1.0"
SLOT="0"

IUSE="bladerf hackrf python rtlsdr uhd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
python? ( dev-lang/swig:0 )
"
PDEPEND="bladerf? ( net-wireless/soapybladerf )
hackrf? ( net-wireless/soapyhackrf )
rtlsdr? ( net-wireless/soapyrtlsdr )
uhd? ( net-wireless/soapyuhd )"

src_configure() {
configuration() {
mycmakeargs+=( -DENABLE_PYTHON=ON )
if python_is_python3; then
mycmakeargs+=( -DBUILD_PYTHON3=ON )
fi
}

if use python; then
python_foreach_impl configuration
fi

cmake-utils_src_configure
}
52 changes: 52 additions & 0 deletions net-wireless/soapysdr/soapysdr-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit cmake-utils python-r1

DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"

if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
KEYWORDS=""
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
fi

LICENSE="Boost-1.0"
SLOT="0"

IUSE="bladerf hackrf python rtlsdr uhd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
python? ( dev-lang/swig:0 )
"
PDEPEND="bladerf? ( net-wireless/soapybladerf )
hackrf? ( net-wireless/soapyhackrf )
rtlsdr? ( net-wireless/soapyrtlsdr )
uhd? ( net-wireless/soapyuhd )"

src_configure() {
configuration() {
mycmakeargs+=( -DENABLE_PYTHON=ON )
if python_is_python3; then
mycmakeargs+=( -DBUILD_PYTHON3=ON )
fi
}

if use python; then
python_foreach_impl configuration
fi

cmake-utils_src_configure
}

0 comments on commit 8d81387

Please sign in to comment.