forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Closes: https://bugs.gentoo.org/595462 Package-Manager: Portage-2.3.16, Repoman-2.3.6
- Loading branch information
Showing
4 changed files
with
52 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
DIST libde265-1.0.2.tar.gz 381737 SHA256 c9769a621d568bf5d1e687453cb5d996d7a813476813edb4752ce0fea437fca8 SHA512 714ce93f204bd034e3cccd9624d32ea6fcb31be25dbfd1a85f91814b33a01cc1515a3887a1ccabb9f0986686ecbcdd984b88e605190ff33d2bd75cc3b9f4bdd3 WHIRLPOOL 39daca6fc9d6b68cf69c696467343f780d3e1333e0ff0b94ff942e893deb3898a2d91070d07c64b7c7a5eb24d4097c4bf55b7466327110566bfa4fc87fa9073a | ||
DIST libde265-1.0.2.tar.gz 381737 BLAKE2B cea70a46193e4cb4a0beb1d0a86af17df13e70602c16c509b85acb918c0ddbdfa3e60bfa2b83922200fd9b1465c18edf20fe0939d7f78f3865a9d54b144de90b SHA512 714ce93f204bd034e3cccd9624d32ea6fcb31be25dbfd1a85f91814b33a01cc1515a3887a1ccabb9f0986686ecbcdd984b88e605190ff33d2bd75cc3b9f4bdd3 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
From 88924722c0e25566953276c52df7ef5040714cc5 Mon Sep 17 00:00:00 2001 | ||
From: Andreas Sturmlechner <[email protected]> | ||
Date: Tue, 5 Dec 2017 01:19:53 +0100 | ||
Subject: [PATCH] Fix Qt5 moc detection, throw away Qt4 | ||
|
||
--- | ||
configure.ac | 24 ++++++------------------ | ||
1 file changed, 6 insertions(+), 18 deletions(-) | ||
|
||
diff --git a/configure.ac b/configure.ac | ||
index 6580963..eb4ccec 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -325,24 +325,12 @@ if eval "test $enable_sherlock265 = yes" && eval "test $have_videogfx != yes" && | ||
fi | ||
|
||
if eval "test $enable_sherlock265 = yes" ; then | ||
- PKG_CHECK_MODULES([QT], [Qt5Core Qt5Gui Qt5Widgets], [found_qt=5], [found_qt=no]) | ||
- if eval "test $found_qt = no" ; then | ||
- PKG_CHECK_MODULES([QT], [QtCore QtGui], [found_qt=4]) | ||
- fi | ||
- AC_PATH_PROGS([QTCHOOSER],[qtchooser]) | ||
- if eval "test x$QTCHOOSER = x" ; then | ||
- AC_PATH_PROGS([QTMOC],[moc-qt$found_qt moc]) | ||
- if eval "test x$QTMOC = x" ; then | ||
- AC_MSG_ERROR([Need the "moc" commandline tool which is required to generate the Qt files required for sherlock265.]) | ||
- fi | ||
- else | ||
- QTMOC="$QTCHOOSER -run-tool=moc -qt=$found_qt" | ||
- fi | ||
- AC_MSG_CHECKING([for version of $QTMOC]) | ||
- QTMOC_VERSION=`$QTMOC -v 2>&1 | $GREP -o '[[0-9]]\+.[[0-9]]\+.[[0-9]]\+'` | ||
- AC_MSG_RESULT([$QTMOC_VERSION]) | ||
- AX_COMPARE_VERSION([$QTMOC_VERSION], [lt], [$found_qt], | ||
- [AC_MSG_ERROR([Please install "moc" for Qt$found_qt (found $QTMOC_VERSION).])]) | ||
+ PKG_CHECK_MODULES([QT], [Qt5Core >= 5.1.0 Qt5Gui Qt5Widgets], [ | ||
+ QT_PATH="$( eval $PKG_CONFIG --variable=host_bins Qt5Core )" | ||
+ AC_PATH_PROGS([QTMOC], [moc-qt5 moc], [moc], [$QT_PATH]) | ||
+ ], [ | ||
+ AC_MSG_ERROR([Qt5 moc not found, which is required to generate the Qt files for sherlock265.]) | ||
+ ]) | ||
AC_SUBST(QTMOC) | ||
fi | ||
|
||
-- | ||
2.15.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters