forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-system-monitor: Version bump to 41.0
Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-system-monitor-40.1.tar.xz 763720 BLAKE2B 50d69ed95173301a566078d5bf32c48c011eb297a7fcb598dad1c515ee2900731362c9637dbf7793bb95d31a5584f7f84192b1c726b1a8362dc364b695f54263 SHA512 a6c870ae4e58c5fabdc87c290e10326b051398b3408f7ff159c854eef5c7940371e83766f37c6a713631d49ee5ee7b2670f441a462e2453fa849cba2f3255be4 | ||
DIST gnome-system-monitor-41.0.tar.xz 774644 BLAKE2B 9aafaaf77b414435301eebd8bc84f04faa171139a7d9e6e71ad9bae8f097eaf6d637502ab64f0868636f7964a2b76353364ad27ee2b56c3d8f9131e0a7ee1df2 SHA512 1eecddc479f0d9e986f1821a8c4b72246a6995f7853a6b35c8435d1aaa1afd7bc1df0cc0b9748785e4581563985652be19beb12b193ee17439ba4564febf5d20 |
54 changes: 54 additions & 0 deletions
54
gnome-extra/gnome-system-monitor/gnome-system-monitor-41.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome.org gnome2-utils meson xdg | ||
|
||
DESCRIPTION="The Gnome System Monitor" | ||
HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
IUSE="systemd X" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86" | ||
|
||
RDEPEND=" | ||
>=dev-cpp/glibmm-2.46:2 | ||
>=dev-libs/glib-2.56.0:2 | ||
>=x11-libs/gtk+-3.22:3[X(+)] | ||
>=dev-cpp/gtkmm-3.3.18:3.0 | ||
>=dev-cpp/atkmm-2.28:0 | ||
>=gnome-base/libgtop-2.37.2:2= | ||
>=gui-libs/libhandy-1.0.0:1= | ||
>=gnome-base/librsvg-2.35:2 | ||
>=dev-libs/libxml2-2.0:2 | ||
X? ( >=x11-libs/libwnck-2.91.0:3 ) | ||
systemd? ( >=sys-apps/systemd-44:0= ) | ||
" | ||
# eautoreconf requires gnome-base/gnome-common | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
dev-util/glib-utils | ||
dev-util/itstool | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
>=sys-auth/polkit-0.114 | ||
" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114 | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
$(meson_use X wnck) | ||
$(meson_use systemd) | ||
) | ||
meson_src_configure | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_schemas_update | ||
} |