forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Hans de Graaff <[email protected]>
- Loading branch information
Showing
2 changed files
with
114 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST httpd-2.4.57.tar.bz2 7457022 BLAKE2B b33b51a741acd308ef4d4bdd2444d43eca9db68676fa67ec907eeea7384554f3f9a5608fc43dcf5819498264bbe36f176f30be9809474307642b70720036b88c SHA512 4d1e0a274ee90bdfb5f38d4a7d73a7367ed1c6388e26280e640014e49abc0df03683705b88dcfe2ec2da313dda4c7b4a3b86daffa1911f58e224eba89d82d155 | ||
DIST httpd-2.4.58.tar.bz2 7485817 BLAKE2B 2105b8fada99f1dda55201ed89ed5326f0edb078d352cbff44f02cde80d129b65b63e07366a9a744ba474be5687fa8d3d2d8ddc64ac914b47166607f3f4a9de2 SHA512 d6e73bf413a507ec16b621ff635e178206207a9e9810ce3944b3dc98d39cde8f225307110167fc9da5822175796c8cb66f98be5b9f0d8b76dcd83a401d39b2c1 | ||
DIST httpd-2.4.59.tar.bz2 7503198 BLAKE2B 836e3538a120d71c016149397a4efd61ae6acd8a8fb9d2ce117c7d86209c4b40c0be3c464007891f28c58182e9d40a8793abe9e94e642354492954af91d9878c SHA512 209da0bbac5e2564d4590302515b35495be6402273ff4024aa93e85e44554c95e053201d606383936425a41e1b5b97e6b40055dcbb385eb691a5029a6f3158c2 | ||
DIST httpd-2.4.60.tar.bz2 7508704 BLAKE2B d1b4d2e05edfe8b88f541e6fa8b5db73f37cc349a4037b493e57ae2f2e0bb84f92aad3ad3bc0bdbc454d2677091bbca283ebe752a9335fae6931ec65cc687326 SHA512 c1591389f76699beaa5d32b019729e25f1ed5b828311c82b52f1a4edd5d28b73e697958df384d7628b314521a831dbb0af418bc37cdf031cfe133e53c195d8ad |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,113 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit autotools toolchain-funcs | ||
|
||
DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm" | ||
HOMEPAGE="https://httpd.apache.org/" | ||
SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris" | ||
IUSE="ssl" | ||
RESTRICT="test" | ||
|
||
RDEPEND=">=dev-libs/apr-1.5.0:1= | ||
dev-libs/apr-util:1= | ||
dev-libs/expat | ||
dev-libs/libpcre2 | ||
virtual/libcrypt:= | ||
kernel_linux? ( sys-apps/util-linux ) | ||
ssl? ( dev-libs/openssl:0= )" | ||
DEPEND="${RDEPEND} | ||
dev-build/libtool" | ||
BDEPEND=" | ||
virtual/pkgconfig | ||
" | ||
|
||
S="${WORKDIR}/httpd-${PV}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.4.54-Makefile.patch" #459446 | ||
"${FILESDIR}/${PN}-2.4.54-no-which.patch" #844868 | ||
"${FILESDIR}/${PN}-2.4.54-libtool.patch" #858833 | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# This package really should upgrade to using pcre's .pc file. | ||
cat <<-\EOF > "${T}"/pcre2-config | ||
#!/usr/bin/env bash | ||
flags=() | ||
for flag; do | ||
if [[ ${flag} == "--version" ]]; then | ||
flags+=( --modversion ) | ||
else | ||
flags+=( "${flag}" ) | ||
fi | ||
done | ||
exec ${PKG_CONFIG} libpcre2-8 "${flags[@]}" | ||
EOF | ||
chmod a+x "${T}"/pcre2-config || die | ||
|
||
# Only here for libtool and which patches | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
# Silly check. | ||
tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no" | ||
|
||
tc-export PKG_CONFIG | ||
export ac_cv_path_PKGCONFIG="${PKG_CONFIG}" | ||
export ac_cv_prog_ac_ct_PCRE_CONFIG="${T}"/pcre2-config | ||
|
||
local myeconfargs=( | ||
--libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules | ||
--sbindir="${EPREFIX}"/usr/sbin | ||
--with-z="${EPREFIX}"/usr | ||
--with-apr="${ESYSROOT}"/usr | ||
--with-apr-util="${ESYSROOT}"/usr | ||
--without-pcre | ||
--with-pcre2="${T}"/pcre2-config | ||
$(use_enable ssl) | ||
$(usex ssl '--with-ssl="${EPREFIX}"/usr' '') | ||
) | ||
|
||
# econf overwrites the stuff from config.layout. | ||
econf "${myeconfargs[@]}" | ||
|
||
sed -i \ | ||
-e '/^LTFLAGS/s:--silent::' \ | ||
build/rules.mk build/config_vars.mk || die | ||
} | ||
|
||
src_compile() { | ||
emake -C support | ||
} | ||
|
||
src_install() { | ||
emake -C support DESTDIR="${D}" install | ||
dodoc CHANGES | ||
doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \ | ||
docs/man/{htcacheclean,rotatelogs}.8 | ||
|
||
# Providing compatiblity symlinks for #177697 (which we'll stop to install | ||
# at some point). | ||
pushd "${ED}"/usr/sbin >/dev/null || die | ||
local i | ||
for i in *; do | ||
dosym ${i} /usr/sbin/${i}2 | ||
done | ||
popd >/dev/null || die | ||
|
||
# Provide a symlink for ab-ssl | ||
if use ssl ; then | ||
dosym ab /usr/bin/ab-ssl | ||
dosym ab /usr/bin/ab2-ssl | ||
fi | ||
} |