Skip to content

Commit

Permalink
dev-python/expects: add version 0.8.0_rc3
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
Alex Brandt committed Oct 11, 2015
1 parent 6c2f0ee commit 8e1ebc6
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/expects/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST expects-0.4.2.tar.gz 23813 SHA256 b1e0b27141f784fe81a143153f23d3c8220fe8ec1
DIST expects-0.7.2.tar.gz 398201 SHA256 ed72a184c2453b4f244cf887ee4545ac40dc0d88a1a224eabf150980a88877a9 SHA512 55db29e2bbba881933bf5d28e38f2c1e1087b4e43f15359a2af40e91066658973244fac4dcaf7eca79d6006d78d232232acbd1a2fc03ec1df62223e1226fb94a WHIRLPOOL 9eae839eb607f29f57be70e39fc6adb02fa8b9038d070016c090f75dec5ce05528fd3d18ca72e1d2aaa4205df31f20521fc23ad741b1b73b54262ac273e9e14e
DIST expects-0.8.0_rc1.tar.gz 27424 SHA256 3822d470c3bebe749928e360e7bfdecf0ac6541717040de31cb265f1372dfb43 SHA512 5130b545164fdb8d8306b5d4fc3d83dcfaf9bb56428b9140def434bb1339b479568ba7aab88f5eedf646cadca12ee331163af5be0937633049baf695b309653b WHIRLPOOL 951ab90c1b3c143b3109676207c5f2a5480238555d10662f45c1a1336618c0e38307801aa0e61fc8bc978d333f3f44cd64da811742ebc65008815e635d0536d9
DIST expects-0.8.0_rc2.tar.gz 27307 SHA256 c7959a0b0f76a186b1d3687fbdedaf551f8bbbddbd66e5307c3a52c787a779de SHA512 6ae4553838ce4d27993772cec33f1e1a18d539af4a9b0f62f66ef1fb78464a46f5b76a420096d2d36881f4dc581b69e8f6c8783b89d794df753fdffab275cc33 WHIRLPOOL 04a04534571e8a15bcc2e1d7a9fc2b63bb772a8adaaf0b6239d375f1e5f750be7d7fa9fd10f5d84f017c4e3ad6274a7955e5b70928ee6eec7c199181169e5741
DIST expects-0.8.0_rc3.tar.gz 27478 SHA256 a2809c6c51cf18b3316102f21e9d14d195edfd34526cfcad7d959d592deacbd4 SHA512 2566ddfcb83bb3d58dbddcc881f2b743cca061057f77a52da49d3eb6c16dc1fafaca900734d7023550c85dfd0b86d433a9328daf5a989ab91757d83e9eaa4d81 WHIRLPOOL 7e6c81a27c2dd01d261731db6deefe0830515731dc485278bbf2d5de84a726cef7cea2a5ecd514ccda169167f7cb0ca32f7b02de95c6bdcbd23f26faf502b87d
40 changes: 40 additions & 0 deletions dev-python/expects/expects-0.8.0_rc3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )

inherit distutils-r1 vcs-snapshot

MY_PV=${PV/_/}

DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
HOMEPAGE="https://github.com/jaimegildesagredo/expects"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/mamba[${PYTHON_USEDEP}] )
"
RDEPEND=""

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
mamba || die "tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )

distutils-r1_python_install_all
}

0 comments on commit 8e1ebc6

Please sign in to comment.