Skip to content

Commit

Permalink
dev-haskell/snap-server: bump up to 1.0.1.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Sergei Trofimovich committed Feb 16, 2017
1 parent 2eb4896 commit 8e30490
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-haskell/snap-server/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST snap-server-0.9.5.1.tar.gz 59062 SHA256 af8f2344b90f701dd1924743d6073546206384d5a904a1338bb784e18c8d3ea3 SHA512 6320401c349fd7c376e798959274a9fb3aff49cf11c8b6d9edd513c6311c3daf23eeaf03087cda3c0afb11686203a422b0e36e8391d418b6b47e791505db50e3 WHIRLPOOL c51eda3a8430f3e47386c69b2974c3a1ae47a8ce53d173616ba24c675edd661ef23593af59d75d3488dc7e59ad24e99ca05a3040e081c965dbf8da9cc9c1cb85
DIST snap-server-1.0.1.1.tar.gz 73893 SHA256 878d83a815b9cc8f3d282ef6fafc441528b5f7819147f17f0c1b1f9904146c70 SHA512 bf3496123c07432cefedc6b03de5f335bb9b3a1e917bac45c0ee6b8d7529a3013d19d21433ce02d3f3caa2091abf0a4415b974470317804d70dfb8c9d46b33bd WHIRLPOOL eef257d1c3806e31ffe828e8cdea38e29c279a51ce1e89fa2ceccf623b1bdc4e0dcac6e1e990ecab4cef8c6c7878b668c5ae06f81f06a51abf3129f3a89795d2
1 change: 1 addition & 0 deletions dev-haskell/snap-server/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
<flag name="build-pong">Build a server that just returns "PONG"</flag>
<flag name="openssl">enable https support using <pkg>dev-haskell/hsopenssl</pkg></flag>
<flag name="portable">no non-haskell unportable code.</flag>
</use>
Expand Down
71 changes: 71 additions & 0 deletions dev-haskell/snap-server/snap-server-1.0.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

# ebuild generated by hackport 0.5.9999

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="A web server for the Snap Framework"
HOMEPAGE="http://snapframework.com/"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="build-pong debug openssl portable"

RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
>=dev-haskell/blaze-builder-0.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
>=dev-haskell/bytestring-builder-0.10.4:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
>=dev-haskell/case-insensitive-1.1:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
>=dev-haskell/clock-0.7.1:=[profile?] <dev-haskell/clock-0.8:=[profile?]
>=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.4:=[profile?]
>=dev-haskell/io-streams-haproxy-1.0:=[profile?] <dev-haskell/io-streams-haproxy-1.1:=[profile?]
>=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
>=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.7:=[profile?]
>=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
>=dev-haskell/snap-core-1.0:=[profile?] <dev-haskell/snap-core-1.1:=[profile?]
>=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
>=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
>=dev-lang/ghc-7.4.1:=
openssl? ( >=dev-haskell/hsopenssl-0.10.4:=[profile?] <dev-haskell/hsopenssl-0.12:=[profile?]
>=dev-haskell/openssl-streams-1.1:=[profile?] <dev-haskell/openssl-streams-1.3:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( >=dev-haskell/base16-bytestring-0.1 <dev-haskell/base16-bytestring-0.2
>=dev-haskell/http-common-0.7 <dev-haskell/http-common-0.9
>=dev-haskell/http-streams-0.7 <dev-haskell/http-streams-0.9
>=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
>=dev-haskell/monad-control-1.0 <dev-haskell/monad-control-1.1
>=dev-haskell/parallel-3 <dev-haskell/parallel-4
>=dev-haskell/quickcheck-2.3.0.2 <dev-haskell/quickcheck-3
>=dev-haskell/random-1.0 <dev-haskell/random-1.2
>=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-0.9
>=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4
>=dev-haskell/test-framework-quickcheck2-0.2.12.1 <dev-haskell/test-framework-quickcheck2-0.4
>=dev-haskell/threads-0.5 <dev-haskell/threads-0.6
>=dev-haskell/transformers-0.3 <dev-haskell/transformers-0.6 )
"

src_prepare() {
default

cabal_chdeps \
'directory >= 1.0 && < 1.3' 'directory >= 1.0' \
'directory >= 1.1 && < 1.3' 'directory >= 1.1'
}

src_configure() {
haskell-cabal_src_configure \
$(cabal_flag build-pong build-pong) \
$(cabal_flag debug debug) \
$(cabal_flag openssl openssl) \
$(cabal_flag portable portable)
}

0 comments on commit 8e30490

Please sign in to comment.